<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Trump Will &#039;No Longer Deal&#039; With UK Envoy Who Panned Him</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://www.khaosodenglish.com/xmlrpc.php" />
    <meta property="og:image" content="http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496.jpg" /><link rel="icon" type="image/png" href="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/11/fav1-1.png">
<!-- This site is optimized with the Yoast SEO plugin v11.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Trump Will &#039;No Longer Deal&#039; With UK Envoy Who Panned Him" />
<meta property="og:description" content="LONDON — President Donald Trump threatened Monday to cut off contact with Britain&#8217;s ambassador to the United States after leaked diplomatic cables revealed the envoy called the Trump administration &#8220;dysfunctional&#8221; and &#8220;inept.&#8221; The U.S. leader tweeted about Ambassador Kim Darroch a day after a British newspaper published the diplomat&#8217;s unflattering assessments of the current administration &hellip;" />
<meta property="og:url" content="http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/" />
<meta property="og:site_name" content="Khaosod English" />
<meta property="article:publisher" content="https://www.facebook.com/KhaosodEnglish/" />
<meta property="article:section" content="International" />
<meta property="article:published_time" content="2019-07-09T03:45:56+00:00" />
<meta property="og:image" content="http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="682" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="LONDON — President Donald Trump threatened Monday to cut off contact with Britain&#8217;s ambassador to the United States after leaked diplomatic cables revealed the envoy called the Trump administration &#8220;dysfunctional&#8221; and &#8220;inept.&#8221; The U.S. leader tweeted about Ambassador Kim Darroch a day after a British newspaper published the diplomat&#8217;s unflattering assessments of the current administration [&hellip;]" />
<meta name="twitter:title" content="Trump Will &#039;No Longer Deal&#039; With UK Envoy Who Panned Him" />
<meta name="twitter:site" content="@KhaosodEnglish" />
<meta name="twitter:image" content="http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496.jpg" />
<meta name="twitter:creator" content="@KhaosodEnglish" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://www.khaosodenglish.com/#organization","name":"","url":"http://www.khaosodenglish.com/","sameAs":["https://www.facebook.com/KhaosodEnglish/","https://www.instagram.com/khaosodenglish","https://www.youtube.com/user/khaosodenglish","https://twitter.com/KhaosodEnglish"]},{"@type":"WebSite","@id":"http://www.khaosodenglish.com/#website","url":"http://www.khaosodenglish.com/","name":"Khaosod English","publisher":{"@id":"http://www.khaosodenglish.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://www.khaosodenglish.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/#webpage","url":"http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/","inLanguage":"en-US","name":"Trump Will &#039;No Longer Deal&#039; With UK Envoy Who Panned Him","isPartOf":{"@id":"http://www.khaosodenglish.com/#website"},"image":{"@type":"ImageObject","@id":"http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/#primaryimage","url":"http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496.jpg","width":1024,"height":682,"caption":"President Donald Trump with first lady Melania Trump gestures upon arrival at Andrews Air Force Base, Md., Sunday, July 7, 2019. Photo: Manuel Balce Ceneta / AP"},"primaryImageOfPage":{"@id":"http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/#primaryimage"},"datePublished":"2019-07-09T03:45:56+00:00","dateModified":"2019-07-09T03:45:56+00:00"},{"@type":"Article","@id":"http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/#article","isPartOf":{"@id":"http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/#webpage"},"author":{"@id":"http://www.khaosodenglish.com/author/ap/#author","name":"Associated Press"},"publisher":{"@id":"http://www.khaosodenglish.com/#organization"},"headline":"Trump Will &#8216;No Longer Deal&#8217; With UK Envoy Who Panned Him","datePublished":"2019-07-09T03:45:56+00:00","dateModified":"2019-07-09T03:45:56+00:00","commentCount":0,"mainEntityOfPage":"http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/#webpage","image":{"@id":"http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/#primaryimage"},"articleSection":"International"},{"@type":"Person","@id":"http://www.khaosodenglish.com/author/ap/#author","name":"Associated Press","image":{"@type":"ImageObject","@id":"http://www.khaosodenglish.com/#personlogo","url":"http://2.gravatar.com/avatar/5e6a9fa95f61663e23555842683a8444?s=96&d=blank&r=pg","caption":"Associated Press"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Khaosod English &raquo; Feed" href="http://www.khaosodenglish.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Khaosod English &raquo; Comments Feed" href="http://www.khaosodenglish.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.khaosodenglish.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sb_instagram_styles-css'  href='http://www.khaosodenglish.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.12' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.8.3' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<link rel='stylesheet' id='parent-style-css'  href='http://www.khaosodenglish.com/wp-content/themes/Newspaper/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='http://www.khaosodenglish.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=618b370f2556e74c489bd6592378277f' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%2C500%2C800%2C800italic%2C900%2C900italic%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C600%2C600italic%2C800%2C800italic%2C900italic&#038;subset=gujarati%2Cthai&#038;ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://www.khaosodenglish.com/wp-content/themes/Newspaper-child/style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://www.khaosodenglish.com/wp-content/themes/Newspaper/includes/demos/local_news/demo_style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='http://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=726837bbdee984ffb331a234aadde124' type='text/css' media='all' />
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.8.3'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.8.3'></script>
<link rel='https://api.w.org/' href='http://www.khaosodenglish.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.khaosodenglish.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.khaosodenglish.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='http://www.khaosodenglish.com/?p=1464846572' />
<link rel="alternate" type="application/json+oembed" href="http://www.khaosodenglish.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2019%2F07%2F09%2Ftrump-will-no-longer-deal-with-uk-envoy-who-panned-him%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.khaosodenglish.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2019%2F07%2F09%2Ftrump-will-no-longer-deal-with-uk-envoy-who-panned-him%2F&#038;format=xml" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/kseng-1x1', [1, 1], 'div-gpt-ad-1553672219875-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>



<!-- page POST -->
 <!-- position 1 -->
 <!-- head -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_728x90_b1', [[250, 250], [300, 250], [336, 280]], 'div-gpt-ad-1515395484457-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

 <!-- position 2 -->
 <!-- head -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_336x280_b2', [[336, 280], [250, 250], [300, 250]], 'div-gpt-ad-1515395669610-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<!-- position 3 -->
<!-- head -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_728x90_b3', [[336, 280], [300, 250], [728, 90]], 'div-gpt-ad-1515395736307-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<!-- page HOME -->
<!-- position 3 -->
<!-- head -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/13542554/eng_home_336x280_b3', [[300, 250], [336, 280], [300, 600]], 'div-gpt-ad-1515394488762-0').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
	googletag.enableServices();
  });
</script>

<link rel="stylesheet" href="https://cdn.knightlab.com/libs/storymapjs/latest/css/storymap.css">
<script type="text/javascript" src="https://cdn.knightlab.com/libs/storymapjs/latest/js/storymap-min.js"></script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=425586894452122&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>    <script>
        window.tdb_globals = {"wpRestNonce":"b3ed3ce2fc","wpRestUrl":"http:\/\/www.khaosodenglish.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/","isAdminBarShowing":false,"origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"http:\/\/www.khaosodenglish.com\/wp-admin\/","wpRestNonce":"b3ed3ce2fc","wpRestUrl":"http:\/\/www.khaosodenglish.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="http://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    <link rel="amphtml" href="http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/amp/"><meta name="generator" content="Powered by Slider Revolution 5.4.8.3 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-65987233-1', 'auto');
  ga('send', 'pageview');

</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "http://www.khaosodenglish.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "http://www.khaosodenglish.com/category/news/international/",
                    "name": "International"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/",
                    "name": "Trump Will &#8216;No Longer Deal&#8217; With UK Envoy Who Panned Him"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="http://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-32x32.gif" sizes="32x32" />
<link rel="icon" href="http://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-192x192.gif" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-180x180.gif" />
<meta name="msapplication-TileImage" content="http://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-270x270.gif" />
<script type="text/javascript">function setREVStartSize(e){									
						try{ e.c=jQuery(e.c);var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;
							if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
						}catch(d){console.log("Failure at Presize of Slider:"+d)}						
					};</script>

<!-- Button style compiled by theme -->

<style>
    .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                  color: #d62532;
                }
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .sfHover > a,
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                  background-color: #d62532;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a,
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #d62532;
                }
                .tdm-btn-style1 {
					background-color: #d62532;
				}
				.tdm-btn-style2:before {
				    border-color: #d62532;
				}
				.tdm-btn-style2 {
				    color: #d62532;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #d62532;
                    -moz-box-shadow: 0 2px 16px #d62532;
                    box-shadow: 0 2px 16px #d62532;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #d62532;
                    -moz-box-shadow: 0 4px 26px #d62532;
                    box-shadow: 0 4px 26px #d62532;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-1464846572 single-format-standard trump-will-no-longer-deal-with-uk-envoy-who-panned-him global-block-template-1 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">


        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-bt-top-menu-container"><ul id="menu-bt-top-menu" class="td-mobile-main-menu"><li id="menu-item-1464768586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-1464768586"><a href="http://www.khaosodenglish.com/category/politics/">Politics</a></li>
<li id="menu-item-1464768584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1464768584"><a href="http://www.khaosodenglish.com/category/life/">Lifestyle<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://www.khaosodenglish.com/category/life/arts/">Arts &amp; Culture</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/life/embassy/">Embassy Corner</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/life/entertainment/">Entertainment</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/life/events/">Events</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/life/food/">Food</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/life/geek/">Geek</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/life/nightlife/">Nightlife</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/life/shopping/">Shopping</a></li>
</ul>
</li>
<li id="menu-item-1464768583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1464768583"><a href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime &#038; Legal<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/calamity/">Calamity</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/courts/">Courts</a></li>
	<li class="menu-item-0"><a href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/crime-crime/">Crime</a></li>
</ul>
</li>
<li id="menu-item-1464768582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768582"><a href="http://www.khaosodenglish.com/category/culture/net/">dot.Net</a></li>
<li id="menu-item-1464768595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768595"><a href="http://www.khaosodenglish.com/category/opinion/">Opinion</a></li>
<li id="menu-item-1464768589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768589"><a href="http://www.khaosodenglish.com/category/news/asean/">ASEAN</a></li>
<li id="menu-item-1464825008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464825008"><a href="http://www.khaosodenglish.com/category/videos/">Videos</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://www.khaosodenglish.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <style>
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    </style>
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 8
-->


<div class="td-header-wrap td-header-style-8 ">
    
    <div class="td-container ">
        <div class="td-header-sp-logo">
                    <a class="td-main-logo" href="http://www.khaosodenglish.com/">
            <img class="td-retina-data" data-retina="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/10/logo_300x284.gif" src="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/10/logo.gif" alt=""/>
            <span class="td-visual-hidden">Khaosod English</span>
        </a>
            </div>
    </div>
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container">
            <div class="td-header-row td-header-top-menu">
                
    <div class="top-bar-style-4">
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>    </div>        
<div class="td-header-sp-top-menu">


	<!-- td weather source: cache -->		<div class="td-weather-top-widget" id="td_top_weather_uid">
			<i class="td-icons few-clouds-d"></i>
			<div class="td-weather-now" data-block-uid="td_top_weather_uid">
				<span class="td-big-degrees">32.9</span>
				<span class="td-weather-unit">C</span>
			</div>
			<div class="td-weather-header">
				<div class="td-weather-city">Bangkok</div>
			</div>
		</div>
		        <div class="td_data_time">
            <div >

                Tuesday, July 9, 2019
            </div>
        </div>
    </div>
    </div>

<!-- LOGIN MODAL -->
            </div>
        </div>
    </div>
    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
            <div class="td-container">
                <div class="td-header-row td-header-main-menu">
                    <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-mobile" href="http://www.khaosodenglish.com/">
			<img class="td-retina-data" data-retina="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/10/logo_300x284.gif" src="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/10/logo.gif" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="http://www.khaosodenglish.com/">
			<img class="td-retina-data" data-retina="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/10/logo_300x284.gif" src="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/10/logo.gif" alt=""/>
		</a>
	    </div>
    <div class="menu-bt-top-menu-container"><ul id="menu-bt-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-1464768586"><a href="http://www.khaosodenglish.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5d2423df72198_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_1_5d2423df72198" ><script>var block_td_uid_1_5d2423df72198 = new tdBlock();
block_td_uid_1_5d2423df72198.id = "td_uid_1_5d2423df72198";
block_td_uid_1_5d2423df72198.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5d2423df72198_rand","tdc_css_class":"td_uid_1_5d2423df72198_rand","tdc_css_class_style":"td_uid_1_5d2423df72198_rand_style"}';
block_td_uid_1_5d2423df72198.td_column_number = "3";
block_td_uid_1_5d2423df72198.block_type = "td_block_mega_menu";
block_td_uid_1_5d2423df72198.post_count = "5";
block_td_uid_1_5d2423df72198.found_posts = "3605";
block_td_uid_1_5d2423df72198.header_color = "";
block_td_uid_1_5d2423df72198.ajax_pagination_infinite_stop = "";
block_td_uid_1_5d2423df72198.max_num_pages = "721";
tdBlocksArray.push(block_td_uid_1_5d2423df72198);
</script><div id=td_uid_1_5d2423df72198 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/politics/2019/07/08/fears-of-future-assaults-force-activists-to-seek-police-protection/" rel="bookmark" class="td-image-wrap" title="Fears of Future Assaults Force Activists to Seek Police Protection"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Fears of Future Assaults Force Activists to Seek Police Protection" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/66487985_674391479639876_4625822490965311488_o-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/politics/2019/07/08/fears-of-future-assaults-force-activists-to-seek-police-protection/" rel="bookmark" title="Fears of Future Assaults Force Activists to Seek Police Protection">Fears of Future Assaults Force Activists to Seek Police Protection</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/politics/2019/07/08/national-park-where-activist-disappeared-left-off-unesco-list/" rel="bookmark" class="td-image-wrap" title="National Park Where Activist Disappeared Left Off UNESCO List"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Porlajee “Billy” Rakchongcharoen poses with his wife and child. Photo: Courtesy of his family" title="National Park Where Activist Disappeared Left Off UNESCO List" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2018/06/14527717221452771738l-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/politics/2019/07/08/national-park-where-activist-disappeared-left-off-unesco-list/" rel="bookmark" title="National Park Where Activist Disappeared Left Off UNESCO List">National Park Where Activist Disappeared Left Off UNESCO List</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/politics/2019/07/05/new-cabinet-submitted-to-king-govt-says/" rel="bookmark" class="td-image-wrap" title="New Cabinet Submitted to King, Gov’t Says"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="New Cabinet Submitted to King, Gov’t Says" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/IMG_20190704100201000000-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/politics/2019/07/05/new-cabinet-submitted-to-king-govt-says/" rel="bookmark" title="New Cabinet Submitted to King, Gov’t Says">New Cabinet Submitted to King, Gov’t Says</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/politics/2019/07/05/future-forward-mps-don-local-dress-stir-debates/" rel="bookmark" class="td-image-wrap" title="Future Forward MPs Don Local Dress, Stir Debates"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Future Forward MPs Don Local Dress, Stir Debates" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/D23A717F-F930-4902-ABDB-B1697D69C990-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/politics/2019/07/05/future-forward-mps-don-local-dress-stir-debates/" rel="bookmark" title="Future Forward MPs Don Local Dress, Stir Debates">Future Forward MPs Don Local Dress, Stir Debates</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/politics/2019/07/04/watch-yourself-house-speaker-warns-mp-who-urged-justice-for-ja-new/" rel="bookmark" class="td-image-wrap" title="‘Watch Yourself,’ House Speaker Warns MP Who Urged Justice for Ja New"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="‘Watch Yourself,’ House Speaker Warns MP Who Urged Justice for Ja New" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/1561709544374-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/politics/2019/07/04/watch-yourself-house-speaker-warns-mp-who-urged-justice-for-ja-new/" rel="bookmark" title="‘Watch Yourself,’ House Speaker Warns MP Who Urged Justice for Ja New">‘Watch Yourself,’ House Speaker Warns MP Who Urged Justice for Ja&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5d2423df72198" data-td_block_id="td_uid_1_5d2423df72198"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5d2423df72198" data-td_block_id="td_uid_1_5d2423df72198"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768584"><a href="http://www.khaosodenglish.com/category/life/">Lifestyle</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5d2423df9a8a7_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_2_5d2423df9a8a7" ><script>var block_td_uid_2_5d2423df9a8a7 = new tdBlock();
block_td_uid_2_5d2423df9a8a7.id = "td_uid_2_5d2423df9a8a7";
block_td_uid_2_5d2423df9a8a7.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"42","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_2_5d2423df9a8a7_rand","tdc_css_class":"td_uid_2_5d2423df9a8a7_rand","tdc_css_class_style":"td_uid_2_5d2423df9a8a7_rand_style"}';
block_td_uid_2_5d2423df9a8a7.td_column_number = "3";
block_td_uid_2_5d2423df9a8a7.block_type = "td_block_mega_menu";
block_td_uid_2_5d2423df9a8a7.post_count = "4";
block_td_uid_2_5d2423df9a8a7.found_posts = "3700";
block_td_uid_2_5d2423df9a8a7.header_color = "";
block_td_uid_2_5d2423df9a8a7.ajax_pagination_infinite_stop = "";
block_td_uid_2_5d2423df9a8a7.max_num_pages = "925";
tdBlocksArray.push(block_td_uid_2_5d2423df9a8a7);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_2_5d2423df9a8a7" id="td_uid_3_5d2423dfb0009" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="" href="http://www.khaosodenglish.com/category/life/">All</a><a class="mega-menu-sub-cat-td_uid_2_5d2423df9a8a7"  id="td_uid_4_5d2423dfb013e" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="128" href="http://www.khaosodenglish.com/category/life/arts/">Arts &amp; Culture</a><a class="mega-menu-sub-cat-td_uid_2_5d2423df9a8a7"  id="td_uid_5_5d2423dfb02a4" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="587" href="http://www.khaosodenglish.com/category/life/embassy/">Embassy Corner</a><a class="mega-menu-sub-cat-td_uid_2_5d2423df9a8a7"  id="td_uid_6_5d2423dfb03fb" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="127" href="http://www.khaosodenglish.com/category/life/entertainment/">Entertainment</a><a class="mega-menu-sub-cat-td_uid_2_5d2423df9a8a7"  id="td_uid_7_5d2423dfb057c" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="123" href="http://www.khaosodenglish.com/category/life/events/">Events</a><a class="mega-menu-sub-cat-td_uid_2_5d2423df9a8a7"  id="td_uid_8_5d2423dfb06cf" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="44" href="http://www.khaosodenglish.com/category/life/food/">Food</a><a class="mega-menu-sub-cat-td_uid_2_5d2423df9a8a7"  id="td_uid_9_5d2423dfb082b" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="53" href="http://www.khaosodenglish.com/category/life/geek/">Geek</a><a class="mega-menu-sub-cat-td_uid_2_5d2423df9a8a7"  id="td_uid_10_5d2423dfb098d" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="130" href="http://www.khaosodenglish.com/category/life/nightlife/">Nightlife</a><a class="mega-menu-sub-cat-td_uid_2_5d2423df9a8a7"  id="td_uid_11_5d2423dfb0ade" data-td_block_id="td_uid_2_5d2423df9a8a7" data-td_filter_value="232" href="http://www.khaosodenglish.com/category/life/shopping/">Shopping</a></div></div><div id=td_uid_2_5d2423df9a8a7 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/culture/net/2019/07/08/crazy-rich-bangkokians-viral-instagram-bougiebangkokgirl-gets-political/" rel="bookmark" class="td-image-wrap" title="Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Image: BougieBangkokGirl / Instagram" title="Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/Screen-Shot-2019-07-08-at-5.55.26-PM-1-218x150.png"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/culture/net/2019/07/08/crazy-rich-bangkokians-viral-instagram-bougiebangkokgirl-gets-political/" rel="bookmark" title="Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political">Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/life/2019/07/08/watch-the-best-of-german-flicks-at-german-film-week/" rel="bookmark" class="td-image-wrap" title="Watch the Best of German Flicks at German Film Week"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="A still from “The Young Karl Marx.” Image: Neue Visionen Filmverleih" title="Watch the Best of German Flicks at German Film Week" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/GERMANFILMFEST_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/life/2019/07/08/watch-the-best-of-german-flicks-at-german-film-week/" rel="bookmark" title="Watch the Best of German Flicks at German Film Week">Watch the Best of German Flicks at German Film Week</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/2019/07/06/royal-barge-procession-set-for-oct-24/" rel="bookmark" class="td-image-wrap" title="Royal Barge Procession Set for Oct. 24"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Royal Barge Procession Set for Oct. 24" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/58571192_2455205161165068_7895381300121436160_o-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/2019/07/06/royal-barge-procession-set-for-oct-24/" rel="bookmark" title="Royal Barge Procession Set for Oct. 24">Royal Barge Procession Set for Oct. 24</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/life/2019/07/05/making-a-blockbuster-thai-film-the-studio-behind-pee-mak-and-bad-genius/" rel="bookmark" class="td-image-wrap" title="Making A Blockbuster Thai Film: The Studio Behind “Pee Mak” and “Bad Genius”"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Left: A still from “Pee Mak.” Right: A still from “Bad Genius.” Photo: GDH 555" title="Making A Blockbuster Thai Film: The Studio Behind “Pee Mak” and “Bad Genius”" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/GDH_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/life/2019/07/05/making-a-blockbuster-thai-film-the-studio-behind-pee-mak-and-bad-genius/" rel="bookmark" title="Making A Blockbuster Thai Film: The Studio Behind “Pee Mak” and “Bad Genius”">Making A Blockbuster Thai Film: The Studio Behind “Pee Mak” and&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5d2423df9a8a7" data-td_block_id="td_uid_2_5d2423df9a8a7"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5d2423df9a8a7" data-td_block_id="td_uid_2_5d2423df9a8a7"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768583"><a href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime &#038; Legal</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_12_5d2423dfb5935_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_12_5d2423dfb5935" ><script>var block_td_uid_12_5d2423dfb5935 = new tdBlock();
block_td_uid_12_5d2423dfb5935.id = "td_uid_12_5d2423dfb5935";
block_td_uid_12_5d2423dfb5935.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"41","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_12_5d2423dfb5935_rand","tdc_css_class":"td_uid_12_5d2423dfb5935_rand","tdc_css_class_style":"td_uid_12_5d2423dfb5935_rand_style"}';
block_td_uid_12_5d2423dfb5935.td_column_number = "3";
block_td_uid_12_5d2423dfb5935.block_type = "td_block_mega_menu";
block_td_uid_12_5d2423dfb5935.post_count = "4";
block_td_uid_12_5d2423dfb5935.found_posts = "3307";
block_td_uid_12_5d2423dfb5935.header_color = "";
block_td_uid_12_5d2423dfb5935.ajax_pagination_infinite_stop = "";
block_td_uid_12_5d2423dfb5935.max_num_pages = "827";
tdBlocksArray.push(block_td_uid_12_5d2423dfb5935);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_12_5d2423dfb5935" id="td_uid_13_5d2423dfc73ae" data-td_block_id="td_uid_12_5d2423dfb5935" data-td_filter_value="" href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/">All</a><a class="mega-menu-sub-cat-td_uid_12_5d2423dfb5935"  id="td_uid_14_5d2423dfc7531" data-td_block_id="td_uid_12_5d2423dfb5935" data-td_filter_value="191" href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/calamity/">Calamity</a><a class="mega-menu-sub-cat-td_uid_12_5d2423dfb5935"  id="td_uid_15_5d2423dfc76db" data-td_block_id="td_uid_12_5d2423dfb5935" data-td_filter_value="173" href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/courts/">Courts</a><a class="mega-menu-sub-cat-td_uid_12_5d2423dfb5935"  id="td_uid_16_5d2423dfc78a9" data-td_block_id="td_uid_12_5d2423dfb5935" data-td_filter_value="179" href="http://www.khaosodenglish.com/category/news/crimecourtscalamity/crime-crime/">Crime</a></div></div><div id=td_uid_12_5d2423dfb5935 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/crimecourtscalamity/2019/07/08/high-schooler-kicked-into-coma-during-sotus-hazing/" rel="bookmark" class="td-image-wrap" title="High Schooler Kicked Into Coma During SOTUS Hazing, Family Says"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="High Schooler Kicked Into Coma During SOTUS Hazing, Family Says" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/bracelethazing-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/crimecourtscalamity/2019/07/08/high-schooler-kicked-into-coma-during-sotus-hazing/" rel="bookmark" title="High Schooler Kicked Into Coma During SOTUS Hazing, Family Says">High Schooler Kicked Into Coma During SOTUS Hazing, Family Says</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/crimecourtscalamity/2019/07/07/five-baby-hornbills-rescued-from-wildlife-traders-house/" rel="bookmark" class="td-image-wrap" title="Five Baby Hornbills Rescued From Wildlife Trader’s House"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Five Baby Hornbills Rescued From Wildlife Trader’s House" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/65944542_460285074771834_833465406248189952_n-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/crimecourtscalamity/2019/07/07/five-baby-hornbills-rescued-from-wildlife-traders-house/" rel="bookmark" title="Five Baby Hornbills Rescued From Wildlife Trader’s House">Five Baby Hornbills Rescued From Wildlife Trader’s House</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/crimecourtscalamity/2019/07/05/south-korean-actress-charged-for-catching-giant-clams/" rel="bookmark" class="td-image-wrap" title="South Korean Actress Charged for Catching Giant Clams"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="South Korean Actress Charged for Catching Giant Clams" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/korean01-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/crimecourtscalamity/2019/07/05/south-korean-actress-charged-for-catching-giant-clams/" rel="bookmark" title="South Korean Actress Charged for Catching Giant Clams">South Korean Actress Charged for Catching Giant Clams</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/crimecourtscalamity/2019/07/04/fugitive-busted-after-busting-dance-moves-on-facebook-live/" rel="bookmark" class="td-image-wrap" title="Fugitive Busted After Busting Dance Moves on Facebook Live"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Fugitive Busted After Busting Dance Moves on Facebook Live" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/cover-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/crimecourtscalamity/2019/07/04/fugitive-busted-after-busting-dance-moves-on-facebook-live/" rel="bookmark" title="Fugitive Busted After Busting Dance Moves on Facebook Live">Fugitive Busted After Busting Dance Moves on Facebook Live</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_12_5d2423dfb5935" data-td_block_id="td_uid_12_5d2423dfb5935"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_12_5d2423dfb5935" data-td_block_id="td_uid_12_5d2423dfb5935"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768582"><a href="http://www.khaosodenglish.com/category/culture/net/">dot.Net</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_17_5d2423dfcc33e_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_17_5d2423dfcc33e" ><script>var block_td_uid_17_5d2423dfcc33e = new tdBlock();
block_td_uid_17_5d2423dfcc33e.id = "td_uid_17_5d2423dfcc33e";
block_td_uid_17_5d2423dfcc33e.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"43","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_17_5d2423dfcc33e_rand","tdc_css_class":"td_uid_17_5d2423dfcc33e_rand","tdc_css_class_style":"td_uid_17_5d2423dfcc33e_rand_style"}';
block_td_uid_17_5d2423dfcc33e.td_column_number = "3";
block_td_uid_17_5d2423dfcc33e.block_type = "td_block_mega_menu";
block_td_uid_17_5d2423dfcc33e.post_count = "5";
block_td_uid_17_5d2423dfcc33e.found_posts = "455";
block_td_uid_17_5d2423dfcc33e.header_color = "";
block_td_uid_17_5d2423dfcc33e.ajax_pagination_infinite_stop = "";
block_td_uid_17_5d2423dfcc33e.max_num_pages = "91";
tdBlocksArray.push(block_td_uid_17_5d2423dfcc33e);
</script><div id=td_uid_17_5d2423dfcc33e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/culture/net/2019/07/08/crazy-rich-bangkokians-viral-instagram-bougiebangkokgirl-gets-political/" rel="bookmark" class="td-image-wrap" title="Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Image: BougieBangkokGirl / Instagram" title="Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/Screen-Shot-2019-07-08-at-5.55.26-PM-1-218x150.png"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/culture/net/2019/07/08/crazy-rich-bangkokians-viral-instagram-bougiebangkokgirl-gets-political/" rel="bookmark" title="Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political">Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/culture/net/2019/07/04/thai-mental-health-dept-battles-earworms-after-chip-n-dale-song/" rel="bookmark" class="td-image-wrap" title="Thai Mental Health Dept. Battles Earworms After Chip ‘N’ Dale Song"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Mickey isn’t pleased. Images: Mickey Mouse / YouTube" title="Thai Mental Health Dept. Battles Earworms After Chip ‘N’ Dale Song" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/done-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/culture/net/2019/07/04/thai-mental-health-dept-battles-earworms-after-chip-n-dale-song/" rel="bookmark" title="Thai Mental Health Dept. Battles Earworms After Chip ‘N’ Dale Song">Thai Mental Health Dept. Battles Earworms After Chip ‘N’ Dale Song</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/featured/2019/07/02/chip-n-dales-thai-song-paddles-into-nations-ears/" rel="bookmark" class="td-image-wrap" title="Chip ‘N’ Dale’s Thai Song Paddles Into Nation’s Ears"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Chip ‘n’ Dale are two brothers, selling stuff in the khlong. Image: Mickey Mouse / YouTube" title="Chip ‘N’ Dale’s Thai Song Paddles Into Nation’s Ears" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/chip-n-dale-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/featured/2019/07/02/chip-n-dales-thai-song-paddles-into-nations-ears/" rel="bookmark" title="Chip ‘N’ Dale’s Thai Song Paddles Into Nation’s Ears">Chip ‘N’ Dale’s Thai Song Paddles Into Nation’s Ears</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/featured/2019/07/01/thai-canadian-fan-favorite-wins-miss-universe-thailand-2019/" rel="bookmark" class="td-image-wrap" title="Thai-Canadian Fan Favorite Wins Miss Universe Thailand 2019"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Paweensuda “Fahsai” Drouin is crowned Miss Universe Thailand 2013 on June 29, 2019." title="Thai-Canadian Fan Favorite Wins Miss Universe Thailand 2019" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/20190629225628_IMG_0762-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/featured/2019/07/01/thai-canadian-fan-favorite-wins-miss-universe-thailand-2019/" rel="bookmark" title="Thai-Canadian Fan Favorite Wins Miss Universe Thailand 2019">Thai-Canadian Fan Favorite Wins Miss Universe Thailand 2019</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/culture/net/2019/06/27/thai-fans-mourn-divorce-of-dream-k-drama-couple-from-descendants-of-the-sun/" rel="bookmark" class="td-image-wrap" title="Thai Fans Mourn Divorce of Dream K-Drama Couple from ‘Descendants of the Sun’"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Song Joong Ki and Song Hye Kyo at their Oct. 31, 2017 wedding." title="Thai Fans Mourn Divorce of Dream K-Drama Couple from ‘Descendants of the Sun’" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/06/songsong-001-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/culture/net/2019/06/27/thai-fans-mourn-divorce-of-dream-k-drama-couple-from-descendants-of-the-sun/" rel="bookmark" title="Thai Fans Mourn Divorce of Dream K-Drama Couple from ‘Descendants of the Sun’">Thai Fans Mourn Divorce of Dream K-Drama Couple from ‘Descendants of&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_17_5d2423dfcc33e" data-td_block_id="td_uid_17_5d2423dfcc33e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_17_5d2423dfcc33e" data-td_block_id="td_uid_17_5d2423dfcc33e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768595"><a href="http://www.khaosodenglish.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_18_5d2423dfd5287_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_18_5d2423dfd5287" ><script>var block_td_uid_18_5d2423dfd5287 = new tdBlock();
block_td_uid_18_5d2423dfd5287.id = "td_uid_18_5d2423dfd5287";
block_td_uid_18_5d2423dfd5287.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"47","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_5d2423dfd5287_rand","tdc_css_class":"td_uid_18_5d2423dfd5287_rand","tdc_css_class_style":"td_uid_18_5d2423dfd5287_rand_style"}';
block_td_uid_18_5d2423dfd5287.td_column_number = "3";
block_td_uid_18_5d2423dfd5287.block_type = "td_block_mega_menu";
block_td_uid_18_5d2423dfd5287.post_count = "5";
block_td_uid_18_5d2423dfd5287.found_posts = "358";
block_td_uid_18_5d2423dfd5287.header_color = "";
block_td_uid_18_5d2423dfd5287.ajax_pagination_infinite_stop = "";
block_td_uid_18_5d2423dfd5287.max_num_pages = "72";
tdBlocksArray.push(block_td_uid_18_5d2423dfd5287);
</script><div id=td_uid_18_5d2423dfd5287 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/opinion/2019/07/04/opinion-thailands-slippery-road-of-political-hatred/" rel="bookmark" class="td-image-wrap" title="Opinion: Thailand’s Slippery Road of Political Hatred"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Opinion: Thailand’s Slippery Road of Political Hatred" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/205ba436a99fc277aa314ad7d00e643abe5d3796c44a4eb740649cf9bbd2a540-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/opinion/2019/07/04/opinion-thailands-slippery-road-of-political-hatred/" rel="bookmark" title="Opinion: Thailand’s Slippery Road of Political Hatred">Opinion: Thailand’s Slippery Road of Political Hatred</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/opinion/2019/06/28/opinion-goodbye-the-nation-newspaper/" rel="bookmark" class="td-image-wrap" title="Opinion: Goodbye The Nation Newspaper"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Opinion: Goodbye The Nation Newspaper" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/06/newbeginningnation-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/opinion/2019/06/28/opinion-goodbye-the-nation-newspaper/" rel="bookmark" title="Opinion: Goodbye The Nation Newspaper">Opinion: Goodbye The Nation Newspaper</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/opinion/2019/06/23/opinion-learning-from-thailands-forgotten-former-national-day/" rel="bookmark" class="td-image-wrap" title="Opinion: Learning from Thailand’s Forgotten, Former National Day"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Inauguration of Democracy Monument on June 24, 1940. The ceremony was presided by Prime Minister Field Marshall Plaek Pibulsongkram. Photo: National Archive." title="Opinion: Learning from Thailand’s Forgotten, Former National Day" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/06/15612551819734171584766688204643-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/opinion/2019/06/23/opinion-learning-from-thailands-forgotten-former-national-day/" rel="bookmark" title="Opinion: Learning from Thailand’s Forgotten, Former National Day">Opinion: Learning from Thailand’s Forgotten, Former National Day</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/opinion/2019/06/22/opinion-us-should-pursue-cooperation-with-china-not-unilateralism/" rel="bookmark" class="td-image-wrap" title="Opinion: US Should Seek Cooperation With China, Not Unilateralism"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Opinion: US Should Seek Cooperation With China, Not Unilateralism" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/06/Trump_US_China.JPG-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/opinion/2019/06/22/opinion-us-should-pursue-cooperation-with-china-not-unilateralism/" rel="bookmark" title="Opinion: US Should Seek Cooperation With China, Not Unilateralism">Opinion: US Should Seek Cooperation With China, Not Unilateralism</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/opinion/2019/06/16/opinion-protests-in-hong-kong-empty-streets-in-bangkok/" rel="bookmark" class="td-image-wrap" title="Opinion: Protests in Hong Kong, Empty Streets in Bangkok"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Protesters march on the streets against an extradition bill in Hong Kong on Sunday, June 16, 2019. Photo:Vincent Yu / AP" title="Opinion: Protests in Hong Kong, Empty Streets in Bangkok" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/06/AP19167250406656-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/opinion/2019/06/16/opinion-protests-in-hong-kong-empty-streets-in-bangkok/" rel="bookmark" title="Opinion: Protests in Hong Kong, Empty Streets in Bangkok">Opinion: Protests in Hong Kong, Empty Streets in Bangkok</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_5d2423dfd5287" data-td_block_id="td_uid_18_5d2423dfd5287"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_18_5d2423dfd5287" data-td_block_id="td_uid_18_5d2423dfd5287"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768589"><a href="http://www.khaosodenglish.com/category/news/asean/">ASEAN</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_19_5d2423dfdd89d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_19_5d2423dfdd89d" ><script>var block_td_uid_19_5d2423dfdd89d = new tdBlock();
block_td_uid_19_5d2423dfdd89d.id = "td_uid_19_5d2423dfdd89d";
block_td_uid_19_5d2423dfdd89d.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"52","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_19_5d2423dfdd89d_rand","tdc_css_class":"td_uid_19_5d2423dfdd89d_rand","tdc_css_class_style":"td_uid_19_5d2423dfdd89d_rand_style"}';
block_td_uid_19_5d2423dfdd89d.td_column_number = "3";
block_td_uid_19_5d2423dfdd89d.block_type = "td_block_mega_menu";
block_td_uid_19_5d2423dfdd89d.post_count = "5";
block_td_uid_19_5d2423dfdd89d.found_posts = "1351";
block_td_uid_19_5d2423dfdd89d.header_color = "";
block_td_uid_19_5d2423dfdd89d.ajax_pagination_infinite_stop = "";
block_td_uid_19_5d2423dfdd89d.max_num_pages = "271";
tdBlocksArray.push(block_td_uid_19_5d2423dfdd89d);
</script><div id=td_uid_19_5d2423dfdd89d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/asean/2019/06/25/forget-boring-summit-and-head-to-asean-film-fest/" rel="bookmark" class="td-image-wrap" title="Forget Boring Summit and Head to ASEAN Film Fest"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Forget Boring Summit and Head to ASEAN Film Fest" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/06/the-only-mom-2019-movie-still-8t5hry-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/asean/2019/06/25/forget-boring-summit-and-head-to-asean-film-fest/" rel="bookmark" title="Forget Boring Summit and Head to ASEAN Film Fest">Forget Boring Summit and Head to ASEAN Film Fest</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/asean/2019/04/23/myanmar-court-rejects-appeal-of-jailed-reuters-reporters-2/" rel="bookmark" class="td-image-wrap" title="Myanmar Court Rejects Appeal of Jailed Reuters Reporters"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Myanmar Court Rejects Appeal of Jailed Reuters Reporters" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/01/AP19011289451341-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/asean/2019/04/23/myanmar-court-rejects-appeal-of-jailed-reuters-reporters-2/" rel="bookmark" title="Myanmar Court Rejects Appeal of Jailed Reuters Reporters">Myanmar Court Rejects Appeal of Jailed Reuters Reporters</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/asean/2019/04/23/powerful-quake-hits-philippines-day-after-deadly-temblor/" rel="bookmark" class="td-image-wrap" title="Powerful Quake Hits Philippines Day After Deadly Temblor"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Damaged St. Catherine church is seen Tuesday following a 6.1 magnitude earthquake that also caused the collapse of a commercial building in Porac township, Pampanga province, north of Manila, Philippines. Photo: Bullit Marquez / Associated Press" title="Powerful Quake Hits Philippines Day After Deadly Temblor" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/04/1024-preview-30-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/asean/2019/04/23/powerful-quake-hits-philippines-day-after-deadly-temblor/" rel="bookmark" title="Powerful Quake Hits Philippines Day After Deadly Temblor">Powerful Quake Hits Philippines Day After Deadly Temblor</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/asean/2019/04/12/malaysia-revives-china-backed-rail-link/" rel="bookmark" class="td-image-wrap" title="Malaysia Revives China-Backed Rail Link"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="In this Aug. 30, 2018, file photo, a security official stands near a display showing different models of Chinese trains at a maintenance yard during a media tour ahead of the 2018 Forum on China-Africa Cooperation in Beijing. Photo: Mark Schiefelbein / Associated Press" title="Malaysia Revives China-Backed Rail Link" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/04/1024-preview-26-1-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/asean/2019/04/12/malaysia-revives-china-backed-rail-link/" rel="bookmark" title="Malaysia Revives China-Backed Rail Link">Malaysia Revives China-Backed Rail Link</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/asean/2019/04/10/singapore-pm-defends-law-combating-fake-online-news/" rel="bookmark" class="td-image-wrap" title="Singapore PM Defends Law Combating Fake Online News"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Malaysian Prime Minister Mahathir Mohamad, right, shakes hands with Singaporean Prime Minister Lee Hsien Loong Tuesday after a press conference in Putrajaya, Malaysia. Photo: Vincent Thian / Associated Press" title="Singapore PM Defends Law Combating Fake Online News" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/04/1024-preview-26-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/asean/2019/04/10/singapore-pm-defends-law-combating-fake-online-news/" rel="bookmark" title="Singapore PM Defends Law Combating Fake Online News">Singapore PM Defends Law Combating Fake Online News</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_19_5d2423dfdd89d" data-td_block_id="td_uid_19_5d2423dfdd89d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_19_5d2423dfdd89d" data-td_block_id="td_uid_19_5d2423dfdd89d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464825008"><a href="http://www.khaosodenglish.com/category/videos/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5d2423dfeaf0a_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_20_5d2423dfeaf0a" ><script>var block_td_uid_20_5d2423dfeaf0a = new tdBlock();
block_td_uid_20_5d2423dfeaf0a.id = "td_uid_20_5d2423dfeaf0a";
block_td_uid_20_5d2423dfeaf0a.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"46","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_20_5d2423dfeaf0a_rand","tdc_css_class":"td_uid_20_5d2423dfeaf0a_rand","tdc_css_class_style":"td_uid_20_5d2423dfeaf0a_rand_style"}';
block_td_uid_20_5d2423dfeaf0a.td_column_number = "3";
block_td_uid_20_5d2423dfeaf0a.block_type = "td_block_mega_menu";
block_td_uid_20_5d2423dfeaf0a.post_count = "5";
block_td_uid_20_5d2423dfeaf0a.found_posts = "232";
block_td_uid_20_5d2423dfeaf0a.header_color = "";
block_td_uid_20_5d2423dfeaf0a.ajax_pagination_infinite_stop = "";
block_td_uid_20_5d2423dfeaf0a.max_num_pages = "47";
tdBlocksArray.push(block_td_uid_20_5d2423dfeaf0a);
</script><div id=td_uid_20_5d2423dfeaf0a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/videos/2019/06/21/smooth-criminal-animal-control-lugs-python-to-policeman-with-snake-phobia-video/" rel="bookmark" class="td-image-wrap" title="Smooth Criminal: Animal Control Lugs Python to Policeman with Snake Phobia (Video)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Somkiat Khunsaen brings a python on June 21, 2019 to the Saraburi City Provincial Police Station." title="Smooth Criminal: Animal Control Lugs Python to Policeman with Snake Phobia (Video)" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/06/hed-3-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/videos/2019/06/21/smooth-criminal-animal-control-lugs-python-to-policeman-with-snake-phobia-video/" rel="bookmark" title="Smooth Criminal: Animal Control Lugs Python to Policeman with Snake Phobia (Video)">Smooth Criminal: Animal Control Lugs Python to Policeman with Snake Phobia&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/life/arts/2019/04/25/stand-under-van-goghs-starry-night-at-bangkok-exhibition-video/" rel="bookmark" class="td-image-wrap" title="Stand Under Van Gogh’s Starry Night at Bangkok Exhibition (Video)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Stand Under Van Gogh’s Starry Night at Bangkok Exhibition (Video)" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/04/maxresdefault-3-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="http://www.khaosodenglish.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/life/arts/2019/04/25/stand-under-van-goghs-starry-night-at-bangkok-exhibition-video/" rel="bookmark" title="Stand Under Van Gogh’s Starry Night at Bangkok Exhibition (Video)">Stand Under Van Gogh’s Starry Night at Bangkok Exhibition (Video)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/videos/2019/04/24/the-running-of-the-kwais-trangs-annual-buffalo-bacchanal/" rel="bookmark" class="td-image-wrap" title="The Running of the Kwais: Trang’s Annual Buffalo Bacchanal"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="The Running of the Kwais: Trang’s Annual Buffalo Bacchanal" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/04/KWAI-16-9-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/videos/2019/04/24/the-running-of-the-kwais-trangs-annual-buffalo-bacchanal/" rel="bookmark" title="The Running of the Kwais: Trang’s Annual Buffalo Bacchanal">The Running of the Kwais: Trang’s Annual Buffalo Bacchanal</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/videos/2019/04/20/khaosod-english-talks-to-hawkeye-the-most-humble-avenger/" rel="bookmark" class="td-image-wrap" title="Khaosod English Talks to Hawkeye, the Most Humble Avenger"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Khaosod English Talks to Hawkeye, the Most Humble Avenger" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/04/Hawkeye-Cover-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/videos/2019/04/20/khaosod-english-talks-to-hawkeye-the-most-humble-avenger/" rel="bookmark" title="Khaosod English Talks to Hawkeye, the Most Humble Avenger">Khaosod English Talks to Hawkeye, the Most Humble Avenger</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/opinion/2019/04/17/an-ode-to-notre-dame-for-now-video/" rel="bookmark" class="td-image-wrap" title="An Ode to Notre Dame, For Now (Video)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="An Ode to Notre Dame, For Now (Video)" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/04/AP19105658700895-218x150.jpeg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/opinion/2019/04/17/an-ode-to-notre-dame-for-now-video/" rel="bookmark" title="An Ode to Notre Dame, For Now (Video)">An Ode to Notre Dame, For Now (Video)</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5d2423dfeaf0a" data-td_block_id="td_uid_20_5d2423dfeaf0a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5d2423dfeaf0a" data-td_block_id="td_uid_20_5d2423dfeaf0a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
</ul></div></div>


    <div class="td-search-wrapper">
        <div id="td-top-search">
            <!-- Search -->
            <div class="header-search-wrap">
                <div class="dropdown header-search">
                    <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                </div>
            </div>
        </div>
    </div>
                </div>
            </div>
        </div>
    </div>

            <div class="td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_21_5d2423dff4167_rand td_block_template_1"><script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/khaosod-khaosodeng/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script> </div>
</div>                </div>
            </div>
        </div>
    
</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://www.khaosodenglish.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in International" class="entry-crumb" href="http://www.khaosodenglish.com/category/news/international/">International</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Trump Will &#8216;No Longer Deal&#8217; With UK Envoy Who Panned Him</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-1464846572" class="post-1464846572 post type-post status-publish format-standard has-post-thumbnail category-international" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  style="background-color:#d52432; color:#fff; border-color:#d52432;" href="http://www.khaosodenglish.com/category/news/">News</a></li><li class="entry-category"><a  style="background-color:#432b79; color:#fff; border-color:#432b79;" href="http://www.khaosodenglish.com/category/news/international/">International</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Trump Will &#8216;No Longer Deal&#8217; With UK Envoy Who Panned Him</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://www.khaosodenglish.com/author/ap/">Associated Press</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2019-07-09T10:45:56+00:00" >July 9, 2019 10:45 am</time></span>                                                        </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2019%2F07%2F09%2Ftrump-will-no-longer-deal-with-uk-envoy-who-panned-him%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him&url=http%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2019%2F07%2F09%2Ftrump-will-no-longer-deal-with-uk-envoy-who-panned-him%2F&via=KhaosodEnglish">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him%0D%0Ahttp://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/">
                                        <div class="td-social-but-icon"><i class="td-icon-line"></i></div>
                                        <div class="td-social-but-text">LINE</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him %0A%0A http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/&amp;media=http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496.jpg&description=Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/&title=Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/">
                                        <div class="td-social-but-icon"><i class="td-icon-vk"></i></div>
                                        <div class="td-social-but-text">VK</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><figure><img width="696" height="464" class="entry-thumb" src="http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496-696x464.jpg" srcset="http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496-696x464.jpg 696w, http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496-300x200.jpg 300w, http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496-768x512.jpg 768w, http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496.jpg 1024w, http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496-500x333.jpg 500w, http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496-631x420.jpg 631w" sizes="(max-width: 696px) 100vw, 696px" alt="President Donald Trump with first lady Melania Trump gestures upon arrival at Andrews Air Force Base, Md., Sunday, July 7, 2019. Photo: Manuel Balce Ceneta / AP" title="President Donald Trump with first lady Melania Trump gestures upon arrival at Andrews Air Force Base, Md., Sunday, July 7, 2019. Photo: Manuel Balce Ceneta / AP"/><figcaption class="wp-caption-text">President Donald Trump with first lady Melania Trump gestures upon arrival at Andrews Air Force Base, Md., Sunday, July 7, 2019. Photo: Manuel Balce Ceneta / AP</figcaption></figure></div>
        <div class="td-a-rec td-a-rec-id-content_top  td_uid_23_5d2423e00531a_rand td_block_template_1"><!-- Revive Adserver Javascript Tag - Generated with Revive Adserver v4.1.1 -->
<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ads6.matichon.co.th/www/delivery/ajs.php':'http://ads6.matichon.co.th/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=78");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ads6.matichon.co.th/www/delivery/ck.php?n=aebc01f1&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://ads6.matichon.co.th/www/delivery/avw.php?zoneid=78&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=aebc01f1' border='0' alt='' /></a></noscript>
</div><p><strong>LONDON</strong> — President Donald Trump threatened Monday to cut off contact with Britain&#8217;s ambassador to the United States after leaked diplomatic cables revealed the envoy called the Trump administration &#8220;dysfunctional&#8221; and &#8220;inept.&#8221;</p>
<p>The U.S. leader tweeted about Ambassador Kim Darroch a day after a British newspaper published the diplomat&#8217;s unflattering assessments of the current administration in Washington.</p>
<p>&#8220;I do not know the Ambassador, but he is not liked or well thought of within the US. We will no longer deal with him,&#8221; Trump wrote.</p>
<p>The documents — published in the Mail on Sunday newspaper — have created awkwardness between two countries that are longtime allies. British officials said they were hunting for the culprit behind the leak, which was both an embarrassment to Prime Minister Theresa May&#8217;s government and a major breach of diplomatic security.</p><div class="td-a-rec td-a-rec-id-content_inlineright  td_uid_22_5d2423e004d5d_rand td_block_template_1"><div id='div-gpt-ad-1471511141011-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1471511141011-0'); });
</script>
</div>
</div>
<p>Darroch has served as Britain&#8217;s envoy to Washington since 2016, and the cables cover a period from 2017 to recent weeks.</p>
<p>In the leaked documents he called the Trump administration&#8217;s policy toward Iran &#8220;incoherent,&#8221; said the president might be indebted to &#8220;dodgy Russians&#8221; and raised doubts about whether the White House &#8220;will ever look competent.&#8221;</p>
<p>&#8220;We don&#8217;t really believe this administration is going to become substantially more normal; less dysfunctional; less unpredictable; less faction riven; less diplomatically clumsy and inept,&#8221; one missive said.</p>
<p>The documents were intended for senior U.K. ministers and civil servants. Government officials think the mole will be found among British politicians or officials, not foreign governments or hackers.</p>
<p>&#8220;I&#8217;ve seen nothing to suggest hostile state actors were involved,&#8221; said May&#8217;s spokesman, James Slack.</p>
<p>Some U.K. diplomatic cables go to more than 100 recipients, though more sensitive messages have a smaller distribution list.</p>
<p>The inquiry is being led by civil servants in the Cabinet Office, and Slack said police would only be called in &#8220;if evidence of criminality is found.&#8221;</p>
<p>But Conservative U.K. lawmaker Tom Tugendhat, who chairs Parliament&#8217;s foreign affairs committee, said he had written to the chief of London&#8217;s Metropolitan Police asking for a criminal investigation into the leak.</p>
<p>It&#8217;s possible the leaker could be charged with breaching the Official Secrets Act, which bars public servants from making &#8220;damaging&#8221; disclosures of classified material. Breaching the act carries a maximum sentence of two years in prison, though prosecutions are rare.</p>
<p>Foreign Secretary Jeremy Hunt said there would be &#8220;very serious consequences&#8221; if the culprit was caught.</p>
<p>He said the ability to communicate frankly was &#8220;fundamental&#8221; to diplomacy.</p>
<p>Amid the trans-Atlantic strain, Trump on Monday renewed his criticism of the outgoing prime minister&#8217;s handling of Britain&#8217;s stalled departure from the European Union.</p>
<p>&#8220;I have been very critical about the way the U.K. and Prime Minister Theresa May handled Brexit,&#8221; he tweeted. &#8220;What a mess she and her representatives have created. I told her how it should be done, but she decided to go another way.&#8221;</p>
<p>He added: &#8220;The good news for the wonderful United Kingdom is that they will soon have a new Prime Minister.&#8221;</p>
<p>May is set to step down later this month, replaced either by Hunt or by his predecessor as foreign secretary, former London mayor Boris Johnson. Trump has previously praised both men.</p>
<p>Slack said May had &#8220;full faith&#8221; in Darroch, a long-serving diplomat, though didn&#8217;t agree with the ambassador&#8217;s characterization of the Trump administration.</p>
<p>He said ambassadors were hired to provide &#8220;honest, unvarnished assessments&#8221; of politics in the countries where they served, which didn&#8217;t necessarily reflect the views of the British government.</p>
<p>But Trump&#8217;s tweets increased the pressure on Britain&#8217;s government over Darroch, who also has been accused by some Brexit-backing U.K. politicians of having a lack of enthusiasm for Britain&#8217;s departure from the EU.</p>
<p>The journalist who reported the leak, Isabel Oakeshott, is a strong supporter of Brexit and an ally of Brexit Party leader Nigel Farage, who also is Britain&#8217;s leading champion of Trump.</p>
<p>Trump said in 2016 that Farage would &#8220;do a great job&#8221; as an ambassador to Washington.</p>
<p>Farage brushed off that idea Monday, saying &#8220;I&#8217;m not a diplomat, and I think that&#8217;s quite an understatement.&#8221;</p>
<p>But Farage said Darroch&#8217;s comments were &#8220;pretty irresponsible.&#8221;</p>
<p>Robin Renwick, who served as Britain&#8217;s ambassador to Washington in the 1990s, said Darroch had done nothing wrong but the leaked cables had made his position &#8220;untenable.&#8221;</p>
<p>&#8220;There will of course be a decent interval. He will then have to be moved on,&#8221; Renwick told the BBC.</p>
<p>International Trade Secretary Liam Fox called the leak &#8220;malicious.&#8221;</p>
<p>&#8220;I think it is unconscionable that any professional person in either politics of the civil service can behave in this way,&#8221; he said.</p>
<p>Fox, who was meeting Trump&#8217;s daughter Ivanka in Washington on Monday, told the BBC he would apologize for the fact that standards of &#8220;either our civil service or elements of our political class&#8221; had &#8220;lapsed in a most extraordinary and unacceptable way.&#8221;</p>
<p><em>Story: Jill Lawless.</em></p>
<div class="td-a-rec td-a-rec-id-content_bottom  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p td_uid_24_5d2423e005b67_rand td_block_template_1"><!--[xyz-ihs snippet="genie"]
<!--  ad tags Size: 300x250 ZoneId:1404334
<script type="text/javascript" src="http://js.genieessp.com/t/404/334/a1404334.js"></script>


--></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2019%2F07%2F09%2Ftrump-will-no-longer-deal-with-uk-envoy-who-panned-him%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him&url=http%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2019%2F07%2F09%2Ftrump-will-no-longer-deal-with-uk-envoy-who-panned-him%2F&via=KhaosodEnglish">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him%0D%0Ahttp://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/">
                                        <div class="td-social-but-icon"><i class="td-icon-line"></i></div>
                                        <div class="td-social-but-text">LINE</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him %0A%0A http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/&amp;media=http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496.jpg&description=Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/&title=Trump+Will+%E2%80%98No+Longer+Deal%E2%80%99+With+UK+Envoy+Who+Panned+Him">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/">
                                        <div class="td-social-but-icon"><i class="td-icon-vk"></i></div>
                                        <div class="td-social-but-text">VK</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://www.khaosodenglish.com/politics/2019/07/08/fears-of-future-assaults-force-activists-to-seek-police-protection/">Fears of Future Assaults Force Activists to Seek Police Protection</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://www.khaosodenglish.com/news/international/2019/07/09/lam-says-hong-kong-bill-is-dead-but-unclear-if-demand-met/">Lam Says Hong Kong Bill Is &#8216;Dead&#8217; but Unclear If Demand Met</a></div></div></div>            <div class="author-box-wrap"><a href="http://www.khaosodenglish.com/author/ap/"><img alt='' src='http://2.gravatar.com/avatar/5e6a9fa95f61663e23555842683a8444?s=96&#038;d=blank&#038;r=pg' srcset='http://2.gravatar.com/avatar/5e6a9fa95f61663e23555842683a8444?s=192&#038;d=blank&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://www.khaosodenglish.com/author/ap/">Associated Press</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Associated Press"></span><meta itemprop="datePublished" content="2019-07-09T10:45:56+00:00"><meta itemprop="dateModified" content="2019-07-09T10:45:56+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/10/logo.gif"></span><meta itemprop="name" content="Khaosod English"></span><meta itemprop="headline " content="Trump Will &#039;No Longer Deal&#039; With UK Envoy Who Panned Him"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19188809318496.jpg"><meta itemprop="width" content="1024"><meta itemprop="height" content="682"></span>        </footer>

    </article> <!-- /.post -->

    
	<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/khaosod-khaosodeng/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script> 

<div id="taboola-below-article-thumbnails-2"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'organic-thumbnails-a',
    container: 'taboola-below-article-thumbnails-2',
    placement: 'Below Article Thumbnails 2',
    target_type: 'mix'
  });
</script> 

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script> <div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td_block_wrap td_block_social_counter td_block_widget td_uid_25_5d2423e00aa39_rand td-social-style9 td-social-boxed td-social-colored td-pb-border-top td_block_template_1">
<style>
.td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-pulldown-filter-link:hover,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-subcat-item a:hover,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-subcat-item .td-cur-simple-item {
                color: #D62532;
            }

            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .block-title > *,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-subcat-dropdown:hover .td-subcat-more {
                background-color: #D62532;
            }
            .td-theme-wrap .td-footer-wrapper .td_uid_25_5d2423e00aa39_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .block-title {
                border-color: #D62532;
            }

            
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td_quote_on_blocks,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-instagram-user a {
                color: #D62532;
            }

            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-next-prev-wrap a:hover,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-load-more-wrap a:hover {
                background-color: #D62532;
                border-color: #D62532;
            }

            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-read-more a,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-weather-information:before,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-weather-week:before,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .td_uid_25_5d2423e00aa39_rand .td-post-category,
            .td-theme-wrap .td_uid_25_5d2423e00aa39_rand .td-post-category:hover {
                background-color: #D62532;
            }
</style><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">FOLLOW US</span></h4></div><div class="td-social-list"><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-social-box"><div class="td-sp td-sp-facebook"></div><span class="td_social_info">133,083</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/KhaosodEnglish"  target="_blank" >Like</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_instagram"><div class="td-social-box"><div class="td-sp td-sp-instagram"></div><span class="td_social_info">2,676</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://instagram.com/khaosodenglish#"  target="_blank" >Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-social-box"><div class="td-sp td-sp-twitter"></div><span class="td_social_info">25,314</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/khaosodenglish"  target="_blank" >Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_youtube"><div class="td-social-box"><div class="td-sp td-sp-youtube"></div><span class="td_social_info">14,686</span><span class="td_social_info td_social_info_name">Subscribers</span><span class="td_social_button"><a href="https://www.youtube.com/channel/UCftKKSU1fyGv9CkGR4AtRAQ"  target="_blank" >Subscribe</a></span></div></div></div></div> <!-- ./block --><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Revive Adserver Javascript Tag - Generated with Revive Adserver v4.1.1 -->
<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ads6.matichon.co.th/www/delivery/ajs.php':'http://ads6.matichon.co.th/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=76");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ads6.matichon.co.th/www/delivery/ck.php?n=a60abea2&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://ads6.matichon.co.th/www/delivery/avw.php?zoneid=76&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a60abea2' border='0' alt='' /></a></noscript>
<!-- Revive Adserver Javascript Tag - Generated with Revive Adserver v4.1.1 -->
<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ads6.matichon.co.th/www/delivery/ajs.php':'http://ads6.matichon.co.th/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=77");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ads6.matichon.co.th/www/delivery/ck.php?n=aa7fc7fd&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://ads6.matichon.co.th/www/delivery/avw.php?zoneid=77&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=aa7fc7fd' border='0' alt='' /></a></noscript></div></aside><div class="td_block_wrap td_block_9 td_block_widget td_uid_26_5d2423e00ba24_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding td_block_bot_line"  data-td-block-uid="td_uid_26_5d2423e00ba24" >
<style>
.td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-pulldown-filter-link:hover,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-subcat-item a:hover,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-subcat-item .td-cur-simple-item {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .block-title > *,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-subcat-dropdown:hover .td-subcat-more {
                background-color: #d62532;
            }
            .td-theme-wrap .td-footer-wrapper .td_uid_26_5d2423e00ba24_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .block-title {
                border-color: #d62532;
            }

            
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td_quote_on_blocks,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-instagram-user a {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-next-prev-wrap a:hover,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-load-more-wrap a:hover {
                background-color: #d62532;
                border-color: #d62532;
            }

            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-read-more a,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-weather-information:before,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-weather-week:before,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .td_uid_26_5d2423e00ba24_rand .td-post-category,
            .td-theme-wrap .td_uid_26_5d2423e00ba24_rand .td-post-category:hover {
                background-color: #d62532;
            }
</style><script>var block_td_uid_26_5d2423e00ba24 = new tdBlock();
block_td_uid_26_5d2423e00ba24.id = "td_uid_26_5d2423e00ba24";
block_td_uid_26_5d2423e00ba24.atts = '{"custom_title":"LATEST NEWS","custom_url":"","block_template_id":"","header_color":"#d62532","header_text_color":"#","accent_text_color":"#","m8_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"-109","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_26_5d2423e00ba24_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_settings":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_settings":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_settings":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_26_5d2423e00ba24_rand","tdc_css_class_style":"td_uid_26_5d2423e00ba24_rand_style"}';
block_td_uid_26_5d2423e00ba24.td_column_number = "1";
block_td_uid_26_5d2423e00ba24.block_type = "td_block_9";
block_td_uid_26_5d2423e00ba24.post_count = "5";
block_td_uid_26_5d2423e00ba24.found_posts = "18519";
block_td_uid_26_5d2423e00ba24.header_color = "#d62532";
block_td_uid_26_5d2423e00ba24.ajax_pagination_infinite_stop = "";
block_td_uid_26_5d2423e00ba24.max_num_pages = "3704";
tdBlocksArray.push(block_td_uid_26_5d2423e00ba24);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">LATEST NEWS</span></h4></div><div id=td_uid_26_5d2423e00ba24 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/international/2019/07/09/swiss-air-force-team-apologizes-for-fly-by-in-wrong-place/" rel="bookmark" title="Swiss Air Force Team Apologizes for Fly-By in Wrong Place">Swiss Air Force Team Apologizes for Fly-By in Wrong Place</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/international/2019/07/09/lam-says-hong-kong-bill-is-dead-but-unclear-if-demand-met/" rel="bookmark" title="Lam Says Hong Kong Bill Is &#8216;Dead&#8217; but Unclear If Demand Met">Lam Says Hong Kong Bill Is &#8216;Dead&#8217; but Unclear If Demand Met</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/international/2019/07/09/trump-will-no-longer-deal-with-uk-envoy-who-panned-him/" rel="bookmark" title="Trump Will &#8216;No Longer Deal&#8217; With UK Envoy Who Panned Him">Trump Will &#8216;No Longer Deal&#8217; With UK Envoy Who Panned Him</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/politics/2019/07/08/fears-of-future-assaults-force-activists-to-seek-police-protection/" rel="bookmark" title="Fears of Future Assaults Force Activists to Seek Police Protection">Fears of Future Assaults Force Activists to Seek Police Protection</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/culture/net/2019/07/08/crazy-rich-bangkokians-viral-instagram-bougiebangkokgirl-gets-political/" rel="bookmark" title="Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political">Crazy Rich Bangkokians: Viral Instagram @BougieBangkokGirl Gets Political</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside class="td_block_template_1 widget widget_mc4wp_form_widget"><h4 class="block-title"><span>Get Khaosod English by mail.</span></h4><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.5.2 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-1464787522" method="post" data-id="1464787522" data-name="Get Khaosod English by mail. Binge-read when you want." ><div class="mc4wp-form-fields"><p>
	<label>Newsletter: </label>
	<input type="email" name="EMAIL" placeholder="Your email address" required />
</p>	<input type="submit" value="Sign up" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1562649568" /><input type="hidden" name="_mc4wp_form_id" value="1464787522" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></aside><div class="td_block_wrap td_block_13 td_block_widget td_uid_27_5d2423e017b30_rand td-pb-border-top td_block_template_1 td-column-1"  data-td-block-uid="td_uid_27_5d2423e017b30" >
<style>
.td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-pulldown-filter-link:hover,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-subcat-item a:hover,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-subcat-item .td-cur-simple-item {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .block-title > *,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-subcat-dropdown:hover .td-subcat-more {
                background-color: #d62532;
            }
            .td-theme-wrap .td-footer-wrapper .td_uid_27_5d2423e017b30_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .block-title {
                border-color: #d62532;
            }

            
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td_quote_on_blocks,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-instagram-user a {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-next-prev-wrap a:hover,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-load-more-wrap a:hover {
                background-color: #d62532;
                border-color: #d62532;
            }

            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-read-more a,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-weather-information:before,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-weather-week:before,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .td_uid_27_5d2423e017b30_rand .td-post-category,
            .td-theme-wrap .td_uid_27_5d2423e017b30_rand .td-post-category:hover {
                background-color: #d62532;
            }
</style><script>var block_td_uid_27_5d2423e017b30 = new tdBlock();
block_td_uid_27_5d2423e017b30.id = "td_uid_27_5d2423e017b30";
block_td_uid_27_5d2423e017b30.atts = '{"custom_title":"COMING UP IN BANGKOK!","custom_url":"","block_template_id":"","header_color":"#d62532","header_text_color":"#","accent_text_color":"#","header_image":"","mx3_tl":"","m14_tl":"","m14_el":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"123","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_27_5d2423e017b30_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx3f_title_font_header":"","mx3f_title_font_title":"Article title","mx3f_title_font_settings":"","mx3f_title_font_family":"","mx3f_title_font_size":"","mx3f_title_font_line_height":"","mx3f_title_font_style":"","mx3f_title_font_weight":"","mx3f_title_font_transform":"","mx3f_title_font_spacing":"","mx3f_title_":"","mx3f_cat_font_title":"Article category tag","mx3f_cat_font_settings":"","mx3f_cat_font_family":"","mx3f_cat_font_size":"","mx3f_cat_font_line_height":"","mx3f_cat_font_style":"","mx3f_cat_font_weight":"","mx3f_cat_font_transform":"","mx3f_cat_font_spacing":"","mx3f_cat_":"","mx3f_meta_font_title":"Article meta info","mx3f_meta_font_settings":"","mx3f_meta_font_family":"","mx3f_meta_font_size":"","mx3f_meta_font_line_height":"","mx3f_meta_font_style":"","mx3f_meta_font_weight":"","mx3f_meta_font_transform":"","mx3f_meta_font_spacing":"","mx3f_meta_":"","m14f_title_font_header":"","m14f_title_font_title":"Article title","m14f_title_font_settings":"","m14f_title_font_family":"","m14f_title_font_size":"","m14f_title_font_line_height":"","m14f_title_font_style":"","m14f_title_font_weight":"","m14f_title_font_transform":"","m14f_title_font_spacing":"","m14f_title_":"","m14f_cat_font_title":"Article category tag","m14f_cat_font_settings":"","m14f_cat_font_family":"","m14f_cat_font_size":"","m14f_cat_font_line_height":"","m14f_cat_font_style":"","m14f_cat_font_weight":"","m14f_cat_font_transform":"","m14f_cat_font_spacing":"","m14f_cat_":"","m14f_meta_font_title":"Article meta info","m14f_meta_font_settings":"","m14f_meta_font_family":"","m14f_meta_font_size":"","m14f_meta_font_line_height":"","m14f_meta_font_style":"","m14f_meta_font_weight":"","m14f_meta_font_transform":"","m14f_meta_font_spacing":"","m14f_meta_":"","m14f_ex_font_title":"Article excerpt","m14f_ex_font_settings":"","m14f_ex_font_family":"","m14f_ex_font_size":"","m14f_ex_font_line_height":"","m14f_ex_font_style":"","m14f_ex_font_weight":"","m14f_ex_font_transform":"","m14f_ex_font_spacing":"","m14f_ex_":"","m14f_btn_font_title":"Article read more button","m14f_btn_font_settings":"","m14f_btn_font_family":"","m14f_btn_font_size":"","m14f_btn_font_line_height":"","m14f_btn_font_style":"","m14f_btn_font_weight":"","m14f_btn_font_transform":"","m14f_btn_font_spacing":"","m14f_btn_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_27_5d2423e017b30_rand","tdc_css_class_style":"td_uid_27_5d2423e017b30_rand_style"}';
block_td_uid_27_5d2423e017b30.td_column_number = "1";
block_td_uid_27_5d2423e017b30.block_type = "td_block_13";
block_td_uid_27_5d2423e017b30.post_count = "5";
block_td_uid_27_5d2423e017b30.found_posts = "942";
block_td_uid_27_5d2423e017b30.header_color = "#d62532";
block_td_uid_27_5d2423e017b30.ajax_pagination_infinite_stop = "";
block_td_uid_27_5d2423e017b30.max_num_pages = "189";
tdBlocksArray.push(block_td_uid_27_5d2423e017b30);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">COMING UP IN BANGKOK!</span></h4></div><div id=td_uid_27_5d2423e017b30 class="td_block_inner">
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/life/2019/07/08/watch-the-best-of-german-flicks-at-german-film-week/" rel="bookmark" class="td-image-wrap" title="Watch the Best of German Flicks at German Film Week"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="A still from “The Young Karl Marx.” Image: Neue Visionen Filmverleih" title="Watch the Best of German Flicks at German Film Week" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/GERMANFILMFEST_Header-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/life/2019/07/08/watch-the-best-of-german-flicks-at-german-film-week/" rel="bookmark" title="Watch the Best of German Flicks at German Film Week">Watch the Best of German Flicks at German Film Week</a></h3>                            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/2019/07/06/royal-barge-procession-set-for-oct-24/" rel="bookmark" class="td-image-wrap" title="Royal Barge Procession Set for Oct. 24"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="" title="Royal Barge Procession Set for Oct. 24" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/58571192_2455205161165068_7895381300121436160_o-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/2019/07/06/royal-barge-procession-set-for-oct-24/" rel="bookmark" title="Royal Barge Procession Set for Oct. 24">Royal Barge Procession Set for Oct. 24</a></h3>                            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/life/events/2019/07/02/nessun-dorma-operas-ballets-and-more-coming-to-bangkok-this-september/" rel="bookmark" class="td-image-wrap" title="Nessun Dorma! Operas, Ballets, and More Coming to Bangkok This September"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="Zoya Tsererina of the Ekaterinburg Opera troupe in “Turandot.” Photo: Olga Kerelyuk / Courtesy" title="Nessun Dorma! Operas, Ballets, and More Coming to Bangkok This September" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/Turandot-Zoya-Tsererina.Photo-by-Olga-Kerelyuk-3-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/life/events/2019/07/02/nessun-dorma-operas-ballets-and-more-coming-to-bangkok-this-september/" rel="bookmark" title="Nessun Dorma! Operas, Ballets, and More Coming to Bangkok This September">Nessun Dorma! Operas, Ballets, and More Coming to Bangkok This September</a></h3>                            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/2019/07/02/celebrate-tanabata-in-ayutthayas-historic-japanese-village/" rel="bookmark" class="td-image-wrap" title="Celebrate Tanabata in Ayutthaya’s Historic Japanese Village"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="" title="Celebrate Tanabata in Ayutthaya’s Historic Japanese Village" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/20180711_180712_0001-e1531381292652-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/2019/07/02/celebrate-tanabata-in-ayutthayas-historic-japanese-village/" rel="bookmark" title="Celebrate Tanabata in Ayutthaya’s Historic Japanese Village">Celebrate Tanabata in Ayutthaya’s Historic Japanese Village</a></h3>                            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/featured/2019/07/01/lgbt-film-fest-explores-the-many-shades-of-pride/" rel="bookmark" class="td-image-wrap" title="LGBT+ Film Fest Explores the Many Shades of Pride"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="A still from “Family in Transition.” Image: Movie Trailers Source / YouTube" title="LGBT+ Film Fest Explores the Many Shades of Pride" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/LGBTFILMFEST_Header-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/featured/2019/07/01/lgbt-film-fest-explores-the-many-shades-of-pride/" rel="bookmark" title="LGBT+ Film Fest Explores the Many Shades of Pride">LGBT+ Film Fest Explores the Many Shades of Pride</a></h3>                            </div>

        </div>

        </div></div> <!-- ./block --><aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>FRESH CUTS</span></h4><div class="textwidget custom-html-widget"><div style="position:relative;height:0;padding-bottom:56.25%"><iframe src="https://www.youtube.com/embed/U8LJlh1KHI4?&autoplay=1&mute=1&controls=1&amp;showinfo=0?&loop=1
&playlist=YYAfF6loezI, pNXEjp9dCbI, Vs9PC_mG5hM, yYZgEbU2ZR0, uYsU3pLgwoQ, lcBKli1dMVw, sUR12BRBksQ, nJ2IlW0GSng, sG4PXiWgTb0, YYAfF6loezI,Hjx6EVSZDdc,KKMT0uqCmWE,SE6XQF3pX8U,ohSsnCt49as,JbLnm0cfxF4,u7_OVX9rZSk,DMsUbJ76Cmw,1_Hhlq-12zs,oE1GLBtqh98,XL2oqFp3Xd4,crNtqFBCvoo,vK12IiKBmY0, 37_QRvMSJeE,Oh4AiPLmkhU, btbkG9lJL5c,PvL1O7DtbbE,iS4CaYRIqsU,MUS6hM_pct0,O-qsge84IIE,nKgtOz5WSnY,fDohK80t-lY,EjL23aAoZEw,sEcwhM72kiA, HrDhsIEdvN0, mrDa14TZIcQ, Of_NSIPUx6o, cfxcaxNkvd8, 9FMVIkCsKuc, mipg3Hz2oB4, yNhGN_ngL-g, 6JoOzLpVScE, c0V_6Nu-RCY, ZmYWvBtTGnQ
" width="300" height="169" frameborder="0" style="position:absolute;width:100%;height:100%;left:0" allowfullscreen></iframe></div>
</div></aside><div class="td_block_wrap td_block_weather td_block_widget td_uid_28_5d2423e024507_rand td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_28_5d2423e024507" ><div class="td-block-title-wrap"></div><div id=td_uid_28_5d2423e024507 class="td-weather-wrap td_block_inner td-column-1"><!-- td weather source: cache -->
		<div class="td-weather-header">
			<div class="td-weather-city">Bangkok</div>
			<div class="td-weather-condition">few clouds</div>
			<i class="td-location-icon td-icons-location" data-block-uid="td_uid_28_5d2423e024507"></i>
		</div>

		<div class="td-weather-set-location">
			<form class="td-manual-location-form" action="#" data-block-uid="td_uid_28_5d2423e024507">
				<input id="td_uid_28_5d2423e024507" class="td-location-set-input" type="text"
					   name="location" value="">
				<label>enter location</label>
			</form>
		</div>

		<div class="td-weather-temperature">
			<div class="td-weather-temp-wrap">
				<div class="td-weather-animated-icon">
					<span
						class="td_animation_sprite-27-100-80-0-0-1 few-clouds-d td-w-today-icon"
						data-td-block-uid="td_uid_28_5d2423e024507"></span>
				</div>
				<div class="td-weather-now" data-block-uid="td_uid_28_5d2423e024507">
					<span class="td-big-degrees">32.9</span>
					<span class="td-circle">&deg;</span>
					<span class="td-weather-unit">C</span>
				</div>
				<div class="td-weather-lo-hi">
					<div class="td-weather-degrees-wrap">
						<i class="td-up-icon td-icons-arrows-up"></i>
						<span
							class="td-small-degrees td-w-high-temp">34.4</span>
						<span class="td-circle">&deg;</span>
					</div>
					<div class="td-weather-degrees-wrap">
						<i class="td-down-icon td-icons-arrows-down"></i>
						<span
							class="td-small-degrees td-w-low-temp">32</span>
						<span class="td-circle">&deg;</span>
					</div>
				</div>
			</div>
		</div>

		<div class="td-weather-info-wrap">
			<div class="td-weather-information">
				<div class="td-weather-section-1">
					<i class="td-icons-drop"></i>
					<span class="td-weather-parameter td-w-today-humidity">62						%</span>
				</div>
				<div class="td-weather-section-2">
					<i class="td-icons-wind"></i>
					<span
						class="td-weather-parameter td-w-today-wind-speed">3.6kmh</span>
				</div>
				<div class="td-weather-section-3">
					<i class="td-icons-cloud"></i>
					<span class="td-weather-parameter td-w-today-clouds">20						%</span>
				</div>
			</div>


			<div class="td-weather-week">
									<div class="td-weather-days">
						<div class="td-day-0">Tue</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-0">36</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-1">Wed</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-1">34</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-2">Thu</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-2">35</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-3">Fri</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-3">34</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-4">Sat</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-4">35</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
								</div>
		</div>

		</div></div> <!-- ./block --><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Revive Adserver Javascript Tag - Generated with Revive Adserver v4.1.1 -->
<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ads6.matichon.co.th/www/delivery/ajs.php':'http://ads6.matichon.co.th/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=86");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ads6.matichon.co.th/www/delivery/ck.php?n=aa8cee1d&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://ads6.matichon.co.th/www/delivery/avw.php?zoneid=86&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=aa8cee1d' border='0' alt='' /></a></noscript></div></aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->


    <div class="td-main-content-wrap td-footer-instagram-container td-container-wrap ">
        
        <div class="td-instagram-user">
            <h4 class="td-footer-instagram-title">
                Follow us on Instagram                <a class="td-footer-instagram-user-link" href="https://www.instagram.com/khaosodenglish" target="_blank">@khaosodenglish</a>
            </h4>
        </div>

        <div class="td_block_wrap td_block_instagram td_uid_29_5d2423e025060_rand td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_29_5d2423e025060" ><div class="td-block-title-wrap"></div><div id=td_uid_29_5d2423e025060 class="td-instagram-wrap td_block_inner td-column-1"><!-- td instagram source: instagram_cache -->        <!-- header section -->
        
        <!-- user shared images -->
                    <div class="td-instagram-main td-images-on-row-5 td-image-gap-2">
                                        <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/Bzp2fM9nnDg" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-3.fna.fbcdn.net/vp/d284d01bf513c58f5cac1958a009a90d/5DC5E721/t51.2885-15/sh0.08/e35/c102.0.670.670a/s640x640/65878788_2443110695747115_2897775131529081054_n.jpg?_nc_ht=instagram.fbkk8-3.fna.fbcdn.net"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BzfN8kqHQdV" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-3.fna.fbcdn.net/vp/90c19c240c51756cf4e2a63cce7875e3/5DBF17CB/t51.2885-15/sh0.08/e35/c236.0.945.945a/s640x640/66137193_643943662786896_3539369224493812798_n.jpg?_nc_ht=instagram.fbkk8-3.fna.fbcdn.net"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BzcWrx5HJ-W" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-3.fna.fbcdn.net/vp/4470328cdf68fc9d69780be7641dbae3/5DA7C8F4/t51.2885-15/sh0.08/e35/s640x640/66051842_469536690532663_6929511997842257328_n.jpg?_nc_ht=instagram.fbkk8-3.fna.fbcdn.net"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BzZo3ODngMh" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-3.fna.fbcdn.net/vp/efb459e1887ddb52d183354dcfff369b/5DA4C1E0/t51.2885-15/sh0.08/e35/s640x640/65860116_134546434413525_2405990018806754879_n.jpg?_nc_ht=instagram.fbkk8-3.fna.fbcdn.net"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BzZowANnV62" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-3.fna.fbcdn.net/vp/a98c0e78db13c7552fb8bc4a1e475754/5DBA0240/t51.2885-15/sh0.08/e35/c1.0.1437.1437a/s640x640/65261358_463745734444298_1300392269836813961_n.jpg?_nc_ht=instagram.fbkk8-3.fna.fbcdn.net"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                    <div class="clearfix"></div>
            </div>
            </div></div> <!-- ./block -->    </div>




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-14 ">
    <div class="td-container td-footer-bottom-full">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="http://www.khaosodenglish.com/"><img class="td-retina-data" src="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/11/footerlogo3.png" data-retina="http://khaosoden-new.unixdev.co.th/wp-content/uploads/2016/11/footeretina-1.png" alt="" title="" width="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Copyright 2018 Khaosod English 40/10 S. Thetsaban Nimit Tai Road Prachaniwet, Chatuchak Bangkok, Thailand, 10900 <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7e1d11100a1f1d0a3e15161f110d111a1b101912170d16501d1113">[email&#160;protected]</a></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span></aside></div>        </div>
    </div>
</div>
	<!-- Sub Footer -->
	

</div><!--close td-outer-wrap-->

<!-- Instagram Feed JS -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
var sbiajaxurl = "http://www.khaosodenglish.com/wp-admin/admin-ajax.php";
</script>
                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/international/2019/07/09/swiss-air-force-team-apologizes-for-fly-by-in-wrong-place/" rel="bookmark" class="td-image-wrap" title="Swiss Air Force Team Apologizes for Fly-By in Wrong Place"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="In this Friday, Jan. 18, 2019 file photo, the Swiss Air Force Patrouille Suisse aerobatic team performs during an alpine ski, men&#039;s World Cup combined in Wengen, Switzerland. The commander of the Swiss air force&#039;s aerobatics display team has apologized after his unit performed a low-altitude pass over the wrong village at the weekend Saturday July 6 - Sunday July 7, 2019. Photo: Marco Tacca / AP" title="Swiss Air Force Team Apologizes for Fly-By in Wrong Place" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19189484008112-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/international/2019/07/09/swiss-air-force-team-apologizes-for-fly-by-in-wrong-place/" rel="bookmark" title="Swiss Air Force Team Apologizes for Fly-By in Wrong Place">Swiss Air Force Team Apologizes for Fly-By in Wrong Place</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-09T11:01:02+00:00" >July 9, 2019 11:01 am</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/news/international/2019/07/09/lam-says-hong-kong-bill-is-dead-but-unclear-if-demand-met/" rel="bookmark" class="td-image-wrap" title="Lam Says Hong Kong Bill Is &#8216;Dead&#8217; but Unclear If Demand Met"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="Hong Kong Chief Executive Carrie Lam pauses during a press conference in Hong Kong, Tuesday, July 9, 2019. Lam said Tuesday the effort to amend an extradition bill was dead, but it wasn&#039;t clear if the legislation was being withdrawn as protesters have demanded. Photo: Vincent Yu / AP" title="Lam Says Hong Kong Bill Is &#8216;Dead&#8217; but Unclear If Demand Met" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/AP19190136257123-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/news/international/2019/07/09/lam-says-hong-kong-bill-is-dead-but-unclear-if-demand-met/" rel="bookmark" title="Lam Says Hong Kong Bill Is &#8216;Dead&#8217; but Unclear If Demand Met">Lam Says Hong Kong Bill Is &#8216;Dead&#8217; but Unclear If Demand...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-09T10:55:42+00:00" >July 9, 2019 10:55 am</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://www.khaosodenglish.com/politics/2019/07/08/fears-of-future-assaults-force-activists-to-seek-police-protection/" rel="bookmark" class="td-image-wrap" title="Fears of Future Assaults Force Activists to Seek Police Protection"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="Fears of Future Assaults Force Activists to Seek Police Protection" data-type="image_tag" data-img-url="http://www.khaosodenglish.com/wp-content/uploads/2019/07/66487985_674391479639876_4625822490965311488_o-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://www.khaosodenglish.com/politics/2019/07/08/fears-of-future-assaults-force-activists-to-seek-police-protection/" rel="bookmark" title="Fears of Future Assaults Force Activists to Seek Police Protection">Fears of Future Assaults Force Activists to Seek Police Protection</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-08T18:19:00+00:00" >July 8, 2019 6:19 pm</time></span>                            </div>
        </div>

        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 9.5 (rara)
        Deploy mode: deploy
        
        uid: 5d2423e06f354
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
@import url("http://fast.fonts.net/t/1.css?apiType=css&projectid=eb81b52c-09ff-4200-bbfe-693c2db29e76");
    @font-face{
        font-family:"DIN Next LT W01 Black";
        src:url("Fonts/ef79833e-ca28-419f-898a-a96725a0e7b5.eot?#iefix");
        src:url("Fonts/ef79833e-ca28-419f-898a-a96725a0e7b5.eot?#iefix") format("eot"),url("Fonts/7324033f-ef94-4c54-8e88-377b447f0fa2.woff2") format("woff2"),url("Fonts/3efb3b3f-ac55-4ec0-8099-940870596c57.woff") format("woff"),url("Fonts/a6869823-bba8-457d-9f31-3b1cfe4c9bb9.ttf") format("truetype");
    }
</style>

<script type="text/javascript"><script type="text/javascript" src="//s3.amazonaws.com/downloads.mailchimp.com/js/signup-forms/popup/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script>
<script type="text/javascript">require(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us12.list-manage.com","uuid":"a848e9861d42590de9aef1b00","lid":"7643ab464a"}) })</script>
<!--BEGIN WEB STAT CODE-->
<script type="text/javascript" src="http://hits.truehits.in.th/data/t0031311.js"></script>
<noscript> 
<a target="_blank" href="http://truehits.net/stat.php?id=t0031311"><img src="http://hits.truehits.in.th/noscript.php?id=t0031311" alt="Thailand Web Stat" border="0" width="14" height="17" /></a> 
<a target="_blank" href="http://truehits.net/">Truehits.net</a> 
</noscript>
<!-- END WEBSTAT CODE --></script><script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"","font_method":"svg"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.12'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=726837bbdee984ffb331a234aadde124'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.5'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=726837bbdee984ffb331a234aadde124'></script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.5.2'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='http://www.khaosodenglish.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.5.2'></script>
<![endif]-->

<!-- JS generated by theme -->

<script>
    

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Bangkok","api_location":"Bangkok","api_language":"en","api_key":"6ecc38c787e2d975b72b6c67fa443691","today_icon":"few-clouds-d","today_icon_text":"few clouds","today_temp":[32.9,91.3],"today_humidity":62,"today_wind_speed":[3.6,2.2],"today_min":[32,89.6],"today_max":[34.4,94],"today_clouds":20,"current_unit":0,"forecast":[{"timestamp":1562652000,"day_name":"Tue","day_temp":[36,97],"owm_day_index":0},{"timestamp":1562716800,"day_name":"Wed","day_temp":[34,94],"owm_day_index":6},{"timestamp":1562803200,"day_name":"Thu","day_temp":[35,95],"owm_day_index":14},{"timestamp":1562889600,"day_name":"Fri","day_temp":[34,92],"owm_day_index":22},{"timestamp":1562976000,"day_name":"Sat","day_temp":[35,95],"owm_day_index":30}]});
				});
			
			

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_uid_28_5d2423e024507","location":"Bangkok","api_location":"Bangkok","api_language":"en","api_key":"6ecc38c787e2d975b72b6c67fa443691","today_icon":"few-clouds-d","today_icon_text":"few clouds","today_temp":[32.9,91.3],"today_humidity":62,"today_wind_speed":[3.6,2.2],"today_min":[32,89.6],"today_max":[34.4,94],"today_clouds":20,"current_unit":0,"forecast":[{"timestamp":1562652000,"day_name":"Tue","day_temp":[36,97],"owm_day_index":0},{"timestamp":1562716800,"day_name":"Wed","day_temp":[34,94],"owm_day_index":6},{"timestamp":1562803200,"day_name":"Thu","day_temp":[35,95],"owm_day_index":14},{"timestamp":1562889600,"day_name":"Fri","day_temp":[34,92],"owm_day_index":22},{"timestamp":1562976000,"day_name":"Sat","day_temp":[35,95],"owm_day_index":30}]});
				});
			
			

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[1464846572]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://www.khaosodenglish.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://www.khaosodenglish.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5d2423e06fb2e"></textarea>
						<div id="td_live_css_uid_1_5d2423e06fb2e" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5d2423e06fb2e');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5d2423e06fb2e");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>