<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>So Long, Internet Explorer. The Browser Retires Today</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.khaosodenglish.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="preload" href="https://www.khaosodenglish.com/wp-content/plugins/plugin-pdpa/js/pdpa.js" as="script">
<meta property="og:image" content="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823.jpeg" /><link rel="icon" type="image/png" href="https://www.khaosodenglish.com/wp-content/uploads/2016/11/fav1-1.png">

<link rel="canonical" href="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="So Long, Internet Explorer. The Browser Retires Today" />
<meta property="og:description" content="SAN FRANCISCO (AP) — Internet Explorer is finally headed out to pasture." />
<meta property="og:url" content="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/" />
<meta property="og:site_name" content="Khaosod English" />
<meta property="article:publisher" content="https://www.facebook.com/KhaosodEnglish/" />
<meta property="article:published_time" content="2022-06-15T05:30:38+00:00" />
<meta property="article:modified_time" content="2022-06-15T05:37:40+00:00" />
<meta property="og:image" content="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823.jpeg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="598" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@KhaosodEnglish" />
<meta name="twitter:site" content="@KhaosodEnglish" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Associated Press" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.khaosodenglish.com/#website","url":"https://www.khaosodenglish.com/","name":"Khaosod English","description":"Thailand a Click Away. News Without Fear or Favor.","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.khaosodenglish.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/#primaryimage","inLanguage":"en-US","url":"https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823.jpeg","contentUrl":"https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823.jpeg","width":1024,"height":598,"caption":"FILE - The Microsoft Internet Explorer logo is projected on a screen during a Microsoft Xbox E3 media briefing in Los Angeles, June 4, 2012. Photo: Damian Dovarganes / AP File"},{"@type":"WebPage","@id":"https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/#webpage","url":"https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/","name":"So Long, Internet Explorer. The Browser Retires Today","isPartOf":{"@id":"https://www.khaosodenglish.com/#website"},"primaryImageOfPage":{"@id":"https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/#primaryimage"},"datePublished":"2022-06-15T05:30:38+00:00","dateModified":"2022-06-15T05:37:40+00:00","author":{"@id":"https://www.khaosodenglish.com/#/schema/person/4a8815276eb63003d10e0e298c61c67b"},"breadcrumb":{"@id":"https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/"]}]},{"@type":"BreadcrumbList","@id":"https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.khaosodenglish.com/"},{"@type":"ListItem","position":2,"name":"So Long, Internet Explorer. The Browser Retires Today"}]},{"@type":"Person","@id":"https://www.khaosodenglish.com/#/schema/person/4a8815276eb63003d10e0e298c61c67b","name":"Associated Press","image":{"@type":"ImageObject","@id":"https://www.khaosodenglish.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/5e6a9fa95f61663e23555842683a8444?s=96&d=blank&r=pg","contentUrl":"https://secure.gravatar.com/avatar/5e6a9fa95f61663e23555842683a8444?s=96&d=blank&r=pg","caption":"Associated Press"},"url":"https://www.khaosodenglish.com/author/ap/"}]}</script>

<link rel='dns-prefetch' href='//www.khaosodenglish.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Khaosod English &raquo; Feed" href="https://www.khaosodenglish.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Khaosod English &raquo; Comments Feed" href="https://www.khaosodenglish.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.khaosodenglish.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='pdpa-style-css' href='https://www.khaosodenglish.com/wp-content/plugins/plugin-pdpa/css/pdpa.css?ver=1645479867' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css' href='https://www.khaosodenglish.com/wp-content/plugins/instagram-feed/css/sbi-styles.min.css?ver=2.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.khaosodenglish.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://www.khaosodenglish.com/wp-content/themes/Newspaper/style.css?ver=1628692091' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://www.khaosodenglish.com/wp-content/themes/Newspaper-child/style.css?ver=1628692091' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.khaosodenglish.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=618b370f2556e74c489bd6592378277f' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%2C500%2C800%2C800italic%2C900%2C900italic%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C600%2C600italic%2C800%2C800italic%2C900italic&#038;subset=gujarati%2Cthai&#038;ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://www.khaosodenglish.com/wp-content/themes/Newspaper-child/style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='https://www.khaosodenglish.com/wp-content/themes/Newspaper/includes/demos/local_news/demo_style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='https://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=726837bbdee984ffb331a234aadde124' type='text/css' media='all' />
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/plugin-pdpa/js/pdpa.js?ver=1645479867' id='pdpa-script-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/js/rbtools.min.js?ver=6.5.5' async id='tp-tools-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/js/rs6.min.js?ver=6.5.5' async id='revmin-js'></script>
<link rel="https://api.w.org/" href="https://www.khaosodenglish.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.khaosodenglish.com/wp-json/wp/v2/posts/1464881636" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.khaosodenglish.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.khaosodenglish.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.3" />
<link rel='shortlink' href='https://www.khaosodenglish.com/?p=1464881636' />
<link rel="alternate" type="application/json+oembed" href="https://www.khaosodenglish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2022%2F06%2F15%2Fso-long-internet-explorer-the-browser-retires-today%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.khaosodenglish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2022%2F06%2F15%2Fso-long-internet-explorer-the-browser-retires-today%2F&#038;format=xml" />
<meta property="dable:item_id" content="1464881636"><meta property="dable:published_time" content="2022-06-15T12:30:38+07:00"><meta property="dable:author" content="Associated Press"><meta property="dable:image" content="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-250x146.jpeg"><meta property="og:image" content="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-250x146.jpeg"><meta property="og:url" content="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/"><meta property="og:title" content="So Long, Internet Explorer. The Browser Retires Today"><meta property="og:description" content="SAN FRANCISCO (AP) — Internet Explorer is finally headed out to pasture."><meta property="article:published_time" content="2022-06-15T12:30:38+07:00"><meta property="article:section" content="dot.Net"><meta property="article:section2" content="International"> <meta property="fb:pages" content="536126593072944" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/kseng-1x1', [1, 1], 'div-gpt-ad-1553672219875-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>



<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_728x90_b1', [[250, 250], [300, 250], [336, 280]], 'div-gpt-ad-1515395484457-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_336x280_b2', [[336, 280], [250, 250], [300, 250]], 'div-gpt-ad-1515395669610-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_728x90_b3', [[336, 280], [300, 250], [728, 90]], 'div-gpt-ad-1515395736307-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>



<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/13542554/eng_home_336x280_b3', [[300, 250], [336, 280], [300, 600]], 'div-gpt-ad-1515394488762-0').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
	googletag.enableServices();
  });
</script>
<link rel="stylesheet" href="https://cdn.knightlab.com/libs/storymapjs/latest/css/storymap.css">
<script type="text/javascript" src="https://cdn.knightlab.com/libs/storymapjs/latest/js/storymap-min.js"></script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=425586894452122&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function () {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') +
                    '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
            })();
        </script>
<script>
        window.tdb_globals = {"wpRestNonce":"21f08190bf","wpRestUrl":"https:\/\/www.khaosodenglish.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/","isAdminBarShowing":false,"origPostEditUrl":null};
    </script>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.khaosodenglish.com\/wp-admin\/","wpRestNonce":"21f08190bf","wpRestUrl":"https:\/\/www.khaosodenglish.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<link rel="amphtml" href="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/amp/"><meta name="generator" content="Powered by Slider Revolution 6.5.5 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<script>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</script>

<style>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</style>

<script data-ad-client="ca-pub-6931715045853286" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<script async src="//cmp.optad360.io/items/814db7ab-5b59-4060-9bc5-1b12cf9728d2.min.js"></script>
<script async src="//get.optad360.io/sf/731fa3a3-566e-4cfa-92c0-03f9169cf1cb/plugin.min.js"></script><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-65987233-1', 'auto');
  ga('send', 'pageview');

</script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.khaosodenglish.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.khaosodenglish.com/category/culture/net/",
                    "name": "dot.Net"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/",
                    "name": "So Long, Internet Explorer. The Browser Retires Today"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-32x32.gif" sizes="32x32" />
<link rel="icon" href="https://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-192x192.gif" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-180x180.gif" />
<meta name="msapplication-TileImage" content="https://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-270x270.gif" />
<script type="text/javascript">function setREVStartSize(e){
			//window.requestAnimationFrame(function() {				 
				window.RSIW = window.RSIW===undefined ? window.innerWidth : window.RSIW;	
				window.RSIH = window.RSIH===undefined ? window.innerHeight : window.RSIH;	
				try {								
					var pw = document.getElementById(e.c).parentNode.offsetWidth,
						newh;
					pw = pw===0 || isNaN(pw) ? window.RSIW : pw;
					e.tabw = e.tabw===undefined ? 0 : parseInt(e.tabw);
					e.thumbw = e.thumbw===undefined ? 0 : parseInt(e.thumbw);
					e.tabh = e.tabh===undefined ? 0 : parseInt(e.tabh);
					e.thumbh = e.thumbh===undefined ? 0 : parseInt(e.thumbh);
					e.tabhide = e.tabhide===undefined ? 0 : parseInt(e.tabhide);
					e.thumbhide = e.thumbhide===undefined ? 0 : parseInt(e.thumbhide);
					e.mh = e.mh===undefined || e.mh=="" || e.mh==="auto" ? 0 : parseInt(e.mh,0);		
					if(e.layout==="fullscreen" || e.l==="fullscreen") 						
						newh = Math.max(e.mh,window.RSIH);					
					else{					
						e.gw = Array.isArray(e.gw) ? e.gw : [e.gw];
						for (var i in e.rl) if (e.gw[i]===undefined || e.gw[i]===0) e.gw[i] = e.gw[i-1];					
						e.gh = e.el===undefined || e.el==="" || (Array.isArray(e.el) && e.el.length==0)? e.gh : e.el;
						e.gh = Array.isArray(e.gh) ? e.gh : [e.gh];
						for (var i in e.rl) if (e.gh[i]===undefined || e.gh[i]===0) e.gh[i] = e.gh[i-1];
											
						var nl = new Array(e.rl.length),
							ix = 0,						
							sl;					
						e.tabw = e.tabhide>=pw ? 0 : e.tabw;
						e.thumbw = e.thumbhide>=pw ? 0 : e.thumbw;
						e.tabh = e.tabhide>=pw ? 0 : e.tabh;
						e.thumbh = e.thumbhide>=pw ? 0 : e.thumbh;					
						for (var i in e.rl) nl[i] = e.rl[i]<window.RSIW ? 0 : e.rl[i];
						sl = nl[0];									
						for (var i in nl) if (sl>nl[i] && nl[i]>0) { sl = nl[i]; ix=i;}															
						var m = pw>(e.gw[ix]+e.tabw+e.thumbw) ? 1 : (pw-(e.tabw+e.thumbw)) / (e.gw[ix]);					
						newh =  (e.gh[ix] * m) + (e.tabh + e.thumbh);
					}
					var el = document.getElementById(e.c);
					if (el!==null && el) el.style.height = newh+"px";					
					el = document.getElementById(e.c+"_wrapper");
					if (el!==null && el) {
						el.style.height = newh+"px";
						el.style.display = "block";
					}
				} catch(e){
					console.log("Failure at Presize of Slider:" + e)
				}					   
			//});
		  };</script>
<style type="text/css" id="wp-custom-css">
			.footer-text-wrap .footer-email-wrap a {
	color: white;
}		</style>

<style>
    .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                  color: #d62532;
                }
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .sfHover > a,
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                  background-color: #d62532;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a,
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #d62532;
                }
                .tdm-btn-style1 {
					background-color: #d62532;
				}
				.tdm-btn-style2:before {
				    border-color: #d62532;
				}
				.tdm-btn-style2 {
				    color: #d62532;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #d62532;
                    -moz-box-shadow: 0 2px 16px #d62532;
                    box-shadow: 0 2px 16px #d62532;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #d62532;
                    -moz-box-shadow: 0 4px 26px #d62532;
                    box-shadow: 0 4px 26px #d62532;
				}
</style>
<style id="tdw-css-placeholder">#invest-in-thailand-front a {
  color: white;
}
#invest-in-thailand-front .td-module-meta-info {
  display: none;
}
#invest-in-thailand-front .td-excerpt {
  color: #ccc;
}
#invest-in-thailand-front .logo-boi {
  text-align: center;
  margin: 20px auto 0;
  width: 175px;
}
@media (min-width: 992px) {
  #invest-in-thailand-front .logo-boi {
    position: absolute;
    bottom: 0px;
    right: 20px;
  }
}
</style></head>
<body class="post-template-default single single-post postid-1464881636 single-format-standard global-block-template-1 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/KhaosodEnglish" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/KhaosodEnglish" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/KhaosodEnglish" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-bt-top-menu-container"><ul id="menu-bt-top-menu" class="td-mobile-main-menu"><li id="menu-item-1464858623" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-first menu-item-has-children menu-item-1464858623"><a href="https://www.khaosodenglish.com/category/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/asean/">ASEAN</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/bangkok/">Bangkok</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/business/">Business</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime, Courts, Calamity</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/calamity/">Calamity</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/courts/">Courts</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/crime-crime/">Crime</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/international/">International</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/transpo/">Transportation</a></li>
</ul>
</li>
<li id="menu-item-1464768586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768586"><a href="https://www.khaosodenglish.com/category/politics/">Politics</a></li>
<li id="menu-item-1464768584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1464768584"><a href="https://www.khaosodenglish.com/category/life/">Lifestyle<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/arts/">Arts &amp; Culture</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/embassy/">Embassy Corner</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/entertainment/">Entertainment</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/events/">Events</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/food/">Food</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/geek/">Geek</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/nightlife/">Nightlife</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/shopping/">Shopping</a></li>
</ul>
</li>
<li id="menu-item-1464768583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1464768583"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime &#038; Legal<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/calamity/">Calamity</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/courts/">Courts</a></li>
<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/crime-crime/">Crime</a></li>
</ul>
</li>
<li id="menu-item-1464768582" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1464768582"><a href="https://www.khaosodenglish.com/category/culture/net/">dot.Net</a></li>
<li id="menu-item-1464768595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768595"><a href="https://www.khaosodenglish.com/category/opinion/">Opinion</a></li>
<li id="menu-item-1464768589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768589"><a href="https://www.khaosodenglish.com/category/news/asean/">ASEAN</a></li>
<li id="menu-item-1464825008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464825008"><a href="https://www.khaosodenglish.com/category/videos/">Videos</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.khaosodenglish.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<style>
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    </style>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-8 ">
<div class="td-container ">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.khaosodenglish.com/">
<img class="td-retina-data" data-retina="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo_300x284.gif" src="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo.gif" alt="" />
<span class="td-visual-hidden">Khaosod English</span>
</a>
</div>
</div>
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container">
<div class="td-header-row td-header-top-menu">
<div class="top-bar-style-4">
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/KhaosodEnglish" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/KhaosodEnglish" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/KhaosodEnglish" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>
<div class="td-header-sp-top-menu">
 <div class="td-weather-top-widget" id="td_top_weather_uid">
<i class="td-icons broken-clouds-d"></i>
<div class="td-weather-now" data-block-uid="td_top_weather_uid">
<span class="td-big-degrees">31.5</span>
<span class="td-weather-unit">C</span>
</div>
<div class="td-weather-header">
<div class="td-weather-city">Bangkok</div>
</div>
</div>
<div class="td_data_time">
<div>
Wednesday, June 15, 2022
 </div>
</div>
</div>
</div>

</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
<div class="td-container">
<div class="td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-mobile" href="https://www.khaosodenglish.com/">
<img class="td-retina-data" data-retina="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo_300x284.gif" src="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo.gif" alt="" />
</a>
<a class="td-header-logo td-sticky-mobile" href="https://www.khaosodenglish.com/">
<img class="td-retina-data" data-retina="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo_300x284.gif" src="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo.gif" alt="" />
</a>
</div>
<div class="menu-bt-top-menu-container"><ul id="menu-bt-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-first td-menu-item td-mega-menu menu-item-1464858623"><a href="https://www.khaosodenglish.com/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_62a9707bc3ccd_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_1_62a9707bc3ccd"><script>var block_td_uid_1_62a9707bc3ccd = new tdBlock();
block_td_uid_1_62a9707bc3ccd.id = "td_uid_1_62a9707bc3ccd";
block_td_uid_1_62a9707bc3ccd.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"136","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_62a9707bc3ccd_rand","tdc_css_class":"td_uid_1_62a9707bc3ccd_rand","tdc_css_class_style":"td_uid_1_62a9707bc3ccd_rand_style"}';
block_td_uid_1_62a9707bc3ccd.td_column_number = "3";
block_td_uid_1_62a9707bc3ccd.block_type = "td_block_mega_menu";
block_td_uid_1_62a9707bc3ccd.post_count = "4";
block_td_uid_1_62a9707bc3ccd.found_posts = "15663";
block_td_uid_1_62a9707bc3ccd.header_color = "";
block_td_uid_1_62a9707bc3ccd.ajax_pagination_infinite_stop = "";
block_td_uid_1_62a9707bc3ccd.max_num_pages = "3916";
tdBlocksArray.push(block_td_uid_1_62a9707bc3ccd);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_2_62a9707bd896f" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="" href="https://www.khaosodenglish.com/category/news/">All</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_3_62a9707bd89a8" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="52" href="https://www.khaosodenglish.com/category/news/asean/">ASEAN</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_4_62a9707bd89ca" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="135" href="https://www.khaosodenglish.com/category/news/bangkok/">Bangkok</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_5_62a9707bd89e6" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="108" href="https://www.khaosodenglish.com/category/news/business/">Business</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_6_62a9707bd8a00" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="41" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime, Courts, Calamity</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_7_62a9707bd8a18" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="191" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/calamity/">Calamity</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_8_62a9707bd8a37" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="173" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/courts/">Courts</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_9_62a9707bd8a56" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="179" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/crime-crime/">Crime</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_10_62a9707bd8a74" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="51" href="https://www.khaosodenglish.com/category/news/international/">International</a><a class="mega-menu-sub-cat-td_uid_1_62a9707bc3ccd" id="td_uid_11_62a9707bd8a8b" data-td_block_id="td_uid_1_62a9707bc3ccd" data-td_filter_value="133" href="https://www.khaosodenglish.com/category/news/transpo/">Transportation</a></div></div><div id=td_uid_1_62a9707bc3ccd class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/" rel="bookmark" class="td-image-wrap" title="So Long, Internet Explorer. The Browser Retires Today"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="FILE - The Microsoft Internet Explorer logo is projected on a screen during a Microsoft Xbox E3 media briefing in Los Angeles, June 4, 2012. Photo: Damian Dovarganes / AP File" title="So Long, Internet Explorer. The Browser Retires Today" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/" rel="bookmark" title="So Long, Internet Explorer. The Browser Retires Today">So Long, Internet Explorer. The Browser Retires Today</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/russians-control-80-of-key-ukraine-city-cut-escape-routes/" rel="bookmark" class="td-image-wrap" title="Russians Control 80% Of Key Ukraine City, Cut Escape Routes"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="A woman heads to the market in Makariv, on the outskirts of Kyiv, Ukraine, Tuesday, June 14, 2022. Photo: Natacha Pisarenko / AP" title="Russians Control 80% Of Key Ukraine City, Cut Escape Routes" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22165453528959-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/russians-control-80-of-key-ukraine-city-cut-escape-routes/" rel="bookmark" title="Russians Control 80% Of Key Ukraine City, Cut Escape Routes">Russians Control 80% Of Key Ukraine City, Cut Escape Routes</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2022/06/14/cambodian-court-convicts-lawyer-dozens-of-others-of-treason/" rel="bookmark" class="td-image-wrap" title="Cambodian Court Convicts Lawyer, Dozens of Others of Treason"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Cambodian-American lawyer Theary Seng, center, dressed in the Lady Liberty, is escorted by local police officers outside Phnom Penh Municipal Court in Phnom Penh, Cambodia, Tuesday, June 14, 2022. Photo: Heng Sinith / AP" title="Cambodian Court Convicts Lawyer, Dozens of Others of Treason" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22165127938187-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/14/cambodian-court-convicts-lawyer-dozens-of-others-of-treason/" rel="bookmark" title="Cambodian Court Convicts Lawyer, Dozens of Others of Treason">Cambodian Court Convicts Lawyer, Dozens of Others of Treason</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2022/06/14/jan-6-panel-hears-trump-detached-from-reality-in-defeat/" rel="bookmark" class="td-image-wrap" title="Jan. 6 Panel Hears: Trump &#8216;Detached From Reality&#8217; in Defeat"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="A video of former President Donald Trump speaking is displayed as the House select committee investigating the Jan. 6 attack on the U.S. Capitol continues to reveal its findings of a year-long investigation, at the Capitol in Washington, Monday, June 13, 2022. Photo: Mandel Ngan / Pool via AP" title="Jan. 6 Panel Hears: Trump &#8216;Detached From Reality&#8217; in Defeat" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22164613447429-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/14/jan-6-panel-hears-trump-detached-from-reality-in-defeat/" rel="bookmark" title="Jan. 6 Panel Hears: Trump &#8216;Detached From Reality&#8217; in Defeat">Jan. 6 Panel Hears: Trump &#8216;Detached From Reality&#8217; in Defeat</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_62a9707bc3ccd" data-td_block_id="td_uid_1_62a9707bc3ccd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_62a9707bc3ccd" data-td_block_id="td_uid_1_62a9707bc3ccd"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768586"><a href="https://www.khaosodenglish.com/category/politics/">Politics</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_12_62a9707bdacdb_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_12_62a9707bdacdb"><script>var block_td_uid_12_62a9707bdacdb = new tdBlock();
block_td_uid_12_62a9707bdacdb.id = "td_uid_12_62a9707bdacdb";
block_td_uid_12_62a9707bdacdb.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_12_62a9707bdacdb_rand","tdc_css_class":"td_uid_12_62a9707bdacdb_rand","tdc_css_class_style":"td_uid_12_62a9707bdacdb_rand_style"}';
block_td_uid_12_62a9707bdacdb.td_column_number = "3";
block_td_uid_12_62a9707bdacdb.block_type = "td_block_mega_menu";
block_td_uid_12_62a9707bdacdb.post_count = "5";
block_td_uid_12_62a9707bdacdb.found_posts = "4380";
block_td_uid_12_62a9707bdacdb.header_color = "";
block_td_uid_12_62a9707bdacdb.ajax_pagination_infinite_stop = "";
block_td_uid_12_62a9707bdacdb.max_num_pages = "876";
tdBlocksArray.push(block_td_uid_12_62a9707bdacdb);
</script><div id=td_uid_12_62a9707bdacdb class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2022/05/23/bangkok-governors-election-handily-won-by-opposition-figure/" rel="bookmark" class="td-image-wrap" title="Bangkok Governor&#8217;s Election Handily Won by Opposition Figure"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Chadchart Sittipunt celebrates after an unofficial vote count showed him winning the Bangkok gubernatorial election on May 22, 2022." title="Bangkok Governor&#8217;s Election Handily Won by Opposition Figure" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/05/S__6619241-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2022/05/23/bangkok-governors-election-handily-won-by-opposition-figure/" rel="bookmark" title="Bangkok Governor&#8217;s Election Handily Won by Opposition Figure">Bangkok Governor&#8217;s Election Handily Won by Opposition Figure</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2022/05/12/arnon-monarchy-reform-movement-still-on-track-despite-no-street-protests/" rel="bookmark" class="td-image-wrap" title="Arnon: Monarchy Reform Movement Still on Track Despite No Street Protests"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Civil rights lawyer and activist Arnon Nampa at an anti-government rally on Aug. 10, 2020." title="Arnon: Monarchy Reform Movement Still on Track Despite No Street Protests" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/08/WARRANT_Header-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2022/05/12/arnon-monarchy-reform-movement-still-on-track-despite-no-street-protests/" rel="bookmark" title="Arnon: Monarchy Reform Movement Still on Track Despite No Street Protests">Arnon: Monarchy Reform Movement Still on Track Despite No Street Protests</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2022/04/29/ukrainian-envoy-urges-thai-govt-to-waive-visa-extension-fees-for-stranded-ukrainians/" rel="bookmark" class="td-image-wrap" title="Ukrainian Envoy Urges Thai Gov’t To Waive Visa Extension Fees for Stranded Ukrainians"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Ukrainian Charges d’Affaires Oleksandr Lysak speaks at a press conference at the Pullman G Hotel in Bangkok on Apr. 28, 2022." title="Ukrainian Envoy Urges Thai Gov’t To Waive Visa Extension Fees for Stranded Ukrainians" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/04/DSC_7533-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2022/04/29/ukrainian-envoy-urges-thai-govt-to-waive-visa-extension-fees-for-stranded-ukrainians/" rel="bookmark" title="Ukrainian Envoy Urges Thai Gov’t To Waive Visa Extension Fees for Stranded Ukrainians">Ukrainian Envoy Urges Thai Gov’t To Waive Visa Extension Fees for&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2022/04/03/thai-vietjets-april-fools-tweet-outrage-ultra-royalists/" rel="bookmark" class="td-image-wrap" title="Thai VietJet&#8217;s April Fool&#8217;s Tweet Outrage Ultra-Royalists"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="A file photo of an aircraft operated by Thai VietJet." title="Thai VietJet&#8217;s April Fool&#8217;s Tweet Outrage Ultra-Royalists" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/04/ไทยเวียตเจ็ท3-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2022/04/03/thai-vietjets-april-fools-tweet-outrage-ultra-royalists/" rel="bookmark" title="Thai VietJet&#8217;s April Fool&#8217;s Tweet Outrage Ultra-Royalists">Thai VietJet&#8217;s April Fool&#8217;s Tweet Outrage Ultra-Royalists</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2022/03/25/100-objects-of-political-campaigns-on-exhibit-till-sunday/" rel="bookmark" class="td-image-wrap" title="100 Objects of Political Campaigns On Exhibit Till Sunday"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Anon Chawalawan at his exhibition of objects related to Thai political conflicts at Kinjai Contemporary." title="100 Objects of Political Campaigns On Exhibit Till Sunday" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/03/111110-e1648210094756-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2022/03/25/100-objects-of-political-campaigns-on-exhibit-till-sunday/" rel="bookmark" title="100 Objects of Political Campaigns On Exhibit Till Sunday">100 Objects of Political Campaigns On Exhibit Till Sunday</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_12_62a9707bdacdb" data-td_block_id="td_uid_12_62a9707bdacdb"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_12_62a9707bdacdb" data-td_block_id="td_uid_12_62a9707bdacdb"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768584"><a href="https://www.khaosodenglish.com/category/life/">Lifestyle</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_13_62a9707be43fc_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_13_62a9707be43fc"><script>var block_td_uid_13_62a9707be43fc = new tdBlock();
block_td_uid_13_62a9707be43fc.id = "td_uid_13_62a9707be43fc";
block_td_uid_13_62a9707be43fc.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"42","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_13_62a9707be43fc_rand","tdc_css_class":"td_uid_13_62a9707be43fc_rand","tdc_css_class_style":"td_uid_13_62a9707be43fc_rand_style"}';
block_td_uid_13_62a9707be43fc.td_column_number = "3";
block_td_uid_13_62a9707be43fc.block_type = "td_block_mega_menu";
block_td_uid_13_62a9707be43fc.post_count = "4";
block_td_uid_13_62a9707be43fc.found_posts = "4188";
block_td_uid_13_62a9707be43fc.header_color = "";
block_td_uid_13_62a9707be43fc.ajax_pagination_infinite_stop = "";
block_td_uid_13_62a9707be43fc.max_num_pages = "1047";
tdBlocksArray.push(block_td_uid_13_62a9707be43fc);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_14_62a9707bebc0b" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="" href="https://www.khaosodenglish.com/category/life/">All</a><a class="mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_15_62a9707bebc34" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="128" href="https://www.khaosodenglish.com/category/life/arts/">Arts &amp; Culture</a><a class="mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_16_62a9707bebc53" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="587" href="https://www.khaosodenglish.com/category/life/embassy/">Embassy Corner</a><a class="mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_17_62a9707bebc6d" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="127" href="https://www.khaosodenglish.com/category/life/entertainment/">Entertainment</a><a class="mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_18_62a9707bebc86" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="123" href="https://www.khaosodenglish.com/category/life/events/">Events</a><a class="mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_19_62a9707bebc9e" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="44" href="https://www.khaosodenglish.com/category/life/food/">Food</a><a class="mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_20_62a9707bebcb6" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="53" href="https://www.khaosodenglish.com/category/life/geek/">Geek</a><a class="mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_21_62a9707bebcce" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="130" href="https://www.khaosodenglish.com/category/life/nightlife/">Nightlife</a><a class="mega-menu-sub-cat-td_uid_13_62a9707be43fc" id="td_uid_22_62a9707bebce5" data-td_block_id="td_uid_13_62a9707be43fc" data-td_filter_value="232" href="https://www.khaosodenglish.com/category/life/shopping/">Shopping</a></div></div><div id=td_uid_13_62a9707be43fc class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/events/2022/04/27/justin-bieber-coming-to-bangkok-in-november/" rel="bookmark" class="td-image-wrap" title="&#8216;Justin Bieber&#8217; Coming to Bangkok in November"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Photo: Tero Asia" title="&#8216;Justin Bieber&#8217; Coming to Bangkok in November" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/04/JUSTIN-BIEBER_02-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/events/2022/04/27/justin-bieber-coming-to-bangkok-in-november/" rel="bookmark" title="&#8216;Justin Bieber&#8217; Coming to Bangkok in November">&#8216;Justin Bieber&#8217; Coming to Bangkok in November</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/2022/04/25/japanese-documentary-director-reveals-the-success-factors-behind-huawei-thailand/" rel="bookmark" class="td-image-wrap" title="Japanese documentary director reveals the success factors behind Huawei Thailand "><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Japanese documentary director reveals the success factors behind Huawei Thailand " data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/04/image1-18-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/2022/04/25/japanese-documentary-director-reveals-the-success-factors-behind-huawei-thailand/" rel="bookmark" title="Japanese documentary director reveals the success factors behind Huawei Thailand ">Japanese documentary director reveals the success factors behind Huawei Thailand </a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2022/03/25/100-objects-of-political-campaigns-on-exhibit-till-sunday/" rel="bookmark" class="td-image-wrap" title="100 Objects of Political Campaigns On Exhibit Till Sunday"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Anon Chawalawan at his exhibition of objects related to Thai political conflicts at Kinjai Contemporary." title="100 Objects of Political Campaigns On Exhibit Till Sunday" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/03/111110-e1648210094756-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2022/03/25/100-objects-of-political-campaigns-on-exhibit-till-sunday/" rel="bookmark" title="100 Objects of Political Campaigns On Exhibit Till Sunday">100 Objects of Political Campaigns On Exhibit Till Sunday</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/arts/2022/02/08/what-does-farang-thinks-about-farangs-an-interview-with-stepff-the-cartoonist/" rel="bookmark" class="td-image-wrap" title="What Does Farang Think About Farangs? An Interview with Stephff the Cartoonist"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Image: Stephane Peray / Courtesy" title="What Does Farang Think About Farangs? An Interview with Stephff the Cartoonist" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/02/97360-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/arts/2022/02/08/what-does-farang-thinks-about-farangs-an-interview-with-stepff-the-cartoonist/" rel="bookmark" title="What Does Farang Think About Farangs? An Interview with Stephff the Cartoonist">What Does Farang Think About Farangs? An Interview with Stephff the&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_13_62a9707be43fc" data-td_block_id="td_uid_13_62a9707be43fc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_13_62a9707be43fc" data-td_block_id="td_uid_13_62a9707be43fc"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768583"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime &#038; Legal</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_62a9707bee60a_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_23_62a9707bee60a"><script>var block_td_uid_23_62a9707bee60a = new tdBlock();
block_td_uid_23_62a9707bee60a.id = "td_uid_23_62a9707bee60a";
block_td_uid_23_62a9707bee60a.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"41","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_23_62a9707bee60a_rand","tdc_css_class":"td_uid_23_62a9707bee60a_rand","tdc_css_class_style":"td_uid_23_62a9707bee60a_rand_style"}';
block_td_uid_23_62a9707bee60a.td_column_number = "3";
block_td_uid_23_62a9707bee60a.block_type = "td_block_mega_menu";
block_td_uid_23_62a9707bee60a.post_count = "4";
block_td_uid_23_62a9707bee60a.found_posts = "4553";
block_td_uid_23_62a9707bee60a.header_color = "";
block_td_uid_23_62a9707bee60a.ajax_pagination_infinite_stop = "";
block_td_uid_23_62a9707bee60a.max_num_pages = "1139";
tdBlocksArray.push(block_td_uid_23_62a9707bee60a);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_62a9707bee60a" id="td_uid_24_62a9707c00305" data-td_block_id="td_uid_23_62a9707bee60a" data-td_filter_value="" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">All</a><a class="mega-menu-sub-cat-td_uid_23_62a9707bee60a" id="td_uid_25_62a9707c00335" data-td_block_id="td_uid_23_62a9707bee60a" data-td_filter_value="191" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/calamity/">Calamity</a><a class="mega-menu-sub-cat-td_uid_23_62a9707bee60a" id="td_uid_26_62a9707c0035a" data-td_block_id="td_uid_23_62a9707bee60a" data-td_filter_value="173" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/courts/">Courts</a><a class="mega-menu-sub-cat-td_uid_23_62a9707bee60a" id="td_uid_27_62a9707c0037c" data-td_block_id="td_uid_23_62a9707bee60a" data-td_filter_value="179" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/crime-crime/">Crime</a></div></div><div id=td_uid_23_62a9707bee60a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2022/04/07/despite-risk-of-death-thailand-sends-fleeing-myanmar-refugees-back/" rel="bookmark" class="td-image-wrap" title="Despite Risk of Death, Thailand Sends Fleeing Myanmar Refugees Back"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Displaced people from Myanmar carry donated lunch boxes to their tents along the Thai side of the Moei River in Mae Sot, Thailand on Feb. 5, 2022. Photo: AP" title="Despite Risk of Death, Thailand Sends Fleeing Myanmar Refugees Back" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/04/AP22096315872584-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2022/04/07/despite-risk-of-death-thailand-sends-fleeing-myanmar-refugees-back/" rel="bookmark" title="Despite Risk of Death, Thailand Sends Fleeing Myanmar Refugees Back">Despite Risk of Death, Thailand Sends Fleeing Myanmar Refugees Back</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2022/03/10/cricket-great-warne-begins-final-journey-home-to-australia/" rel="bookmark" class="td-image-wrap" title="Cricket Great Warne Begins Final Journey Home to Australia"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Pakistan and Australia cricket team players pay tribute to Shane Warne at the start of 2nd day play of the first cricket test match between them at the Pindi Stadium, in Rawalpindi, Pakistan, Saturday, March 5, 2022. Photo: Anjum Naveed / AP" title="Cricket Great Warne Begins Final Journey Home to Australia" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/03/AP22064222941247-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2022/03/10/cricket-great-warne-begins-final-journey-home-to-australia/" rel="bookmark" title="Cricket Great Warne Begins Final Journey Home to Australia">Cricket Great Warne Begins Final Journey Home to Australia</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2022/03/07/autopsy-says-cricket-star-warne-died-of-natural-causes/" rel="bookmark" class="td-image-wrap" title="Autopsy Says Cricket Star Warne Died of Natural Causes"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="A man places a set of cricket stumps and a photos at the statue of Shane Warne outside the Melbourne Cricket Ground in Melbourne, Australia, Saturday, March 5, 2022. Photo: Asanka Brendon Ratnayake / AP" title="Autopsy Says Cricket Star Warne Died of Natural Causes" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/03/AP22064154132905-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2022/03/07/autopsy-says-cricket-star-warne-died-of-natural-causes/" rel="bookmark" title="Autopsy Says Cricket Star Warne Died of Natural Causes">Autopsy Says Cricket Star Warne Died of Natural Causes</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2022/02/14/interpol-issues-red-notice-for-phuket-hitmen/" rel="bookmark" class="td-image-wrap" title="Interpol Issues Red Notice for Phuket Hitmen"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="A still from CCTV footage showing one of the suspects leaving Thailand at Suvarnabhumi Airport on Feb. 6, 2022." title="Interpol Issues Red Notice for Phuket Hitmen" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/02/FLcyWCWaMAA18WH-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2022/02/14/interpol-issues-red-notice-for-phuket-hitmen/" rel="bookmark" title="Interpol Issues Red Notice for Phuket Hitmen">Interpol Issues Red Notice for Phuket Hitmen</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_62a9707bee60a" data-td_block_id="td_uid_23_62a9707bee60a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_23_62a9707bee60a" data-td_block_id="td_uid_23_62a9707bee60a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-1464768582"><a href="https://www.khaosodenglish.com/category/culture/net/">dot.Net</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_28_62a9707c02ec5_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_28_62a9707c02ec5"><script>var block_td_uid_28_62a9707c02ec5 = new tdBlock();
block_td_uid_28_62a9707c02ec5.id = "td_uid_28_62a9707c02ec5";
block_td_uid_28_62a9707c02ec5.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"43","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_28_62a9707c02ec5_rand","tdc_css_class":"td_uid_28_62a9707c02ec5_rand","tdc_css_class_style":"td_uid_28_62a9707c02ec5_rand_style"}';
block_td_uid_28_62a9707c02ec5.td_column_number = "3";
block_td_uid_28_62a9707c02ec5.block_type = "td_block_mega_menu";
block_td_uid_28_62a9707c02ec5.post_count = "5";
block_td_uid_28_62a9707c02ec5.found_posts = "584";
block_td_uid_28_62a9707c02ec5.header_color = "";
block_td_uid_28_62a9707c02ec5.ajax_pagination_infinite_stop = "";
block_td_uid_28_62a9707c02ec5.max_num_pages = "117";
tdBlocksArray.push(block_td_uid_28_62a9707c02ec5);
</script><div id=td_uid_28_62a9707c02ec5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/" rel="bookmark" class="td-image-wrap" title="So Long, Internet Explorer. The Browser Retires Today"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="FILE - The Microsoft Internet Explorer logo is projected on a screen during a Microsoft Xbox E3 media briefing in Los Angeles, June 4, 2012. Photo: Damian Dovarganes / AP File" title="So Long, Internet Explorer. The Browser Retires Today" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/" rel="bookmark" title="So Long, Internet Explorer. The Browser Retires Today">So Long, Internet Explorer. The Browser Retires Today</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2021/11/18/khaosod-recognized-by-facebook-in-award-campaign/" rel="bookmark" class="td-image-wrap" title="Khaosod Recognized by Facebook in Prestigious Award Campaign"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Khaosod Recognized by Facebook in Prestigious Award Campaign" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/11/IMG_8598-scaled-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2021/11/18/khaosod-recognized-by-facebook-in-award-campaign/" rel="bookmark" title="Khaosod Recognized by Facebook in Prestigious Award Campaign">Khaosod Recognized by Facebook in Prestigious Award Campaign</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2021/02/24/meet-thailands-hottest-tiktok-star-a-cambodian-migrant-worker/" rel="bookmark" class="td-image-wrap" title="Meet Thailand’s Hottest TikTok Star: A Cambodian Migrant Worker"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Meet Thailand’s Hottest TikTok Star: A Cambodian Migrant Worker" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-24-at-2.11.22-PM-copy-218x150.png" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2021/02/24/meet-thailands-hottest-tiktok-star-a-cambodian-migrant-worker/" rel="bookmark" title="Meet Thailand’s Hottest TikTok Star: A Cambodian Migrant Worker">Meet Thailand’s Hottest TikTok Star: A Cambodian Migrant Worker</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2021/02/22/miss-grand-mexico-criticized-for-posing-with-buddha-image/" rel="bookmark" class="td-image-wrap" title="‘Miss Grand Mexico’ Criticized For Posing With Buddha Image"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="‘Miss Grand Mexico’ Criticized For Posing With Buddha Image" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/02/missgrand-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2021/02/22/miss-grand-mexico-criticized-for-posing-with-buddha-image/" rel="bookmark" title="‘Miss Grand Mexico’ Criticized For Posing With Buddha Image">‘Miss Grand Mexico’ Criticized For Posing With Buddha Image</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2021/02/15/feb-march-march-luk-thung-earworm-about-calendar-vexes-netizens/" rel="bookmark" class="td-image-wrap" title="Feb! March! March! Luk Thung Earworm About Calendar Vexes Netizens"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Feb! March! March! Luk Thung Earworm About Calendar Vexes Netizens" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-15-at-11.12.22-AM-copy-218x150.png" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2021/02/15/feb-march-march-luk-thung-earworm-about-calendar-vexes-netizens/" rel="bookmark" title="Feb! March! March! Luk Thung Earworm About Calendar Vexes Netizens">Feb! March! March! Luk Thung Earworm About Calendar Vexes Netizens</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_28_62a9707c02ec5" data-td_block_id="td_uid_28_62a9707c02ec5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_28_62a9707c02ec5" data-td_block_id="td_uid_28_62a9707c02ec5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768595"><a href="https://www.khaosodenglish.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_29_62a9707c0b52d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_29_62a9707c0b52d"><script>var block_td_uid_29_62a9707c0b52d = new tdBlock();
block_td_uid_29_62a9707c0b52d.id = "td_uid_29_62a9707c0b52d";
block_td_uid_29_62a9707c0b52d.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"47","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_29_62a9707c0b52d_rand","tdc_css_class":"td_uid_29_62a9707c0b52d_rand","tdc_css_class_style":"td_uid_29_62a9707c0b52d_rand_style"}';
block_td_uid_29_62a9707c0b52d.td_column_number = "3";
block_td_uid_29_62a9707c0b52d.block_type = "td_block_mega_menu";
block_td_uid_29_62a9707c0b52d.post_count = "5";
block_td_uid_29_62a9707c0b52d.found_posts = "543";
block_td_uid_29_62a9707c0b52d.header_color = "";
block_td_uid_29_62a9707c0b52d.ajax_pagination_infinite_stop = "";
block_td_uid_29_62a9707c0b52d.max_num_pages = "109";
tdBlocksArray.push(block_td_uid_29_62a9707c0b52d);
</script><div id=td_uid_29_62a9707c0b52d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2022/06/12/opinion-thailands-marijuana-challenge-lets-not-get-too-high-prematurely/" rel="bookmark" class="td-image-wrap" title="Opinion: Thailand&#8217;s Marijuana Challenge: Let&#8217;s Not Get Too High Prematurely"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Health Minister Anutin Charnvirakul poses with people holding their marijuana plants during the distribution of 1 million free marijuana seedlings in Buriram province on June 10, 2022. Photo: Bhumjaithai Party." title="Opinion: Thailand&#8217;s Marijuana Challenge: Let&#8217;s Not Get Too High Prematurely" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/86479-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2022/06/12/opinion-thailands-marijuana-challenge-lets-not-get-too-high-prematurely/" rel="bookmark" title="Opinion: Thailand&#8217;s Marijuana Challenge: Let&#8217;s Not Get Too High Prematurely">Opinion: Thailand&#8217;s Marijuana Challenge: Let&#8217;s Not Get Too High Prematurely</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2022/06/05/opinion-behold-our-unconscious-political-bias-on-social-media/" rel="bookmark" class="td-image-wrap" title="Opinion: Behold Our Unconscious Political Bias on Social Media"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="A file photo of Facebook, Messenger and Instagram apps displayed on an iPhone. Photo: Jenny Kane / AP" title="Opinion: Behold Our Unconscious Political Bias on Social Media" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/07/THAIPBS_Header-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2022/06/05/opinion-behold-our-unconscious-political-bias-on-social-media/" rel="bookmark" title="Opinion: Behold Our Unconscious Political Bias on Social Media">Opinion: Behold Our Unconscious Political Bias on Social Media</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2022/05/29/opinion-chadcharts-victory-gives-hope-to-not-just-bangkok-but-thai-democracy/" rel="bookmark" class="td-image-wrap" title="Opinion: Chadchart&#8217;s Victory Gives Hope to Not Just Bangkok But Thai Democracy"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Bangkok Governor-elect Chadchart Sittipunt inspects damaged pavement at Bang Kapi&#039;s Lam Sali Intersection on May 25, 2022." title="Opinion: Chadchart&#8217;s Victory Gives Hope to Not Just Bangkok But Thai Democracy" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/05/LINE_ALBUM_220529-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2022/05/29/opinion-chadcharts-victory-gives-hope-to-not-just-bangkok-but-thai-democracy/" rel="bookmark" title="Opinion: Chadchart&#8217;s Victory Gives Hope to Not Just Bangkok But Thai Democracy">Opinion: Chadchart&#8217;s Victory Gives Hope to Not Just Bangkok But Thai&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2022/05/22/opinion-what-can-we-expect-from-leading-candidates-as-new-bangkok-governor/" rel="bookmark" class="td-image-wrap" title="Opinion: What Can We Expect From Leading Candidates as New Bangkok Governor?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Voters line up at a polling station in Bangkok&#039;s Kannayao district to cast their vote for Bangkok gubernatorial election on May 22, 2022." title="Opinion: What Can We Expect From Leading Candidates as New Bangkok Governor?" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/05/S__5750870-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2022/05/22/opinion-what-can-we-expect-from-leading-candidates-as-new-bangkok-governor/" rel="bookmark" title="Opinion: What Can We Expect From Leading Candidates as New Bangkok Governor?">Opinion: What Can We Expect From Leading Candidates as New Bangkok&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2022/05/15/opinion-as-bangkokians-gear-up-to-elect-their-own-governor-after-9-years-people-in-the-provinces-continue-to-wait-after-a-century/" rel="bookmark" class="td-image-wrap" title="Opinion: As Bangkokians Gear Up to Elect Their Own Governor After 9 Years, People in the Provinces Continue to Wait After a Century"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Workers set up polling station for the upcoming Bangkok gubernatorial election on May 15, 2022." title="Opinion: As Bangkokians Gear Up to Elect Their Own Governor After 9 Years, People in the Provinces Continue to Wait After a Century" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/05/S__3350544-218x150.jpeg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2022/05/15/opinion-as-bangkokians-gear-up-to-elect-their-own-governor-after-9-years-people-in-the-provinces-continue-to-wait-after-a-century/" rel="bookmark" title="Opinion: As Bangkokians Gear Up to Elect Their Own Governor After 9 Years, People in the Provinces Continue to Wait After a Century">Opinion: As Bangkokians Gear Up to Elect Their Own Governor After&#8230;</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_29_62a9707c0b52d" data-td_block_id="td_uid_29_62a9707c0b52d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_29_62a9707c0b52d" data-td_block_id="td_uid_29_62a9707c0b52d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768589"><a href="https://www.khaosodenglish.com/category/news/asean/">ASEAN</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_62a9707c10f87_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_30_62a9707c10f87"><script>var block_td_uid_30_62a9707c10f87 = new tdBlock();
block_td_uid_30_62a9707c10f87.id = "td_uid_30_62a9707c10f87";
block_td_uid_30_62a9707c10f87.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"52","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_30_62a9707c10f87_rand","tdc_css_class":"td_uid_30_62a9707c10f87_rand","tdc_css_class_style":"td_uid_30_62a9707c10f87_rand_style"}';
block_td_uid_30_62a9707c10f87.td_column_number = "3";
block_td_uid_30_62a9707c10f87.block_type = "td_block_mega_menu";
block_td_uid_30_62a9707c10f87.post_count = "5";
block_td_uid_30_62a9707c10f87.found_posts = "1364";
block_td_uid_30_62a9707c10f87.header_color = "";
block_td_uid_30_62a9707c10f87.ajax_pagination_infinite_stop = "";
block_td_uid_30_62a9707c10f87.max_num_pages = "273";
tdBlocksArray.push(block_td_uid_30_62a9707c10f87);
</script><div id=td_uid_30_62a9707c10f87 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/2021/03/09/myanmar-protesters-defy-curfew-media-outlets-ordered-shut/" rel="bookmark" class="td-image-wrap" title="Myanmar Protesters Defy Curfew; Media Outlets Ordered Shut"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Myanmar Protesters Defy Curfew; Media Outlets Ordered Shut" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/03/AP21068061561975-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/2021/03/09/myanmar-protesters-defy-curfew-media-outlets-ordered-shut/" rel="bookmark" title="Myanmar Protesters Defy Curfew; Media Outlets Ordered Shut">Myanmar Protesters Defy Curfew; Media Outlets Ordered Shut</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2019/11/12/myanmar-accused-at-un-court-of-genocide-against-rohingya/" rel="bookmark" class="td-image-wrap" title="Myanmar Accused at UN Court of Genocide Against Rohingya"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="-FILE- In this Tuesday, Sept. 5, 2017, file photo members of Myanmar&#039;s Rohingya ethnic minority walk through rice fields after crossing the border into Bangladesh near Cox&#039;s Bazar&#039;s Teknaf area. Gambia has filed a case at the United Nations&#039; highest court in The Hague, Netherlands, Monday, Nov. 11, 2019, accusing Myanmar of genocide in its campaign against the Rohingya Muslim minority. A statement released Monday by lawyers for Gambia says the case also asks the International Court of Justice to order measures &quot;to stop Myanmar&#039;s genocidal conduct immediately.&quot; Photo: Bernat Armangue / AP File" title="Myanmar Accused at UN Court of Genocide Against Rohingya" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/AP19315378442630-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2019/11/12/myanmar-accused-at-un-court-of-genocide-against-rohingya/" rel="bookmark" title="Myanmar Accused at UN Court of Genocide Against Rohingya">Myanmar Accused at UN Court of Genocide Against Rohingya</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2019/11/01/us-official-urges-asean-to-stand-up-to-china-in-sea-row/" rel="bookmark" class="td-image-wrap" title="US Official Urges ASEAN to Stand up to China in Sea Row"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="David Stilwell, the U.S. State Department’s assistant secretary for East Asia and the Pacific, left, speaks during a forum in Kuala Lumpur, Thursday, Oct. 31, 2019. The senior U.S. official says a free and open Indo-Pacific concept is not a move to expand U.S. domination but reflects Washington’s “enduring engagement” to prosper the region. Photo: Vincent Thian / AP" title="US Official Urges ASEAN to Stand up to China in Sea Row" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/AP19304154940604-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2019/11/01/us-official-urges-asean-to-stand-up-to-china-in-sea-row/" rel="bookmark" title="US Official Urges ASEAN to Stand up to China in Sea Row">US Official Urges ASEAN to Stand up to China in Sea&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2019/11/01/police-say-body-of-british-tourist-missing-in-cambodia-found/" rel="bookmark" class="td-image-wrap" title="Police Say Body of British Tourist Missing in Cambodia Found"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Roy Bambridge uncle of missing British backpacker Amelia Bambridge talks on his mobile phone in Koh Rong island, southwestern Cambodia, Thursday, Oct. 31, 2019. Around 150 people are taking part in the search for Bambridge who has not been seen since last Wednesday night when she attended a beach party on the island joined by tourists of various nationalities. Photo: Heng Sinith / AP" title="Police Say Body of British Tourist Missing in Cambodia Found" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/AP19304135216933-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2019/11/01/police-say-body-of-british-tourist-missing-in-cambodia-found/" rel="bookmark" title="Police Say Body of British Tourist Missing in Cambodia Found">Police Say Body of British Tourist Missing in Cambodia Found</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/asean/2019/10/21/widodo-begins-2nd-term-pledging-to-make-indonesia-developed/" rel="bookmark" class="td-image-wrap" title="Widodo Begins 2nd Term Pledging to Make Indonesia Developed"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Indonesian President Joko Widodo, center, smiles as he speaks to the media upon arrival after his inauguration for his second term, at Merdeka Palace in Jakarta, Indonesia, Sunday, Oct. 20, 2019. Widodo, who rose from poverty and pledged to champion democracy, fight entrenched corruption and modernize the world&#039;s most populous Muslim-majority nation, was sworn in Sunday for his second and final five-year term with a pledge to take bolder actions. Photo: Dita Alangkara / AP" title="Widodo Begins 2nd Term Pledging to Make Indonesia Developed" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/10/AP19293413715448-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/asean/2019/10/21/widodo-begins-2nd-term-pledging-to-make-indonesia-developed/" rel="bookmark" title="Widodo Begins 2nd Term Pledging to Make Indonesia Developed">Widodo Begins 2nd Term Pledging to Make Indonesia Developed</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_62a9707c10f87" data-td_block_id="td_uid_30_62a9707c10f87"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_30_62a9707c10f87" data-td_block_id="td_uid_30_62a9707c10f87"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464825008"><a href="https://www.khaosodenglish.com/category/videos/">Videos</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_31_62a9707c17639_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_31_62a9707c17639"><script>var block_td_uid_31_62a9707c17639 = new tdBlock();
block_td_uid_31_62a9707c17639.id = "td_uid_31_62a9707c17639";
block_td_uid_31_62a9707c17639.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"46","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_31_62a9707c17639_rand","tdc_css_class":"td_uid_31_62a9707c17639_rand","tdc_css_class_style":"td_uid_31_62a9707c17639_rand_style"}';
block_td_uid_31_62a9707c17639.td_column_number = "3";
block_td_uid_31_62a9707c17639.block_type = "td_block_mega_menu";
block_td_uid_31_62a9707c17639.post_count = "5";
block_td_uid_31_62a9707c17639.found_posts = "238";
block_td_uid_31_62a9707c17639.header_color = "";
block_td_uid_31_62a9707c17639.ajax_pagination_infinite_stop = "";
block_td_uid_31_62a9707c17639.max_num_pages = "48";
tdBlocksArray.push(block_td_uid_31_62a9707c17639);
</script><div id=td_uid_31_62a9707c17639 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/food/2020/09/25/this-thai-hakka-street-food-snack-has-all-but-disappeared/" rel="bookmark" class="td-image-wrap" title="This Thai-Hakka Street Food Snack Has All But Disappeared"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="This Thai-Hakka Street Food Snack Has All But Disappeared" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/09/8-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/food/2020/09/25/this-thai-hakka-street-food-snack-has-all-but-disappeared/" rel="bookmark" title="This Thai-Hakka Street Food Snack Has All But Disappeared">This Thai-Hakka Street Food Snack Has All But Disappeared</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/featured/2019/12/27/khaosod-englishs-top-6-watched-videos-of-2019/" rel="bookmark" class="td-image-wrap" title="Khaosod English’s Top 6 Watched Videos of 2019"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Bua Noi the gorilla, left, The Last Overland team leader Alex Bescoby, center, and Miss Universe Thailand 2019 Jennifer Paweensuda “Fahsai” Drouin, right." title="Khaosod English’s Top 6 Watched Videos of 2019" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/12/YEAREND_VIDEOS_Header-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/featured/2019/12/27/khaosod-englishs-top-6-watched-videos-of-2019/" rel="bookmark" title="Khaosod English’s Top 6 Watched Videos of 2019">Khaosod English’s Top 6 Watched Videos of 2019</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/20/surreal-video-of-grandma-slapping-student-to-christmas-carols-goes-viral/" rel="bookmark" class="td-image-wrap" title="Surreal Video of Grandma Slapping Student to Christmas Carols Goes Viral"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Surreal Video of Grandma Slapping Student to Christmas Carols Goes Viral" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/12/slap-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/20/surreal-video-of-grandma-slapping-student-to-christmas-carols-goes-viral/" rel="bookmark" title="Surreal Video of Grandma Slapping Student to Christmas Carols Goes Viral">Surreal Video of Grandma Slapping Student to Christmas Carols Goes Viral</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/04/american-on-phuket-fined-for-fighting-with-burmese-waiters-over-seafood-order-video/" rel="bookmark" class="td-image-wrap" title="American on Phuket Fined for Fighting With Burmese Waiters Over Seafood Order (Video)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="A still from CCTV footage showing a brawl between a foreigner and wait staff outside a restaurant on Karon Beach on Dec. 2, 2019." title="American on Phuket Fined for Fighting With Burmese Waiters Over Seafood Order (Video)" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/12/AMERICAN_Header-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/04/american-on-phuket-fined-for-fighting-with-burmese-waiters-over-seafood-order-video/" rel="bookmark" title="American on Phuket Fined for Fighting With Burmese Waiters Over Seafood Order (Video)">American on Phuket Fined for Fighting With Burmese Waiters Over Seafood&#8230;</a></h3> </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/videos/2019/11/15/colombian-priest-in-thailand-translates-pope-welcome-song-into-spanish/" rel="bookmark" class="td-image-wrap" title="Colombian Priest in Thailand Translates Pope Welcome Song into Spanish (Video)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Colombian Priest in Thailand Translates Pope Welcome Song into Spanish (Video)" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/maxresdefault-218x150.jpg" width="218" height="150" /><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://www.khaosodenglish.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video" /></span></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/videos/2019/11/15/colombian-priest-in-thailand-translates-pope-welcome-song-into-spanish/" rel="bookmark" title="Colombian Priest in Thailand Translates Pope Welcome Song into Spanish (Video)">Colombian Priest in Thailand Translates Pope Welcome Song into Spanish (Video)</a></h3> </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_31_62a9707c17639" data-td_block_id="td_uid_31_62a9707c17639"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_31_62a9707c17639" data-td_block_id="td_uid_31_62a9707c17639"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> </div></div></li>
</ul>
</li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.khaosodenglish.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in dot.Net" class="entry-crumb" href="https://www.khaosodenglish.com/category/culture/net/">dot.Net</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">So Long, Internet Explorer. The Browser Retires Today</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-1464881636" class="post-1464881636 post type-post status-publish format-standard has-post-thumbnail category-net category-international tag-tech" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a style="background-color:#e5296d; color:#fff; border-color:#e5296d;" href="https://www.khaosodenglish.com/category/culture/">Culture</a></li><li class="entry-category"><a style="background-color:#9440dd; color:#fff; border-color:#9440dd;" href="https://www.khaosodenglish.com/category/culture/net/">dot.Net</a></li><li class="entry-category"><a style="background-color:#d52432; color:#fff; border-color:#d52432;" href="https://www.khaosodenglish.com/category/news/">News</a></li><li class="entry-category"><a style="background-color:#432b79; color:#fff; border-color:#432b79;" href="https://www.khaosodenglish.com/category/news/international/">International</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">So Long, Internet Explorer. The Browser Retires Today</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.khaosodenglish.com/author/ap/">Associated Press</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2022-06-15T12:30:38+00:00">June 15, 2022 12:30 pm</time></span> </div>
</header>
</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2022%2F06%2F15%2Fso-long-internet-explorer-the-browser-retires-today%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today&url=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2022%2F06%2F15%2Fso-long-internet-explorer-the-browser-retires-today%2F&via=KhaosodEnglish">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today%0D%0Ahttps://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/">
<div class="td-social-but-icon"><i class="td-icon-line"></i></div>
<div class="td-social-but-text">LINE</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today %0A%0A https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/&amp;media=https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823.jpeg&description=So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/&title=So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/">
<div class="td-social-but-icon"><i class="td-icon-vk"></i></div>
<div class="td-social-but-text">VK</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content">
<div class="td-post-featured-image"><figure><img width="696" height="406" class="entry-thumb" src="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-696x406.jpeg" srcset="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-696x406.jpeg 696w, https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-300x175.jpeg 300w, https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-768x449.jpeg 768w, https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-250x146.jpeg 250w, https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-500x292.jpeg 500w, https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823-719x420.jpeg 719w, https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823.jpeg 1024w" sizes="(max-width: 696px) 100vw, 696px" alt="FILE - The Microsoft Internet Explorer logo is projected on a screen during a Microsoft Xbox E3 media briefing in Los Angeles, June 4, 2012. Photo: Damian Dovarganes / AP File" title="FILE - The Microsoft Internet Explorer logo is projected on a screen during a Microsoft Xbox E3 media briefing in Los Angeles, June 4, 2012. Photo: Damian Dovarganes / AP File" /><figcaption class="wp-caption-text">FILE - The Microsoft Internet Explorer logo is projected on a screen during a Microsoft Xbox E3 media briefing in Los Angeles, June 4, 2012. Photo: Damian Dovarganes / AP File</figcaption></figure></div>
<div class="td-a-rec td-a-rec-id-content_top  td_uid_33_62a9707c1f44f_rand td_block_template_1">
</div>
<div id="dablewidget_2XnGJxod" data-widget_id="2XnGJxod">
<script> 
(function(d,a,b,l,e,_) { if(d[b]&&d[b].q)return;d[b]=function(){(d[b].q=d[b].q||[]).push(arguments)};e=a.createElement(l); e.async=1;e.charset='utf-8';e.src='//static.dable.io/dist/plugin.min.js'; _=a.getElementsByTagName(l)[0];_.parentNode.insertBefore(e,_); })(window,document,'dable','script'); 
dable('setService', 'khaosodenglish.com'); 
dable('sendLogOnce'); 
dable('renderWidget', 'dablewidget_2XnGJxod'); 
</script>
</div>
<p><strong>SAN FRANCISCO (AP)</strong> — Internet Explorer is finally headed out to pasture.</p>
<p>As of Wednesday, Microsoft will no longer support the once-dominant browser that legions of web surfers loved to hate — and a few still claim to adore. The 27-year-old application now joins BlackBerry phones, dial-up modems and Palm Pilots in the dustbin of tech history.</p>
<p>IE&#8217;s demise was not a surprise. A year ago, Microsoft said that it was putting an end to Internet Explorer on June 15, 2022, pushing users to its Edge browser, which was launched in 2015.</p>
<p>The company made clear then it was time to move on.</p><div class="td-a-rec td-a-rec-id-content_inlineright  td_uid_32_62a9707c1eff7_rand td_block_template_1"><div id='div-gpt-ad-1471511141011-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1471511141011-0'); });
</script>
</div>
</div>
<p>“Not only is Microsoft Edge a faster, more secure and more modern browsing experience than Internet Explorer, but it is also able to address a key concern: compatibility for older, legacy websites and applications,” Sean Lyndersay, general manager of Microsoft Edge Enterprise, wrote in <strong><a href="https://blogs.windows.com/windowsexperience/2021/05/19/the-future-of-internet-explorer-on-windows-10-is-in-microsoft-edge/" target="_blank" rel="noopener">a May 2021 blog post.</a></strong></p>
<p><a href="https://twitter.com/search?q=%23InternetExplorer&amp;src=typeahead_click" target="_blank" rel="noopener"><strong>Users marked Explorer’s passing</strong></a> on Twitter, with some referring to it as a “bug-ridden, insecure POS” or the “top browser for installing other browsers.” For others it was a moment for 90′s nostalgia memes, while The Wall Street Journal quoted a 22-year-old who was <strong><a href="https://www.wsj.com/articles/sure-microsoft-internet-explorer-browser-had-its-faults-but-fans-are-mourning-its-death-anyway-11655226882?mod=hp_featst_pos5" target="_blank" rel="noopener">sad to see IE go</a></strong>.</p>
<p>Microsoft released the first version of Internet Explorer in 1995, the antediluvian era of web surfing dominated by the first widely popular browser, Netscape Navigator. Its launch signaled the beginning of the end of Navigator: Microsoft went on to tie IE and its ubiquitous Windows operating system together so tightly that many people simply used it by default instead of Navigator.</p>
<p>The Justice Department sued Microsoft in 1997, saying it violated an earlier consent decree by requiring computer makers to use its browser as a condition of using Windows. It eventually agreed to settle the antitrust battle in 2002 over its use of its Windows monopoly to squash competitors. It also tangled with European regulators who said that tying Internet Explorer to Windows gave it an unfair advantage over rivals such as Mozilla’s Firefox, Opera and Google’s Chrome.</p>
<p>Users, meanwhile, complained that IE was slow, prone to crashing and vulnerable to hacks. IE&#8217;s market share, which in the early 2000s was over 90%, began to fade as users found more appealing alternatives.</p>
<p>Today, the Chrome browser dominates with roughly a 65% share of the worldwide browser market, followed by Apple’s Safari with 19%, according to internet analytics company Statcounter. IE&#8217;s heir, Edge, lags with about about 4%, just ahead of Firefox.</p>
<p>___</p>
<p><em>Story: Richard Jacobsen.</em></p>
<div class="td-a-rec td-a-rec-id-content_bottom  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p td_uid_34_62a9707c1fa6a_rand td_block_template_1"></div>  </div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.khaosodenglish.com/tag/tech/">Tech</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2022%2F06%2F15%2Fso-long-internet-explorer-the-browser-retires-today%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today&url=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Finternational%2F2022%2F06%2F15%2Fso-long-internet-explorer-the-browser-retires-today%2F&via=KhaosodEnglish">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today%0D%0Ahttps://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/">
<div class="td-social-but-icon"><i class="td-icon-line"></i></div>
<div class="td-social-but-text">LINE</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today %0A%0A https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/&amp;media=https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823.jpeg&description=So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/&title=So+Long%2C+Internet+Explorer.+The+Browser+Retires+Today">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/">
<div class="td-social-but-icon"><i class="td-icon-vk"></i></div>
<div class="td-social-but-text">VK</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.khaosodenglish.com/news/international/2022/06/15/russians-control-80-of-key-ukraine-city-cut-escape-routes/">Russians Control 80% Of Key Ukraine City, Cut Escape Routes</a></div></div><div class="td-next-prev-separator"></div></div> <div class="author-box-wrap"><a href="https://www.khaosodenglish.com/author/ap/"><img alt='' src='https://secure.gravatar.com/avatar/5e6a9fa95f61663e23555842683a8444?s=96&#038;d=blank&#038;r=pg' srcset='https://secure.gravatar.com/avatar/5e6a9fa95f61663e23555842683a8444?s=192&#038;d=blank&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.khaosodenglish.com/author/ap/">Associated Press</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Associated Press"></span><meta itemprop="datePublished" content="2022-06-15T12:30:38+00:00"><meta itemprop="dateModified" content="2022-06-15T12:37:40+07:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo.gif"></span><meta itemprop="name" content="Khaosod English"></span><meta itemprop="headline " content="So Long, Internet Explorer. The Browser Retires Today"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22166048903823.jpeg"><meta itemprop="width" content="1024"><meta itemprop="height" content="598"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts td_uid_35_62a9707c218ac_rand td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_35_62a9707c218ac"><script>var block_td_uid_35_62a9707c218ac = new tdBlock();
block_td_uid_35_62a9707c218ac.id = "td_uid_35_62a9707c218ac";
block_td_uid_35_62a9707c218ac.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"td_uid_35_62a9707c218ac_rand","td_column_number":3,"live_filter_cur_post_id":1464881636,"live_filter_cur_post_author":"8","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_35_62a9707c218ac_rand","tdc_css_class_style":"td_uid_35_62a9707c218ac_rand_style"}';
block_td_uid_35_62a9707c218ac.td_column_number = "3";
block_td_uid_35_62a9707c218ac.block_type = "td_block_related_posts";
block_td_uid_35_62a9707c218ac.post_count = "6";
block_td_uid_35_62a9707c218ac.found_posts = "170";
block_td_uid_35_62a9707c218ac.header_color = "";
block_td_uid_35_62a9707c218ac.ajax_pagination_infinite_stop = "";
block_td_uid_35_62a9707c218ac.max_num_pages = "29";
tdBlocksArray.push(block_td_uid_35_62a9707c218ac);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_36_62a9707c23c92" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_35_62a9707c218ac" href="#">RELATED ARTICLES</a><a id="td_uid_37_62a9707c23c98" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_35_62a9707c218ac" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_35_62a9707c218ac class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/business/2021/11/23/dtac-and-true-to-merge-pursue-tech-businesses/" rel="bookmark" class="td-image-wrap" title="DTAC and True to Merge, Pursue Tech Businesses"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="DTAC and True to Merge, Pursue Tech Businesses" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/11/AP21326315642725-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/business/2021/11/23/dtac-and-true-to-merge-pursue-tech-businesses/" rel="bookmark" title="DTAC and True to Merge, Pursue Tech Businesses">DTAC and True to Merge, Pursue Tech Businesses</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2021/10/29/in-the-middle-of-a-crisis-facebook-inc-renames-itself-meta/" rel="bookmark" class="td-image-wrap" title="In the Middle of a Crisis, Facebook Inc. Renames Itself Meta"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="In the Middle of a Crisis, Facebook Inc. Renames Itself Meta" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/10/AP21301735595969-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2021/10/29/in-the-middle-of-a-crisis-facebook-inc-renames-itself-meta/" rel="bookmark" title="In the Middle of a Crisis, Facebook Inc. Renames Itself Meta">In the Middle of a Crisis, Facebook Inc. Renames Itself Meta</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2021/08/20/onlyfans-to-ban-sexually-explicit-content/" rel="bookmark" class="td-image-wrap" title="OnlyFans to Ban ‘Sexually Explicit’ Content"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="OnlyFans to Ban ‘Sexually Explicit’ Content" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/08/AP21231777294513-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2021/08/20/onlyfans-to-ban-sexually-explicit-content/" rel="bookmark" title="OnlyFans to Ban ‘Sexually Explicit’ Content">OnlyFans to Ban ‘Sexually Explicit’ Content</a></h3> </div>
</div>
</div> </div>
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2021/06/09/global-sting-began-by-creating-message-service-for-crooks/" rel="bookmark" class="td-image-wrap" title="Global Sting Began by Creating Message Service for Crooks"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Global Sting Began by Creating Message Service for Crooks" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/06/AP21159629902861-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2021/06/09/global-sting-began-by-creating-message-service-for-crooks/" rel="bookmark" title="Global Sting Began by Creating Message Service for Crooks">Global Sting Began by Creating Message Service for Crooks</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2021/06/08/global-glitch-swaths-of-internet-go-down-after-cloud-outage/" rel="bookmark" class="td-image-wrap" title="Global Glitch: Swaths of Internet Go Down After Cloud Outage"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Global Glitch: Swaths of Internet Go Down After Cloud Outage" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/06/AP21159381212416-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2021/06/08/global-glitch-swaths-of-internet-go-down-after-cloud-outage/" rel="bookmark" title="Global Glitch: Swaths of Internet Go Down After Cloud Outage">Global Glitch: Swaths of Internet Go Down After Cloud Outage</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2021/05/05/facebook-boards-trump-decision-could-have-wider-impacts/" rel="bookmark" class="td-image-wrap" title="Facebook Board&#8217;s Trump Decision Could Have Wider Impacts"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Facebook Board&#8217;s Trump Decision Could Have Wider Impacts" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/05/AP21123508600926-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2021/05/05/facebook-boards-trump-decision-could-have-wider-impacts/" rel="bookmark" title="Facebook Board&#8217;s Trump Decision Could Have Wider Impacts">Facebook Board&#8217;s Trump Decision Could Have Wider Impacts</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_35_62a9707c218ac" data-td_block_id="td_uid_35_62a9707c218ac"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_35_62a9707c218ac" data-td_block_id="td_uid_35_62a9707c218ac"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget">
</div></aside><div class="td_block_wrap td_block_9 td_block_widget td_uid_38_62a9707c295d8_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding td_block_bot_line" data-td-block-uid="td_uid_38_62a9707c295d8">
<style>
.td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-pulldown-filter-link:hover,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-subcat-item a:hover,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-subcat-item .td-cur-simple-item {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .block-title > *,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-subcat-dropdown:hover .td-subcat-more {
                background-color: #d62532;
            }
            .td-theme-wrap .td-footer-wrapper .td_uid_38_62a9707c295d8_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .block-title {
                border-color: #d62532;
            }

            
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td_quote_on_blocks,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-instagram-user a {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-next-prev-wrap a:hover,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-load-more-wrap a:hover {
                background-color: #d62532;
                border-color: #d62532;
            }

            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-read-more a,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-weather-information:before,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-weather-week:before,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .td_uid_38_62a9707c295d8_rand .td-post-category,
            .td-theme-wrap .td_uid_38_62a9707c295d8_rand .td-post-category:hover {
                background-color: #d62532;
            }
</style><script>var block_td_uid_38_62a9707c295d8 = new tdBlock();
block_td_uid_38_62a9707c295d8.id = "td_uid_38_62a9707c295d8";
block_td_uid_38_62a9707c295d8.atts = '{"custom_title":"LATEST NEWS","custom_url":"","block_template_id":"","header_color":"#d62532","header_text_color":"#","accent_text_color":"#","m8_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"-109,-639","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_38_62a9707c295d8_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_settings":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_settings":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_settings":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_38_62a9707c295d8_rand","tdc_css_class_style":"td_uid_38_62a9707c295d8_rand_style"}';
block_td_uid_38_62a9707c295d8.td_column_number = "1";
block_td_uid_38_62a9707c295d8.block_type = "td_block_9";
block_td_uid_38_62a9707c295d8.post_count = "5";
block_td_uid_38_62a9707c295d8.found_posts = "23735";
block_td_uid_38_62a9707c295d8.header_color = "#d62532";
block_td_uid_38_62a9707c295d8.ajax_pagination_infinite_stop = "";
block_td_uid_38_62a9707c295d8.max_num_pages = "4747";
tdBlocksArray.push(block_td_uid_38_62a9707c295d8);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">LATEST NEWS</span></h4></div><div id=td_uid_38_62a9707c295d8 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_8 td_module_wrap">
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/so-long-internet-explorer-the-browser-retires-today/" rel="bookmark" title="So Long, Internet Explorer. The Browser Retires Today">So Long, Internet Explorer. The Browser Retires Today</a></h3>
<div class="td-module-meta-info">
</div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_8 td_module_wrap">
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/russians-control-80-of-key-ukraine-city-cut-escape-routes/" rel="bookmark" title="Russians Control 80% Of Key Ukraine City, Cut Escape Routes">Russians Control 80% Of Key Ukraine City, Cut Escape Routes</a></h3>
<div class="td-module-meta-info">
</div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_8 td_module_wrap">
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/14/cambodian-court-convicts-lawyer-dozens-of-others-of-treason/" rel="bookmark" title="Cambodian Court Convicts Lawyer, Dozens of Others of Treason">Cambodian Court Convicts Lawyer, Dozens of Others of Treason</a></h3>
<div class="td-module-meta-info">
</div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_8 td_module_wrap">
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/14/jan-6-panel-hears-trump-detached-from-reality-in-defeat/" rel="bookmark" title="Jan. 6 Panel Hears: Trump &#8216;Detached From Reality&#8217; in Defeat">Jan. 6 Panel Hears: Trump &#8216;Detached From Reality&#8217; in Defeat</a></h3>
<div class="td-module-meta-info">
</div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_8 td_module_wrap">
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2022/06/12/opinion-thailands-marijuana-challenge-lets-not-get-too-high-prematurely/" rel="bookmark" title="Opinion: Thailand&#8217;s Marijuana Challenge: Let&#8217;s Not Get Too High Prematurely">Opinion: Thailand&#8217;s Marijuana Challenge: Let&#8217;s Not Get Too High Prematurely</a></h3>
<div class="td-module-meta-info">
</div>
</div>
</div>
</div> </div></div> <aside class="td_block_template_1 widget widget_mc4wp_form_widget"><h4 class="block-title"><span>GET KHAOSOD ENGLISH BY MAIL</span></h4><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-1464787522" method="post" data-id="1464787522" data-name="Get Khaosod English by mail. Binge-read when you want."><div class="mc4wp-form-fields"><p>
<label>Newsletter: </label>
<input type="email" name="EMAIL" placeholder="Your email address" required />
</p> <input type="submit" value="Sign up" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1655271548" /><input type="hidden" name="_mc4wp_form_id" value="1464787522" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside><div class="td_block_wrap td_block_13 td_block_widget td_uid_39_62a9707c34e49_rand td-pb-border-top td_block_template_1 td-column-1" data-td-block-uid="td_uid_39_62a9707c34e49">
<style>
.td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-pulldown-filter-link:hover,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-subcat-item a:hover,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-subcat-item .td-cur-simple-item {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .block-title > *,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-subcat-dropdown:hover .td-subcat-more {
                background-color: #d62532;
            }
            .td-theme-wrap .td-footer-wrapper .td_uid_39_62a9707c34e49_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .block-title {
                border-color: #d62532;
            }

            
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td_quote_on_blocks,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-instagram-user a {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-next-prev-wrap a:hover,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-load-more-wrap a:hover {
                background-color: #d62532;
                border-color: #d62532;
            }

            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-read-more a,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-weather-information:before,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-weather-week:before,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .td_uid_39_62a9707c34e49_rand .td-post-category,
            .td-theme-wrap .td_uid_39_62a9707c34e49_rand .td-post-category:hover {
                background-color: #d62532;
            }
</style><script>var block_td_uid_39_62a9707c34e49 = new tdBlock();
block_td_uid_39_62a9707c34e49.id = "td_uid_39_62a9707c34e49";
block_td_uid_39_62a9707c34e49.atts = '{"custom_title":"COMING UP IN BANGKOK","custom_url":"","block_template_id":"","header_color":"#d62532","header_text_color":"#","accent_text_color":"#","mx3_tl":"","m14_tl":"","m14_el":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"123","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_39_62a9707c34e49_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx3f_title_font_header":"","mx3f_title_font_title":"Article title","mx3f_title_font_settings":"","mx3f_title_font_family":"","mx3f_title_font_size":"","mx3f_title_font_line_height":"","mx3f_title_font_style":"","mx3f_title_font_weight":"","mx3f_title_font_transform":"","mx3f_title_font_spacing":"","mx3f_title_":"","mx3f_cat_font_title":"Article category tag","mx3f_cat_font_settings":"","mx3f_cat_font_family":"","mx3f_cat_font_size":"","mx3f_cat_font_line_height":"","mx3f_cat_font_style":"","mx3f_cat_font_weight":"","mx3f_cat_font_transform":"","mx3f_cat_font_spacing":"","mx3f_cat_":"","mx3f_meta_font_title":"Article meta info","mx3f_meta_font_settings":"","mx3f_meta_font_family":"","mx3f_meta_font_size":"","mx3f_meta_font_line_height":"","mx3f_meta_font_style":"","mx3f_meta_font_weight":"","mx3f_meta_font_transform":"","mx3f_meta_font_spacing":"","mx3f_meta_":"","m14f_title_font_header":"","m14f_title_font_title":"Article title","m14f_title_font_settings":"","m14f_title_font_family":"","m14f_title_font_size":"","m14f_title_font_line_height":"","m14f_title_font_style":"","m14f_title_font_weight":"","m14f_title_font_transform":"","m14f_title_font_spacing":"","m14f_title_":"","m14f_cat_font_title":"Article category tag","m14f_cat_font_settings":"","m14f_cat_font_family":"","m14f_cat_font_size":"","m14f_cat_font_line_height":"","m14f_cat_font_style":"","m14f_cat_font_weight":"","m14f_cat_font_transform":"","m14f_cat_font_spacing":"","m14f_cat_":"","m14f_meta_font_title":"Article meta info","m14f_meta_font_settings":"","m14f_meta_font_family":"","m14f_meta_font_size":"","m14f_meta_font_line_height":"","m14f_meta_font_style":"","m14f_meta_font_weight":"","m14f_meta_font_transform":"","m14f_meta_font_spacing":"","m14f_meta_":"","m14f_ex_font_title":"Article excerpt","m14f_ex_font_settings":"","m14f_ex_font_family":"","m14f_ex_font_size":"","m14f_ex_font_line_height":"","m14f_ex_font_style":"","m14f_ex_font_weight":"","m14f_ex_font_transform":"","m14f_ex_font_spacing":"","m14f_ex_":"","m14f_btn_font_title":"Article read more button","m14f_btn_font_settings":"","m14f_btn_font_family":"","m14f_btn_font_size":"","m14f_btn_font_line_height":"","m14f_btn_font_style":"","m14f_btn_font_weight":"","m14f_btn_font_transform":"","m14f_btn_font_spacing":"","m14f_btn_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_39_62a9707c34e49_rand","tdc_css_class_style":"td_uid_39_62a9707c34e49_rand_style"}';
block_td_uid_39_62a9707c34e49.td_column_number = "1";
block_td_uid_39_62a9707c34e49.block_type = "td_block_13";
block_td_uid_39_62a9707c34e49.post_count = "5";
block_td_uid_39_62a9707c34e49.found_posts = "1151";
block_td_uid_39_62a9707c34e49.header_color = "#d62532";
block_td_uid_39_62a9707c34e49.ajax_pagination_infinite_stop = "";
block_td_uid_39_62a9707c34e49.max_num_pages = "231";
tdBlocksArray.push(block_td_uid_39_62a9707c34e49);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">COMING UP IN BANGKOK</span></h4></div><div id=td_uid_39_62a9707c34e49 class="td_block_inner">
<div class="td_module_mx3 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/events/2022/04/27/justin-bieber-coming-to-bangkok-in-november/" rel="bookmark" class="td-image-wrap" title="&#8216;Justin Bieber&#8217; Coming to Bangkok in November"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC" alt="Photo: Tero Asia" title="&#8216;Justin Bieber&#8217; Coming to Bangkok in November" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/04/JUSTIN-BIEBER_02-324x235.jpeg" width="324" height="235" /></a></div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/events/2022/04/27/justin-bieber-coming-to-bangkok-in-november/" rel="bookmark" title="&#8216;Justin Bieber&#8217; Coming to Bangkok in November">&#8216;Justin Bieber&#8217; Coming to Bangkok in November</a></h3> </div>
</div>
<div class="td_module_mx3 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2022/03/25/100-objects-of-political-campaigns-on-exhibit-till-sunday/" rel="bookmark" class="td-image-wrap" title="100 Objects of Political Campaigns On Exhibit Till Sunday"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC" alt="Anon Chawalawan at his exhibition of objects related to Thai political conflicts at Kinjai Contemporary." title="100 Objects of Political Campaigns On Exhibit Till Sunday" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/03/111110-e1648210094756-324x235.jpg" width="324" height="235" /></a></div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2022/03/25/100-objects-of-political-campaigns-on-exhibit-till-sunday/" rel="bookmark" title="100 Objects of Political Campaigns On Exhibit Till Sunday">100 Objects of Political Campaigns On Exhibit Till Sunday</a></h3> </div>
</div>
<div class="td_module_mx3 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/2022/02/04/the-maestro-gets-bangkok-screening-for-limited-time/" rel="bookmark" class="td-image-wrap" title="&#8216;The Maestro&#8217; Gets Bangkok Screening for Limited Time"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC" alt="A scene from &quot;The Maestro: A Symphony Of Terror.&quot;" title="&#8216;The Maestro&#8217; Gets Bangkok Screening for Limited Time" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/02/The-Maestro-A-Symphony-of-Terror_1-324x235.jpeg" width="324" height="235" /></a></div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/2022/02/04/the-maestro-gets-bangkok-screening-for-limited-time/" rel="bookmark" title="&#8216;The Maestro&#8217; Gets Bangkok Screening for Limited Time">&#8216;The Maestro&#8217; Gets Bangkok Screening for Limited Time</a></h3> </div>
</div>
<div class="td_module_mx3 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/events/2022/01/26/in-case-miss-the-old-prayut-see-min-ong-lais-deeds-on-exhibit-in-bangkok/" rel="bookmark" class="td-image-wrap" title="In Case You Miss the Old Prayut, See Min Aung Hlaing’s Deeds on Exhibit in Bangkok"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC" alt="Wathanta Aung / yangon.design." title="In Case You Miss the Old Prayut, See Min Aung Hlaing’s Deeds on Exhibit in Bangkok" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/01/94248-324x235.jpg" width="324" height="235" /></a></div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/events/2022/01/26/in-case-miss-the-old-prayut-see-min-ong-lais-deeds-on-exhibit-in-bangkok/" rel="bookmark" title="In Case You Miss the Old Prayut, See Min Aung Hlaing’s Deeds on Exhibit in Bangkok">In Case You Miss the Old Prayut, See Min Aung Hlaing’s Deeds on Exhibit in Bangkok</a></h3> </div>
</div>
<div class="td_module_mx3 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/2021/12/27/new-bangkok-canal-park-opens-or-at-least-its-first-stretch/" rel="bookmark" class="td-image-wrap" title="New Bangkok Canal Park Opens — or At Least Its First Stretch"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC" alt="" title="New Bangkok Canal Park Opens — or At Least Its First Stretch" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2021/12/Penot03-324x235.jpg" width="324" height="235" /></a></div>
<div class="td-module-meta-info">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/2021/12/27/new-bangkok-canal-park-opens-or-at-least-its-first-stretch/" rel="bookmark" title="New Bangkok Canal Park Opens — or At Least Its First Stretch">New Bangkok Canal Park Opens — or At Least Its First Stretch</a></h3> </div>
</div>
</div></div> <aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>FRESH CUTS</span></h4><div class="textwidget custom-html-widget"><div style="position:relative;height:0;padding-bottom:56.25%"><iframe src="https://www.youtube.com/embed/MJBDERkQ6lE?autoplay=1&mute=1&controls=1&amp;showinfo=0?&loop=1&playlist=MJBDERkQ6lE,nuL5zMdq2L0,_9Ur0kwTT1A,w--hJA5hFvI,SZAteb3fXug,iJt8MdCZU2k,jDEBPepoBdM,mV-2D81FpG0,rs9vIeLPoQU,HRsk2Mt82yM,McEvuIawaFI,A8s7oQARniA,B7Se0bQhtns,PgdOgAwE7-w,cAycz7cOvQ8,nu_UNPCkZno,GwHhghyk0NM,99MH9dB6ENk,6j71VrPRZ-Q,gFMzfz7O-ZQ,GwHhghyk0NM,99MH9dB6ENk,6j71VrPRZ-Q,xut4v75zdhY,uCvNY6JTz_I,mWz8rgyxxkI,dN7aU1gLhMk,jOxjFnnsCkw,YI3PMQt4uo0,JR5csM9QX4Y,4epIJ6Yfwvw,Xt3BlN-IcOw,bI2fSNw-s_I,pz1Dn71Talw,JVbkIE3xCq8,z8xhyb2gang,U8LJlh1KHI4,YYAfF6loezI,pNXEjp9dCbI,Vs9PC_mG5hM,yYZgEbU2ZR0,uYsU3pLgwoQ,lcBKli1dMVw,sUR12BRBksQ,nJ2IlW0GSng,sG4PXiWgTb0,YYAfF6loezI,Hjx6EVSZDdc,KKMT0uqCmWE,SE6XQF3pX8U,ohSsnCt49as,JbLnm0cfxF4,u7_OVX9rZSk,DMsUbJ76Cmw,1_Hhlq-12zs,oE1GLBtqh98,XL2oqFp3Xd4,crNtqFBCvoo,vK12IiKBmY0,37_QRvMSJeE,Oh4AiPLmkhU,btbkG9lJL5c,PvL1O7DtbbE,iS4CaYRIqsU,MUS6hM_pct0,O-qsge84IIE,nKgtOz5WSnY,fDohK80t-lY,EjL23aAoZEw,sEcwhM72kiA,HrDhsIEdvN0,mrDa14TZIcQ,Of_NSIPUx6o,cfxcaxNkvd8,9FMVIkCsKuc,mipg3Hz2oB4,yNhGN_ngL-g,6JoOzLpVScE,c0V_6Nu-RCY,ZmYWvBtTGnQ" width="300" height="169" frameborder="0" style="position:absolute;width:100%;height:100%;left:0" allowfullscreen></iframe></div>
</div></aside><div class="td_block_wrap td_block_weather td_block_widget td_uid_40_62a9707c3db81_rand td-pb-border-top td_block_template_1" data-td-block-uid="td_uid_40_62a9707c3db81"><div class="td-block-title-wrap"></div><div id=td_uid_40_62a9707c3db81 class="td-weather-wrap td_block_inner td-column-1">
<div class="td-weather-header">
<div class="td-weather-city">Bangkok</div>
<div class="td-weather-condition">overcast clouds</div>
<i class="td-location-icon td-icons-location" data-block-uid="td_uid_40_62a9707c3db81"></i>
</div>
<div class="td-weather-set-location">
<form class="td-manual-location-form" action="#" data-block-uid="td_uid_40_62a9707c3db81">
<input id="td_uid_40_62a9707c3db81" class="td-location-set-input" type="text" name="location" value="">
<label>enter location</label>
</form>
</div>
<div class="td-weather-temperature">
<div class="td-weather-temp-wrap">
<div class="td-weather-animated-icon">
<span class="td_animation_sprite-27-100-80-0-0-1 broken-clouds-d td-w-today-icon" data-td-block-uid="td_uid_40_62a9707c3db81"></span>
</div>
<div class="td-weather-now" data-block-uid="td_uid_40_62a9707c3db81">
<span class="td-big-degrees">31.5</span>
<span class="td-circle">&deg;</span>
<span class="td-weather-unit">C</span>
</div>
<div class="td-weather-lo-hi">
<div class="td-weather-degrees-wrap">
<i class="td-up-icon td-icons-arrows-up"></i>
<span class="td-small-degrees td-w-high-temp">33.3</span>
<span class="td-circle">&deg;</span>
</div>
<div class="td-weather-degrees-wrap">
<i class="td-down-icon td-icons-arrows-down"></i>
<span class="td-small-degrees td-w-low-temp">30.9</span>
<span class="td-circle">&deg;</span>
</div>
</div>
</div>
</div>
<div class="td-weather-info-wrap">
<div class="td-weather-information">
<div class="td-weather-section-1">
<i class="td-icons-drop"></i>
<span class="td-weather-parameter td-w-today-humidity">73 %</span>
</div>
<div class="td-weather-section-2">
<i class="td-icons-wind"></i>
<span class="td-weather-parameter td-w-today-wind-speed">4.7kmh</span>
</div>
<div class="td-weather-section-3">
<i class="td-icons-cloud"></i>
<span class="td-weather-parameter td-w-today-clouds">100 %</span>
</div>
</div>
<div class="td-weather-week">
<div class="td-weather-days">
<div class="td-day-0">Wed</div>
<div class="td-day-degrees">
<span class="td-degrees-0">33</span>
<span class="td-circle">&deg;</span>
</div>
</div>
<div class="td-weather-days">
<div class="td-day-1">Thu</div>
<div class="td-day-degrees">
<span class="td-degrees-1">34</span>
<span class="td-circle">&deg;</span>
</div>
</div>
<div class="td-weather-days">
<div class="td-day-2">Fri</div>
<div class="td-day-degrees">
<span class="td-degrees-2">34</span>
<span class="td-circle">&deg;</span>
</div>
</div>
<div class="td-weather-days">
<div class="td-day-3">Sat</div>
<div class="td-day-degrees">
<span class="td-degrees-3">36</span>
<span class="td-circle">&deg;</span>
</div>
</div>
<div class="td-weather-days">
<div class="td-day-4">Sun</div>
<div class="td-day-degrees">
<span class="td-degrees-4">35</span>
<span class="td-circle">&deg;</span>
</div>
</div>
</div>
</div>
</div></div> <aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"></div></aside> </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-container-wrap td-footer-template-14 ">
<div class="td-container td-footer-bottom-full">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.khaosodenglish.com/"><img class="td-retina-data" src="https://www.khaosodenglish.com/wp-content/uploads/2016/11/footerlogo3.png" data-retina="https://www.khaosodenglish.com/wp-content/uploads/2016/11/footeretina-1.png" alt="" title="" width="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>© 2022 Khaosod English.
40/10 S. Thetsaban Nimit Tai Road Prachaniwet 1, Chatuchak, Bangkok, Thailand 10900<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#34575b5a40555740745f5c555b475b50515a53585d475c1a575b59"><span class="__cf_email__" data-cfemail="94f7fbfae0f5f7e0d4fffcf5">[email&#160;protected]</span>osodenglish.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/KhaosodEnglish" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/KhaosodEnglish" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/KhaosodEnglish" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span></aside></div> </div>
</div>
</div>

</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
			window.RS_MODULES = window.RS_MODULES || {};
			window.RS_MODULES.modules = window.RS_MODULES.modules || {};
			window.RS_MODULES.waiting = window.RS_MODULES.waiting || [];
			window.RS_MODULES.defered = false;
			window.RS_MODULES.moduleWaiting = window.RS_MODULES.moduleWaiting || {};
			window.RS_MODULES.type = 'compiled';
		</script>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>
<script type="text/javascript">
var sbiajaxurl = "https://www.khaosodenglish.com/wp-admin/admin-ajax.php";
</script>
<script type="text/javascript">googletag.cmd.push(function() {
var ud_dfp_screen_width = document.body.clientWidth;
googletag.pubads().enableSingleRequest();
googletag.pubads().setTargeting("post_id", "1464881636");
googletag.pubads().setTargeting("post_name", "so-long-internet-explorer-the-browser-retires-today");
googletag.pubads().setTargeting("post_title", "So Long, Internet Explorer. The Browser Retires Today");
googletag.pubads().setTargeting("post_type", "post");
googletag.pubads().setTargeting("category", ["net", "international"]);
googletag.pubads().setTargeting("post_tag", ["tech"]);
googletag.enableServices();
});</script> <div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/russians-control-80-of-key-ukraine-city-cut-escape-routes/" rel="bookmark" class="td-image-wrap" title="Russians Control 80% Of Key Ukraine City, Cut Escape Routes"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="A woman heads to the market in Makariv, on the outskirts of Kyiv, Ukraine, Tuesday, June 14, 2022. Photo: Natacha Pisarenko / AP" title="Russians Control 80% Of Key Ukraine City, Cut Escape Routes" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/AP22165453528959-100x70.jpeg" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2022/06/15/russians-control-80-of-key-ukraine-city-cut-escape-routes/" rel="bookmark" title="Russians Control 80% Of Key Ukraine City, Cut Escape Routes">Russians Control 80% Of Key Ukraine City, Cut Escape Routes</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-15T12:00:30+00:00">June 15, 2022 12:00 pm</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/sponsored/2022/06/15/austro-german-musical-partnership-will-appear-with-royal-bangkok-symphony-orchestra/" rel="bookmark" class="td-image-wrap" title="Austro-German musical partnership will appear with Royal Bangkok Symphony Orchestra"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Austro-German musical partnership will appear with Royal Bangkok Symphony Orchestra" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/image1-13-100x70.jpg" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/sponsored/2022/06/15/austro-german-musical-partnership-will-appear-with-royal-bangkok-symphony-orchestra/" rel="bookmark" title="Austro-German musical partnership will appear with Royal Bangkok Symphony Orchestra">Austro-German musical partnership will appear with Royal Bangkok Symphony Orchestra</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-15T10:03:23+00:00">June 15, 2022 10:03 am</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.khaosodenglish.com/sponsored/2022/06/15/bgrim-advances-acquisition-of-stakes-in-malaysia-based-solar-energy-firm-renikola-revenues-from-three-solar-firms-being-realised/" rel="bookmark" class="td-image-wrap" title="BGRIM advances acquisition of stakes in Malaysia-based solar energy firm – reNIKOLA Revenues from three solar firms being realised"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="BGRIM advances acquisition of stakes in Malaysia-based solar energy firm – reNIKOLA Revenues from three solar firms being realised" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2022/06/image1-12-100x70.jpg" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/sponsored/2022/06/15/bgrim-advances-acquisition-of-stakes-in-malaysia-based-solar-energy-firm-renikola-revenues-from-three-solar-firms-being-realised/" rel="bookmark" title="BGRIM advances acquisition of stakes in Malaysia-based solar energy firm – reNIKOLA Revenues from three solar firms being realised">BGRIM advances acquisition of stakes in Malaysia-based solar energy firm –...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-15T09:12:21+00:00">June 15, 2022 9:12 am</time></span> </div>
</div>
</div>
</div>
</div>


<style type="text/css" media="screen">
/* custom css theme panel */
@import url("https://fast.fonts.net/t/1.css?apiType=css&projectid=eb81b52c-09ff-4200-bbfe-693c2db29e76");
    @font-face{
        font-family:"DIN Next LT W01 Black";
        src:url("Fonts/ef79833e-ca28-419f-898a-a96725a0e7b5.eot?#iefix");
        src:url("Fonts/ef79833e-ca28-419f-898a-a96725a0e7b5.eot?#iefix") format("eot"),url("Fonts/7324033f-ef94-4c54-8e88-377b447f0fa2.woff2") format("woff2"),url("Fonts/3efb3b3f-ac55-4ec0-8099-940870596c57.woff") format("woff"),url("Fonts/a6869823-bba8-457d-9f31-3b1cfe4c9bb9.ttf") format("truetype");
    }
</style>
<link rel='stylesheet' id='rs-plugin-settings-css' href='https://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/css/rs6.css?ver=6.5.5' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=726837bbdee984ffb331a234aadde124' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.5' id='td-site-min-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/comment-reply.min.js?ver=5.8.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=726837bbdee984ffb331a234aadde124' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/wp-embed.min.js?ver=5.8.3' id='wp-embed-js'></script>
<script type='text/javascript' defer src='https://www.khaosodenglish.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js?ver=4.8.6' id='mc4wp-forms-api-js'></script>
<script type="text/javascript" src="//s3.amazonaws.com/downloads.mailchimp.com/js/signup-forms/popup/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script>
<script type="text/javascript">require(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us12.list-manage.com","uuid":"a848e9861d42590de9aef1b00","lid":"7643ab464a"}) })</script>

<div id="truehits_div"></div>
<script type="text/javascript">
  (function() {
    var ga1 = document.createElement('script'); ga1.type = 'text/javascript';
    ga1.async = true;
    ga1.src = "//lvs.truehits.in.th/dataa/t0031311.js";
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga1, s);
  })();
</script>


<script>
    

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Bangkok","api_location":"Bangkok","api_language":"en","api_key":"6ecc38c787e2d975b72b6c67fa443691","today_icon":"broken-clouds-d","today_icon_text":"overcast clouds","today_temp":[31.5,88.7],"today_humidity":73,"today_wind_speed":[4.7,2.9],"today_min":[30.9,87.7],"today_max":[33.3,91.9],"today_clouds":100,"current_unit":0,"forecast":[{"timestamp":1655272800,"day_name":"Wed","day_temp":[33,92],"owm_day_index":0},{"timestamp":1655337600,"day_name":"Thu","day_temp":[34,92],"owm_day_index":6},{"timestamp":1655424000,"day_name":"Fri","day_temp":[34,93],"owm_day_index":14},{"timestamp":1655510400,"day_name":"Sat","day_temp":[36,96],"owm_day_index":22},{"timestamp":1655596800,"day_name":"Sun","day_temp":[35,96],"owm_day_index":30}]});
				});
			
			

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_uid_40_62a9707c3db81","location":"Bangkok","api_location":"Bangkok","api_language":"en","api_key":"6ecc38c787e2d975b72b6c67fa443691","today_icon":"broken-clouds-d","today_icon_text":"overcast clouds","today_temp":[31.5,88.7],"today_humidity":73,"today_wind_speed":[4.7,2.9],"today_min":[30.9,87.7],"today_max":[33.3,91.9],"today_clouds":100,"current_unit":0,"forecast":[{"timestamp":1655272800,"day_name":"Wed","day_temp":[33,92],"owm_day_index":0},{"timestamp":1655337600,"day_name":"Thu","day_temp":[34,92],"owm_day_index":6},{"timestamp":1655424000,"day_name":"Fri","day_temp":[34,93],"owm_day_index":14},{"timestamp":1655510400,"day_name":"Sat","day_temp":[36,96],"owm_day_index":22},{"timestamp":1655596800,"day_name":"Sun","day_temp":[35,96],"owm_day_index":30}]});
				});
			
			

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[1464881636]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.khaosodenglish.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.khaosodenglish.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
<header>
<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
</header>
<div class="tdw-content">
<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">
<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>
<textarea class="tdw-css-writer-editor td_live_css_uid_1_62a9707c5da99">#invest-in-thailand-front a {
    color: white;
}
#invest-in-thailand-front .td-module-meta-info {
    display: none;
}
#invest-in-thailand-front .td-excerpt {
    color: #ccc;
}

#invest-in-thailand-front .logo-boi {
    text-align: center;
    margin: 20px auto 0;
    width: 175px;
}

@media ( min-width: 992px ) {
    #invest-in-thailand-front .logo-boi {
        position: absolute;
        bottom: 0px;
        right: 20px;
    }
}</textarea>
<div id="td_live_css_uid_1_62a9707c5da99" class="td-code-editor"></div>
<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_62a9707c5da99');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_62a9707c5da99");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>
</div>
</div>
<footer>
<a href="#" class="tdw-save-css">Save</a>
<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>
<div class="tdw-resize"></div>
</footer>
</div>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"71b98dbcbdc45b10","token":"75f1b0bbec4847a597cc96419fb89e02","version":"2022.6.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>