<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Korat Mass Shooter Shot Dead, Police Say</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.khaosodenglish.com/xmlrpc.php" />
    <meta property="og:image" content="https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg" /><link rel="icon" type="image/png" href="https://www.khaosodenglish.com/wp-content/uploads/2016/11/fav1-1.png">
<!-- This site is optimized with the Yoast SEO plugin v13.0 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Korat Mass Shooter Shot Dead, Police Say" />
<meta property="og:description" content="KORAT —  Police say a soldier who killed 21 people in a shooting rampage in Korat was shot dead in a police assault, bringing hours-long siege to an end." />
<meta property="og:url" content="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/" />
<meta property="og:site_name" content="Khaosod English" />
<meta property="article:publisher" content="https://www.facebook.com/KhaosodEnglish/" />
<meta property="article:author" content="https://www.facebook.com/teeranai.charuvastra" />
<meta property="article:tag" content="Nakhon Ratchasima" />
<meta property="article:section" content="Crime, Courts, Calamity" />
<meta property="article:published_time" content="2020-02-09T02:14:00+00:00" />
<meta property="article:modified_time" content="2020-02-09T02:42:10+00:00" />
<meta property="og:updated_time" content="2020-02-09T02:42:10+00:00" />
<meta property="og:image" content="https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg" />
<meta property="og:image:secure_url" content="https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="666" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="KORAT — Police say a soldier who killed 21 people in a shooting rampage in Korat was shot dead in a police assault, bringing hours-long siege to an end." />
<meta name="twitter:title" content="Korat Mass Shooter Shot Dead, Police Say" />
<meta name="twitter:site" content="@KhaosodEnglish" />
<meta name="twitter:image" content="https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg" />
<meta name="twitter:creator" content="@Teeranai_c" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.khaosodenglish.com/#website","url":"https://www.khaosodenglish.com/","name":"Khaosod English","description":"Thailand a Click Away. News Without Fear or Favor.","potentialAction":{"@type":"SearchAction","target":"https://www.khaosodenglish.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/#primaryimage","url":"https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg","width":1000,"height":666},{"@type":"WebPage","@id":"https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/#webpage","url":"https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/","inLanguage":"en-US","name":"Korat Mass Shooter Shot Dead, Police Say","isPartOf":{"@id":"https://www.khaosodenglish.com/#website"},"primaryImageOfPage":{"@id":"https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/#primaryimage"},"datePublished":"2020-02-09T02:14:00+00:00","dateModified":"2020-02-09T02:42:10+00:00","author":{"@id":"https://www.khaosodenglish.com/#/schema/person/cb933cd92016068783d448dc04850e86"}},{"@type":["Person"],"@id":"https://www.khaosodenglish.com/#/schema/person/cb933cd92016068783d448dc04850e86","name":"Teeranai Charuvastra, News Chief","image":{"@type":"ImageObject","@id":"https://www.khaosodenglish.com/#authorlogo","url":"https://secure.gravatar.com/avatar/c921199f7d8cb37abdd9ab51d337efc6?s=96&d=blank&r=pg","caption":"Teeranai Charuvastra, News Chief"},"description":"Teeranai Charuvastra can be reached at <a href=\"mailto:teeranai@khaosodenglish.com\">teeranai@khaosodenglish.com</a> and followed on Twitter at <a href=\"http://www.twitter.com/teeranai_c\">@teeranai_c</a>. He began working for Khaosod newspaper in 2012 before founding Khaosod English in late 2013. His interests include politics, crime, the monarchy and the latest Naga sightings.","sameAs":["https://www.facebook.com/teeranai.charuvastra","https://www.instagram.com/teeranaic/","https://twitter.com/https://twitter.com/Teeranai_c"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Khaosod English &raquo; Feed" href="https://www.khaosodenglish.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Khaosod English &raquo; Comments Feed" href="https://www.khaosodenglish.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.khaosodenglish.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://www.khaosodenglish.com/wp-content/plugins/instagram-feed/css/sb-instagram-2-1.min.css?ver=2.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.khaosodenglish.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/css/rs6.css?ver=6.1.8' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<link rel='stylesheet' id='parent-style-css'  href='https://www.khaosodenglish.com/wp-content/themes/Newspaper/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.khaosodenglish.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=618b370f2556e74c489bd6592378277f' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%2C500%2C800%2C800italic%2C900%2C900italic%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C600%2C600italic%2C800%2C800italic%2C900italic&#038;subset=gujarati%2Cthai&#038;ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.khaosodenglish.com/wp-content/themes/Newspaper-child/style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://www.khaosodenglish.com/wp-content/themes/Newspaper/includes/demos/local_news/demo_style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=726837bbdee984ffb331a234aadde124' type='text/css' media='all' />
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/js/revolution.tools.min.js?ver=6.0'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/revslider/public/assets/js/rs6.min.js?ver=6.1.8'></script>
<link rel='https://api.w.org/' href='https://www.khaosodenglish.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.khaosodenglish.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.khaosodenglish.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.khaosodenglish.com/?p=1464857669' />
<link rel="alternate" type="application/json+oembed" href="https://www.khaosodenglish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Fcrimecourtscalamity%2F2020%2F02%2F09%2Fkorat-mass-shooter-shot-dead-police-say%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.khaosodenglish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Fcrimecourtscalamity%2F2020%2F02%2F09%2Fkorat-mass-shooter-shot-dead-police-say%2F&#038;format=xml" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/kseng-1x1', [1, 1], 'div-gpt-ad-1553672219875-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>



<!-- page POST -->
 <!-- position 1 -->
 <!-- head -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_728x90_b1', [[250, 250], [300, 250], [336, 280]], 'div-gpt-ad-1515395484457-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

 <!-- position 2 -->
 <!-- head -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_336x280_b2', [[336, 280], [250, 250], [300, 250]], 'div-gpt-ad-1515395669610-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<!-- position 3 -->
<!-- head -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/eng_post_728x90_b3', [[336, 280], [300, 250], [728, 90]], 'div-gpt-ad-1515395736307-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<!-- page HOME -->
<!-- position 3 -->
<!-- head -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
	googletag.defineSlot('/13542554/eng_home_336x280_b3', [[300, 250], [336, 280], [300, 600]], 'div-gpt-ad-1515394488762-0').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
	googletag.enableServices();
  });
</script>

<link rel="stylesheet" href="https://cdn.knightlab.com/libs/storymapjs/latest/css/storymap.css">
<script type="text/javascript" src="https://cdn.knightlab.com/libs/storymapjs/latest/js/storymap-min.js"></script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=425586894452122&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>    <script>
        window.tdb_globals = {"wpRestNonce":"2fa1c47c5f","wpRestUrl":"https:\/\/www.khaosodenglish.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/","isAdminBarShowing":false,"origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.khaosodenglish.com\/wp-admin\/","wpRestNonce":"2fa1c47c5f","wpRestUrl":"https:\/\/www.khaosodenglish.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    <link rel="amphtml" href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/amp/"><meta name="generator" content="Powered by Slider Revolution 6.1.8 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-65987233-1', 'auto');
  ga('send', 'pageview');

</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.khaosodenglish.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.khaosodenglish.com/category/news/crimecourtscalamity/",
                    "name": "Crime, Courts, Calamity"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/",
                    "name": "Korat Mass Shooter Shot Dead, Police Say"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-32x32.gif" sizes="32x32" />
<link rel="icon" href="https://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-192x192.gif" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-180x180.gif" />
<meta name="msapplication-TileImage" content="https://www.khaosodenglish.com/wp-content/uploads/2019/03/cropped-kelogo-270x270.gif" />
<script type="text/javascript">function setREVStartSize(e){			
			try {								
				var pw = document.getElementById(e.c).parentNode.offsetWidth,
					newh;
				pw = pw===0 || isNaN(pw) ? window.innerWidth : pw;
				e.tabw = e.tabw===undefined ? 0 : parseInt(e.tabw);
				e.thumbw = e.thumbw===undefined ? 0 : parseInt(e.thumbw);
				e.tabh = e.tabh===undefined ? 0 : parseInt(e.tabh);
				e.thumbh = e.thumbh===undefined ? 0 : parseInt(e.thumbh);
				e.tabhide = e.tabhide===undefined ? 0 : parseInt(e.tabhide);
				e.thumbhide = e.thumbhide===undefined ? 0 : parseInt(e.thumbhide);
				e.mh = e.mh===undefined || e.mh=="" || e.mh==="auto" ? 0 : parseInt(e.mh,0);		
				if(e.layout==="fullscreen" || e.l==="fullscreen") 						
					newh = Math.max(e.mh,window.innerHeight);				
				else{					
					e.gw = Array.isArray(e.gw) ? e.gw : [e.gw];
					for (var i in e.rl) if (e.gw[i]===undefined || e.gw[i]===0) e.gw[i] = e.gw[i-1];					
					e.gh = e.el===undefined || e.el==="" || (Array.isArray(e.el) && e.el.length==0)? e.gh : e.el;
					e.gh = Array.isArray(e.gh) ? e.gh : [e.gh];
					for (var i in e.rl) if (e.gh[i]===undefined || e.gh[i]===0) e.gh[i] = e.gh[i-1];
										
					var nl = new Array(e.rl.length),
						ix = 0,						
						sl;					
					e.tabw = e.tabhide>=pw ? 0 : e.tabw;
					e.thumbw = e.thumbhide>=pw ? 0 : e.thumbw;
					e.tabh = e.tabhide>=pw ? 0 : e.tabh;
					e.thumbh = e.thumbhide>=pw ? 0 : e.thumbh;					
					for (var i in e.rl) nl[i] = e.rl[i]<window.innerWidth ? 0 : e.rl[i];
					sl = nl[0];									
					for (var i in nl) if (sl>nl[i] && nl[i]>0) { sl = nl[i]; ix=i;}															
					var m = pw>(e.gw[ix]+e.tabw+e.thumbw) ? 1 : (pw-(e.tabw+e.thumbw)) / (e.gw[ix]);					

					newh =  (e.type==="carousel" && e.justify==="true" ? e.gh[ix] : (e.gh[ix] * m)) + (e.tabh + e.thumbh);
				}			
				
				if(window.rs_init_css===undefined) window.rs_init_css = document.head.appendChild(document.createElement("style"));					
				document.getElementById(e.c).height = newh;
				window.rs_init_css.innerHTML += "#"+e.c+"_wrapper { height: "+newh+"px }";				
			} catch(e){
				console.log("Failure at Presize of Slider:" + e)
			}					   
		  };</script>

<!-- Button style compiled by theme -->

<style>
    .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                  color: #d62532;
                }
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .sfHover > a,
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                  background-color: #d62532;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a,
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #d62532;
                }
                .tdm-btn-style1 {
					background-color: #d62532;
				}
				.tdm-btn-style2:before {
				    border-color: #d62532;
				}
				.tdm-btn-style2 {
				    color: #d62532;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #d62532;
                    -moz-box-shadow: 0 2px 16px #d62532;
                    box-shadow: 0 2px 16px #d62532;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #d62532;
                    -moz-box-shadow: 0 4px 26px #d62532;
                    box-shadow: 0 4px 26px #d62532;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-1464857669 single-format-standard korat-mass-shooter-shot-dead-police-say global-block-template-1 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">


        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-bt-top-menu-container"><ul id="menu-bt-top-menu" class="td-mobile-main-menu"><li id="menu-item-1464768586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-1464768586"><a href="https://www.khaosodenglish.com/category/politics/">Politics</a></li>
<li id="menu-item-1464768584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1464768584"><a href="https://www.khaosodenglish.com/category/life/">Lifestyle<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/arts/">Arts &amp; Culture</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/embassy/">Embassy Corner</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/entertainment/">Entertainment</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/events/">Events</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/food/">Food</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/geek/">Geek</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/nightlife/">Nightlife</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/life/shopping/">Shopping</a></li>
</ul>
</li>
<li id="menu-item-1464768583" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-1464768583"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime &#038; Legal<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/calamity/">Calamity</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/courts/">Courts</a></li>
	<li class="menu-item-0"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/crime-crime/">Crime</a></li>
</ul>
</li>
<li id="menu-item-1464768582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768582"><a href="https://www.khaosodenglish.com/category/culture/net/">dot.Net</a></li>
<li id="menu-item-1464768595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768595"><a href="https://www.khaosodenglish.com/category/opinion/">Opinion</a></li>
<li id="menu-item-1464768589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464768589"><a href="https://www.khaosodenglish.com/category/news/asean/">ASEAN</a></li>
<li id="menu-item-1464825008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1464825008"><a href="https://www.khaosodenglish.com/category/videos/">Videos</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.khaosodenglish.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <style>
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    </style>
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 8
-->


<div class="td-header-wrap td-header-style-8 ">
    
    <div class="td-container ">
        <div class="td-header-sp-logo">
                    <a class="td-main-logo" href="https://www.khaosodenglish.com/">
            <img class="td-retina-data" data-retina="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo_300x284.gif" src="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo.gif" alt=""/>
            <span class="td-visual-hidden">Khaosod English</span>
        </a>
            </div>
    </div>
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container">
            <div class="td-header-row td-header-top-menu">
                
    <div class="top-bar-style-4">
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>    </div>        
<div class="td-header-sp-top-menu">


	<!-- td weather source: cache -->		<div class="td-weather-top-widget" id="td_top_weather_uid">
			<i class="td-icons mist-d"></i>
			<div class="td-weather-now" data-block-uid="td_top_weather_uid">
				<span class="td-big-degrees">25.6</span>
				<span class="td-weather-unit">C</span>
			</div>
			<div class="td-weather-header">
				<div class="td-weather-city">Bangkok</div>
			</div>
		</div>
		        <div class="td_data_time">
            <div >

                Sunday, February 9, 2020
            </div>
        </div>
    </div>
    </div>

<!-- LOGIN MODAL -->
            </div>
        </div>
    </div>
    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
            <div class="td-container">
                <div class="td-header-row td-header-main-menu">
                    <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-mobile" href="https://www.khaosodenglish.com/">
			<img class="td-retina-data" data-retina="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo_300x284.gif" src="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo.gif" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="https://www.khaosodenglish.com/">
			<img class="td-retina-data" data-retina="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo_300x284.gif" src="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo.gif" alt=""/>
		</a>
	    </div>
    <div class="menu-bt-top-menu-container"><ul id="menu-bt-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-1464768586"><a href="https://www.khaosodenglish.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5e3f7319bf843_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_1_5e3f7319bf843" ><script>var block_td_uid_1_5e3f7319bf843 = new tdBlock();
block_td_uid_1_5e3f7319bf843.id = "td_uid_1_5e3f7319bf843";
block_td_uid_1_5e3f7319bf843.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"40","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5e3f7319bf843_rand","tdc_css_class":"td_uid_1_5e3f7319bf843_rand","tdc_css_class_style":"td_uid_1_5e3f7319bf843_rand_style"}';
block_td_uid_1_5e3f7319bf843.td_column_number = "3";
block_td_uid_1_5e3f7319bf843.block_type = "td_block_mega_menu";
block_td_uid_1_5e3f7319bf843.post_count = "5";
block_td_uid_1_5e3f7319bf843.found_posts = "3809";
block_td_uid_1_5e3f7319bf843.header_color = "";
block_td_uid_1_5e3f7319bf843.ajax_pagination_infinite_stop = "";
block_td_uid_1_5e3f7319bf843.max_num_pages = "762";
tdBlocksArray.push(block_td_uid_1_5e3f7319bf843);
</script><div id=td_uid_1_5e3f7319bf843 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2020/02/07/govt-defends-selling-face-masks-to-public/" rel="bookmark" class="td-image-wrap" title="Gov’t Defends Selling Face Masks to Public"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Citizens queue up to purchase face masks at a stall inside the Government House on Feb. 7, 2020." title="Gov’t Defends Selling Face Masks to Public" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/MASK2_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2020/02/07/govt-defends-selling-face-masks-to-public/" rel="bookmark" title="Gov’t Defends Selling Face Masks to Public">Gov’t Defends Selling Face Masks to Public</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2020/02/06/future-forward-braces-for-yet-another-possible-dissolution/" rel="bookmark" class="td-image-wrap" title="Future Forward Braces for Yet Another Possible Dissolution"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Future Forward Braces for Yet Another Possible Dissolution" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/20200203_182632-1-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2020/02/06/future-forward-braces-for-yet-another-possible-dissolution/" rel="bookmark" title="Future Forward Braces for Yet Another Possible Dissolution">Future Forward Braces for Yet Another Possible Dissolution</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2020/02/05/prawit-defends-police-chief-fast-tracking-his-son-to-senior-rank/" rel="bookmark" class="td-image-wrap" title="Prawit Defends Police Chief Fast-Tracking His Son to Senior Rank"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Prawit Defends Police Chief Fast-Tracking His Son to Senior Rank" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/photo_l-1-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2020/02/05/prawit-defends-police-chief-fast-tracking-his-son-to-senior-rank/" rel="bookmark" title="Prawit Defends Police Chief Fast-Tracking His Son to Senior Rank">Prawit Defends Police Chief Fast-Tracking His Son to Senior Rank</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2020/02/04/avenue-renovation-wont-affect-democracy-monument-officials-say/" rel="bookmark" class="td-image-wrap" title="Avenue Renovation Won’t Affect Democracy Monument, Officials Say"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Avenue Renovation Won’t Affect Democracy Monument, Officials Say" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/pre/14487808201448780886l.jpg"  width="205" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2020/02/04/avenue-renovation-wont-affect-democracy-monument-officials-say/" rel="bookmark" title="Avenue Renovation Won’t Affect Democracy Monument, Officials Say">Avenue Renovation Won’t Affect Democracy Monument, Officials Say</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/business/2020/02/04/no-law-stops-restaurants-hotels-from-discriminating-against-chinese-tourists/" rel="bookmark" class="td-image-wrap" title="No Law Stops Shops, Hotels From Discriminating Against Chinese"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Officials greet a Chinese tourist arriving at Chiang Mai Airport on Jan. 24, 2020." title="No Law Stops Shops, Hotels From Discriminating Against Chinese" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/BAN_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/business/2020/02/04/no-law-stops-restaurants-hotels-from-discriminating-against-chinese-tourists/" rel="bookmark" title="No Law Stops Shops, Hotels From Discriminating Against Chinese">No Law Stops Shops, Hotels From Discriminating Against Chinese</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5e3f7319bf843" data-td_block_id="td_uid_1_5e3f7319bf843"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5e3f7319bf843" data-td_block_id="td_uid_1_5e3f7319bf843"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768584"><a href="https://www.khaosodenglish.com/category/life/">Lifestyle</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5e3f7319c95b9_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_2_5e3f7319c95b9" ><script>var block_td_uid_2_5e3f7319c95b9 = new tdBlock();
block_td_uid_2_5e3f7319c95b9.id = "td_uid_2_5e3f7319c95b9";
block_td_uid_2_5e3f7319c95b9.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"42","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_2_5e3f7319c95b9_rand","tdc_css_class":"td_uid_2_5e3f7319c95b9_rand","tdc_css_class_style":"td_uid_2_5e3f7319c95b9_rand_style"}';
block_td_uid_2_5e3f7319c95b9.td_column_number = "3";
block_td_uid_2_5e3f7319c95b9.block_type = "td_block_mega_menu";
block_td_uid_2_5e3f7319c95b9.post_count = "4";
block_td_uid_2_5e3f7319c95b9.found_posts = "3929";
block_td_uid_2_5e3f7319c95b9.header_color = "";
block_td_uid_2_5e3f7319c95b9.ajax_pagination_infinite_stop = "";
block_td_uid_2_5e3f7319c95b9.max_num_pages = "983";
tdBlocksArray.push(block_td_uid_2_5e3f7319c95b9);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_2_5e3f7319c95b9" id="td_uid_3_5e3f7319cbe19" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="" href="https://www.khaosodenglish.com/category/life/">All</a><a class="mega-menu-sub-cat-td_uid_2_5e3f7319c95b9"  id="td_uid_4_5e3f7319cbf24" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="128" href="https://www.khaosodenglish.com/category/life/arts/">Arts &amp; Culture</a><a class="mega-menu-sub-cat-td_uid_2_5e3f7319c95b9"  id="td_uid_5_5e3f7319cc04d" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="587" href="https://www.khaosodenglish.com/category/life/embassy/">Embassy Corner</a><a class="mega-menu-sub-cat-td_uid_2_5e3f7319c95b9"  id="td_uid_6_5e3f7319cc16c" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="127" href="https://www.khaosodenglish.com/category/life/entertainment/">Entertainment</a><a class="mega-menu-sub-cat-td_uid_2_5e3f7319c95b9"  id="td_uid_7_5e3f7319cc287" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="123" href="https://www.khaosodenglish.com/category/life/events/">Events</a><a class="mega-menu-sub-cat-td_uid_2_5e3f7319c95b9"  id="td_uid_8_5e3f7319cc39f" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="44" href="https://www.khaosodenglish.com/category/life/food/">Food</a><a class="mega-menu-sub-cat-td_uid_2_5e3f7319c95b9"  id="td_uid_9_5e3f7319cc4b4" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="53" href="https://www.khaosodenglish.com/category/life/geek/">Geek</a><a class="mega-menu-sub-cat-td_uid_2_5e3f7319c95b9"  id="td_uid_10_5e3f7319cc5d9" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="130" href="https://www.khaosodenglish.com/category/life/nightlife/">Nightlife</a><a class="mega-menu-sub-cat-td_uid_2_5e3f7319c95b9"  id="td_uid_11_5e3f7319cc6ee" data-td_block_id="td_uid_2_5e3f7319c95b9" data-td_filter_value="232" href="https://www.khaosodenglish.com/category/life/shopping/">Shopping</a></div></div><div id=td_uid_2_5e3f7319c95b9 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/arts/2020/02/07/rap-against-dictatorship-drops-new-song-against-student-hazing/" rel="bookmark" class="td-image-wrap" title="‘Rap Against Dictatorship’ Drops New Song Against Student Hazing"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="‘Rap Against Dictatorship’ Drops New Song Against Student Hazing" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/20200203_182632-3-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/arts/2020/02/07/rap-against-dictatorship-drops-new-song-against-student-hazing/" rel="bookmark" title="‘Rap Against Dictatorship’ Drops New Song Against Student Hazing">‘Rap Against Dictatorship’ Drops New Song Against Student Hazing</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/events/2020/02/06/very-fest-lineup-for-march-is-out-joji-niki-bruno-major/" rel="bookmark" class="td-image-wrap" title="‘Very Fest’ Lineup for March is Out: Joji, Niki, Bruno Major"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="‘Very Fest’ Lineup for March is Out: Joji, Niki, Bruno Major" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/maxresdefault-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/events/2020/02/06/very-fest-lineup-for-march-is-out-joji-niki-bruno-major/" rel="bookmark" title="‘Very Fest’ Lineup for March is Out: Joji, Niki, Bruno Major">‘Very Fest’ Lineup for March is Out: Joji, Niki, Bruno Major</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/2020/02/05/free-mental-health-workshops-for-thai-teens-in-february/" rel="bookmark" class="td-image-wrap" title="Free Mental Health Workshops for Thai Teens in February"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Free Mental Health Workshops for Thai Teens in February" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/1000-3-3-218x150.jpeg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/2020/02/05/free-mental-health-workshops-for-thai-teens-in-february/" rel="bookmark" title="Free Mental Health Workshops for Thai Teens in February">Free Mental Health Workshops for Thai Teens in February</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/2020/02/04/meet-half-mochi-half-rabbit-usagyuuun-and-mascot-friends-this-weekend/" rel="bookmark" class="td-image-wrap" title="Meet Half-Mochi, Half-Rabbit ‘Usagyuuun’ and Mascot Friends This Weekend"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Meet Half-Mochi, Half-Rabbit ‘Usagyuuun’ and Mascot Friends This Weekend" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/81348803_1153663191490203_517655404411355136_o-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/2020/02/04/meet-half-mochi-half-rabbit-usagyuuun-and-mascot-friends-this-weekend/" rel="bookmark" title="Meet Half-Mochi, Half-Rabbit ‘Usagyuuun’ and Mascot Friends This Weekend">Meet Half-Mochi, Half-Rabbit ‘Usagyuuun’ and Mascot Friends This Weekend</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5e3f7319c95b9" data-td_block_id="td_uid_2_5e3f7319c95b9"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5e3f7319c95b9" data-td_block_id="td_uid_2_5e3f7319c95b9"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-1464768583"><a href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime &#038; Legal</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_12_5e3f7319d2582_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_12_5e3f7319d2582" ><script>var block_td_uid_12_5e3f7319d2582 = new tdBlock();
block_td_uid_12_5e3f7319d2582.id = "td_uid_12_5e3f7319d2582";
block_td_uid_12_5e3f7319d2582.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"41","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_12_5e3f7319d2582_rand","tdc_css_class":"td_uid_12_5e3f7319d2582_rand","tdc_css_class_style":"td_uid_12_5e3f7319d2582_rand_style"}';
block_td_uid_12_5e3f7319d2582.td_column_number = "3";
block_td_uid_12_5e3f7319d2582.block_type = "td_block_mega_menu";
block_td_uid_12_5e3f7319d2582.post_count = "4";
block_td_uid_12_5e3f7319d2582.found_posts = "3535";
block_td_uid_12_5e3f7319d2582.header_color = "";
block_td_uid_12_5e3f7319d2582.ajax_pagination_infinite_stop = "";
block_td_uid_12_5e3f7319d2582.max_num_pages = "884";
tdBlocksArray.push(block_td_uid_12_5e3f7319d2582);
</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_12_5e3f7319d2582" id="td_uid_13_5e3f7319d4a55" data-td_block_id="td_uid_12_5e3f7319d2582" data-td_filter_value="" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">All</a><a class="mega-menu-sub-cat-td_uid_12_5e3f7319d2582"  id="td_uid_14_5e3f7319d4b8c" data-td_block_id="td_uid_12_5e3f7319d2582" data-td_filter_value="191" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/calamity/">Calamity</a><a class="mega-menu-sub-cat-td_uid_12_5e3f7319d2582"  id="td_uid_15_5e3f7319d4ce4" data-td_block_id="td_uid_12_5e3f7319d2582" data-td_filter_value="173" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/courts/">Courts</a><a class="mega-menu-sub-cat-td_uid_12_5e3f7319d2582"  id="td_uid_16_5e3f7319d4e47" data-td_block_id="td_uid_12_5e3f7319d2582" data-td_filter_value="179" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/crime-crime/">Crime</a></div></div><div id=td_uid_12_5e3f7319d2582 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/" rel="bookmark" class="td-image-wrap" title="Korat Mass Shooter Shot Dead, Police Say"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Korat Mass Shooter Shot Dead, Police Say" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/" rel="bookmark" title="Korat Mass Shooter Shot Dead, Police Say">Korat Mass Shooter Shot Dead, Police Say</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/" rel="bookmark" class="td-image-wrap" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/82177816_2754729561269779_3483236726372040704_o-1-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/" rel="bookmark" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20">Police, Army Besiege Shopping Mall to Search for Soldier Who Kills&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/business/2020/02/07/no-tourists-no-buyers-pratunam-vendors-hit-hard-by-coronavirus-phobia/" rel="bookmark" class="td-image-wrap" title="No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/840218-2-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/business/2020/02/07/no-tourists-no-buyers-pratunam-vendors-hit-hard-by-coronavirus-phobia/" rel="bookmark" title="No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia">No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/07/boys-playing-with-toy-guns-arrested-mistaken-for-robbers/" rel="bookmark" class="td-image-wrap" title="Boys Playing With Toy Guns Arrested, Mistaken For Robbers"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="A Mini Big C convenience store in Bangkok’s Sai Mai district where the incident took place." title="Boys Playing With Toy Guns Arrested, Mistaken For Robbers" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/KID_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/07/boys-playing-with-toy-guns-arrested-mistaken-for-robbers/" rel="bookmark" title="Boys Playing With Toy Guns Arrested, Mistaken For Robbers">Boys Playing With Toy Guns Arrested, Mistaken For Robbers</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_12_5e3f7319d2582" data-td_block_id="td_uid_12_5e3f7319d2582"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_12_5e3f7319d2582" data-td_block_id="td_uid_12_5e3f7319d2582"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768582"><a href="https://www.khaosodenglish.com/category/culture/net/">dot.Net</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_17_5e3f7319d9e85_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_17_5e3f7319d9e85" ><script>var block_td_uid_17_5e3f7319d9e85 = new tdBlock();
block_td_uid_17_5e3f7319d9e85.id = "td_uid_17_5e3f7319d9e85";
block_td_uid_17_5e3f7319d9e85.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"43","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_17_5e3f7319d9e85_rand","tdc_css_class":"td_uid_17_5e3f7319d9e85_rand","tdc_css_class_style":"td_uid_17_5e3f7319d9e85_rand_style"}';
block_td_uid_17_5e3f7319d9e85.td_column_number = "3";
block_td_uid_17_5e3f7319d9e85.block_type = "td_block_mega_menu";
block_td_uid_17_5e3f7319d9e85.post_count = "5";
block_td_uid_17_5e3f7319d9e85.found_posts = "502";
block_td_uid_17_5e3f7319d9e85.header_color = "";
block_td_uid_17_5e3f7319d9e85.ajax_pagination_infinite_stop = "";
block_td_uid_17_5e3f7319d9e85.max_num_pages = "101";
tdBlocksArray.push(block_td_uid_17_5e3f7319d9e85);
</script><div id=td_uid_17_5e3f7319d9e85 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2020/01/31/woman-who-faceswapped-heroine-statue-faces-criminal-charges/" rel="bookmark" class="td-image-wrap" title="Woman Who Faceswapped Heroine Statue Faces Criminal Charges"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Woman Who Faceswapped Heroine Statue Faces Criminal Charges" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/83698880_234374420918687_3409918602382409728_n-copy-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2020/01/31/woman-who-faceswapped-heroine-statue-faces-criminal-charges/" rel="bookmark" title="Woman Who Faceswapped Heroine Statue Faces Criminal Charges">Woman Who Faceswapped Heroine Statue Faces Criminal Charges</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2020/01/20/netizens-get-a-bang-out-of-bangless-lisa-blackpink/" rel="bookmark" class="td-image-wrap" title="Netizens Get a Bang Out of Bangless Lisa Blackpink"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Photos: Prediction_idol and Xxsasaxxll / Twitter" title="Netizens Get a Bang Out of Bangless Lisa Blackpink" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/lisa-1-copy-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2020/01/20/netizens-get-a-bang-out-of-bangless-lisa-blackpink/" rel="bookmark" title="Netizens Get a Bang Out of Bangless Lisa Blackpink">Netizens Get a Bang Out of Bangless Lisa Blackpink</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2020/01/15/purple-vs-the-rest-thai-twitter-rages-over-favorite-pipo-jelly-flavor/" rel="bookmark" class="td-image-wrap" title="Purple vs the Rest: Thai Twitter Rages Over Favorite Pipo Jelly Flavor"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Left: Pipo jellies. Photo: @IMSU1212 / Twitter. Right: A pack of Pipo Jellies." title="Purple vs the Rest: Thai Twitter Rages Over Favorite Pipo Jelly Flavor" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/EOSRGHJU4AA7DZx-copy-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2020/01/15/purple-vs-the-rest-thai-twitter-rages-over-favorite-pipo-jelly-flavor/" rel="bookmark" title="Purple vs the Rest: Thai Twitter Rages Over Favorite Pipo Jelly Flavor">Purple vs the Rest: Thai Twitter Rages Over Favorite Pipo Jelly&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2020/01/13/photo-of-pro-govt-rally-littering-lumpini-park-is-fake-news/" rel="bookmark" class="td-image-wrap" title="Photo of Pro-Gov’t Rally ‘Littering’ Lumpini Park is Fake News"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="A photo of Suan Khwan Muang Park in Yala on Jan. 12, 2020 filled with litter, posted on Pattani News Facebook page, is labeled “Lumpini Park” by Facebook user Vanisa Tirak." title="Photo of Pro-Gov’t Rally ‘Littering’ Lumpini Park is Fake News" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/81833972_171656197388216_408118925021151232_n-copy-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2020/01/13/photo-of-pro-govt-rally-littering-lumpini-park-is-fake-news/" rel="bookmark" title="Photo of Pro-Gov’t Rally ‘Littering’ Lumpini Park is Fake News">Photo of Pro-Gov’t Rally ‘Littering’ Lumpini Park is Fake News</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2020/01/03/lisa-blackpink-fans-furious-at-cafe-owner-for-sexual-harassment-posts/" rel="bookmark" class="td-image-wrap" title="Lisa Blackpink Fans Furious at Cafe Owner for Sexual Harassment Posts"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Lalisa Manoban at Mqqn Cafe in Bangkok in photos posted to her Instagram on Jan. 2, 2020. Photos: @Lalalalisa_m / Instagram" title="Lisa Blackpink Fans Furious at Cafe Owner for Sexual Harassment Posts" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/Lisa-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2020/01/03/lisa-blackpink-fans-furious-at-cafe-owner-for-sexual-harassment-posts/" rel="bookmark" title="Lisa Blackpink Fans Furious at Cafe Owner for Sexual Harassment Posts">Lisa Blackpink Fans Furious at Cafe Owner for Sexual Harassment Posts</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_17_5e3f7319d9e85" data-td_block_id="td_uid_17_5e3f7319d9e85"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_17_5e3f7319d9e85" data-td_block_id="td_uid_17_5e3f7319d9e85"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768595"><a href="https://www.khaosodenglish.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_18_5e3f7319e36ba_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_18_5e3f7319e36ba" ><script>var block_td_uid_18_5e3f7319e36ba = new tdBlock();
block_td_uid_18_5e3f7319e36ba.id = "td_uid_18_5e3f7319e36ba";
block_td_uid_18_5e3f7319e36ba.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"47","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_18_5e3f7319e36ba_rand","tdc_css_class":"td_uid_18_5e3f7319e36ba_rand","tdc_css_class_style":"td_uid_18_5e3f7319e36ba_rand_style"}';
block_td_uid_18_5e3f7319e36ba.td_column_number = "3";
block_td_uid_18_5e3f7319e36ba.block_type = "td_block_mega_menu";
block_td_uid_18_5e3f7319e36ba.post_count = "5";
block_td_uid_18_5e3f7319e36ba.found_posts = "394";
block_td_uid_18_5e3f7319e36ba.header_color = "";
block_td_uid_18_5e3f7319e36ba.ajax_pagination_infinite_stop = "";
block_td_uid_18_5e3f7319e36ba.max_num_pages = "79";
tdBlocksArray.push(block_td_uid_18_5e3f7319e36ba);
</script><div id=td_uid_18_5e3f7319e36ba class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2020/02/06/opinion-how-coronavirus-lays-bare-govt-inefficiency-china-bashing/" rel="bookmark" class="td-image-wrap" title="Opinion: How Coronavirus Lays Bare Gov’t Inefficiency, China-Bashing"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Opinion: How Coronavirus Lays Bare Gov’t Inefficiency, China-Bashing" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/840218-1-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2020/02/06/opinion-how-coronavirus-lays-bare-govt-inefficiency-china-bashing/" rel="bookmark" title="Opinion: How Coronavirus Lays Bare Gov’t Inefficiency, China-Bashing">Opinion: How Coronavirus Lays Bare Gov’t Inefficiency, China-Bashing</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2020/02/05/editorial-coronavirus-is-no-excuse-for-xenophobia/" rel="bookmark" class="td-image-wrap" title="Editorial: Coronavirus is No Excuse for Xenophobia"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Editorial: Coronavirus is No Excuse for Xenophobia" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/headlineditorial-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2020/02/05/editorial-coronavirus-is-no-excuse-for-xenophobia/" rel="bookmark" title="Editorial: Coronavirus is No Excuse for Xenophobia">Editorial: Coronavirus is No Excuse for Xenophobia</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2020/02/02/opinion-why-did-statues-of-a-former-pm-have-to-go/" rel="bookmark" class="td-image-wrap" title="Opinion: Why Did Statues of a Former PM Have to Go?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Opinion: Why Did Statues of a Former PM Have to Go?" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/img_20200127_184610_1-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2020/02/02/opinion-why-did-statues-of-a-former-pm-have-to-go/" rel="bookmark" title="Opinion: Why Did Statues of a Former PM Have to Go?">Opinion: Why Did Statues of a Former PM Have to Go?</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2020/01/30/editorial-border-policies-must-not-be-based-on-fearmongering/" rel="bookmark" class="td-image-wrap" title="Editorial: Our Border Policies Must Not be Based on Fearmongering"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Editorial: Our Border Policies Must Not be Based on Fearmongering" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/PNY_6497-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2020/01/30/editorial-border-policies-must-not-be-based-on-fearmongering/" rel="bookmark" title="Editorial: Our Border Policies Must Not be Based on Fearmongering">Editorial: Our Border Policies Must Not be Based on Fearmongering</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/opinion/2020/01/18/opinion-a-case-of-political-purification-at-a-hospital/" rel="bookmark" class="td-image-wrap" title="Opinion: A Case of Political Purification at a Hospital"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Opinion: A Case of Political Purification at a Hospital" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/62K242_159_resize-2-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/opinion/2020/01/18/opinion-a-case-of-political-purification-at-a-hospital/" rel="bookmark" title="Opinion: A Case of Political Purification at a Hospital">Opinion: A Case of Political Purification at a Hospital</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_18_5e3f7319e36ba" data-td_block_id="td_uid_18_5e3f7319e36ba"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_18_5e3f7319e36ba" data-td_block_id="td_uid_18_5e3f7319e36ba"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464768589"><a href="https://www.khaosodenglish.com/category/news/asean/">ASEAN</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_19_5e3f7319ec67b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_19_5e3f7319ec67b" ><script>var block_td_uid_19_5e3f7319ec67b = new tdBlock();
block_td_uid_19_5e3f7319ec67b.id = "td_uid_19_5e3f7319ec67b";
block_td_uid_19_5e3f7319ec67b.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"52","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_19_5e3f7319ec67b_rand","tdc_css_class":"td_uid_19_5e3f7319ec67b_rand","tdc_css_class_style":"td_uid_19_5e3f7319ec67b_rand_style"}';
block_td_uid_19_5e3f7319ec67b.td_column_number = "3";
block_td_uid_19_5e3f7319ec67b.block_type = "td_block_mega_menu";
block_td_uid_19_5e3f7319ec67b.post_count = "5";
block_td_uid_19_5e3f7319ec67b.found_posts = "1363";
block_td_uid_19_5e3f7319ec67b.header_color = "";
block_td_uid_19_5e3f7319ec67b.ajax_pagination_infinite_stop = "";
block_td_uid_19_5e3f7319ec67b.max_num_pages = "273";
tdBlocksArray.push(block_td_uid_19_5e3f7319ec67b);
</script><div id=td_uid_19_5e3f7319ec67b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2019/11/12/myanmar-accused-at-un-court-of-genocide-against-rohingya/" rel="bookmark" class="td-image-wrap" title="Myanmar Accused at UN Court of Genocide Against Rohingya"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="-FILE- In this Tuesday, Sept. 5, 2017, file photo members of Myanmar&#039;s Rohingya ethnic minority walk through rice fields after crossing the border into Bangladesh near Cox&#039;s Bazar&#039;s Teknaf area. Gambia has filed a case at the United Nations&#039; highest court in The Hague, Netherlands, Monday, Nov. 11, 2019, accusing Myanmar of genocide in its campaign against the Rohingya Muslim minority. A statement released Monday by lawyers for Gambia says the case also asks the International Court of Justice to order measures &quot;to stop Myanmar&#039;s genocidal conduct immediately.&quot; Photo: Bernat Armangue / AP File" title="Myanmar Accused at UN Court of Genocide Against Rohingya" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/AP19315378442630-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2019/11/12/myanmar-accused-at-un-court-of-genocide-against-rohingya/" rel="bookmark" title="Myanmar Accused at UN Court of Genocide Against Rohingya">Myanmar Accused at UN Court of Genocide Against Rohingya</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2019/11/01/us-official-urges-asean-to-stand-up-to-china-in-sea-row/" rel="bookmark" class="td-image-wrap" title="US Official Urges ASEAN to Stand up to China in Sea Row"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="David Stilwell, the U.S. State Department’s assistant secretary for East Asia and the Pacific, left, speaks during a forum in Kuala Lumpur, Thursday, Oct. 31, 2019. The senior U.S. official says a free and open Indo-Pacific concept is not a move to expand U.S. domination but reflects Washington’s “enduring engagement” to prosper the region. Photo: Vincent Thian / AP" title="US Official Urges ASEAN to Stand up to China in Sea Row" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/AP19304154940604-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2019/11/01/us-official-urges-asean-to-stand-up-to-china-in-sea-row/" rel="bookmark" title="US Official Urges ASEAN to Stand up to China in Sea Row">US Official Urges ASEAN to Stand up to China in Sea&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/international/2019/11/01/police-say-body-of-british-tourist-missing-in-cambodia-found/" rel="bookmark" class="td-image-wrap" title="Police Say Body of British Tourist Missing in Cambodia Found"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Roy Bambridge uncle of missing British backpacker Amelia Bambridge talks on his mobile phone in Koh Rong island, southwestern Cambodia, Thursday, Oct. 31, 2019. Around 150 people are taking part in the search for Bambridge who has not been seen since last Wednesday night when she attended a beach party on the island joined by tourists of various nationalities. Photo: Heng Sinith / AP" title="Police Say Body of British Tourist Missing in Cambodia Found" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/AP19304135216933-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/international/2019/11/01/police-say-body-of-british-tourist-missing-in-cambodia-found/" rel="bookmark" title="Police Say Body of British Tourist Missing in Cambodia Found">Police Say Body of British Tourist Missing in Cambodia Found</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/asean/2019/10/21/widodo-begins-2nd-term-pledging-to-make-indonesia-developed/" rel="bookmark" class="td-image-wrap" title="Widodo Begins 2nd Term Pledging to Make Indonesia Developed"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Indonesian President Joko Widodo, center, smiles as he speaks to the media upon arrival after his inauguration for his second term, at Merdeka Palace in Jakarta, Indonesia, Sunday, Oct. 20, 2019. Widodo, who rose from poverty and pledged to champion democracy, fight entrenched corruption and modernize the world&#039;s most populous Muslim-majority nation, was sworn in Sunday for his second and final five-year term with a pledge to take bolder actions. Photo: Dita Alangkara / AP" title="Widodo Begins 2nd Term Pledging to Make Indonesia Developed" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/10/AP19293413715448-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/asean/2019/10/21/widodo-begins-2nd-term-pledging-to-make-indonesia-developed/" rel="bookmark" title="Widodo Begins 2nd Term Pledging to Make Indonesia Developed">Widodo Begins 2nd Term Pledging to Make Indonesia Developed</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/asean/2019/10/16/china-singapore-agree-to-step-up-belt-road-cooperation/" rel="bookmark" class="td-image-wrap" title="China, Singapore Agree to Step Up Belt &#038; Road Cooperation"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="China, Singapore Agree to Step Up Belt &#038; Road Cooperation" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/10/138474267_15711776798341n-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/asean/2019/10/16/china-singapore-agree-to-step-up-belt-road-cooperation/" rel="bookmark" title="China, Singapore Agree to Step Up Belt &#038; Road Cooperation">China, Singapore Agree to Step Up Belt &#038; Road Cooperation</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_19_5e3f7319ec67b" data-td_block_id="td_uid_19_5e3f7319ec67b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_19_5e3f7319ec67b" data-td_block_id="td_uid_19_5e3f7319ec67b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-1464825008"><a href="https://www.khaosodenglish.com/category/videos/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5e3f731a02390_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_20_5e3f731a02390" ><script>var block_td_uid_20_5e3f731a02390 = new tdBlock();
block_td_uid_20_5e3f731a02390.id = "td_uid_20_5e3f731a02390";
block_td_uid_20_5e3f731a02390.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"46","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_20_5e3f731a02390_rand","tdc_css_class":"td_uid_20_5e3f731a02390_rand","tdc_css_class_style":"td_uid_20_5e3f731a02390_rand_style"}';
block_td_uid_20_5e3f731a02390.td_column_number = "3";
block_td_uid_20_5e3f731a02390.block_type = "td_block_mega_menu";
block_td_uid_20_5e3f731a02390.post_count = "5";
block_td_uid_20_5e3f731a02390.found_posts = "237";
block_td_uid_20_5e3f731a02390.header_color = "";
block_td_uid_20_5e3f731a02390.ajax_pagination_infinite_stop = "";
block_td_uid_20_5e3f731a02390.max_num_pages = "48";
tdBlocksArray.push(block_td_uid_20_5e3f731a02390);
</script><div id=td_uid_20_5e3f731a02390 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/featured/2019/12/27/khaosod-englishs-top-6-watched-videos-of-2019/" rel="bookmark" class="td-image-wrap" title="Khaosod English’s Top 6 Watched Videos of 2019"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Bua Noi the gorilla, left, The Last Overland team leader Alex Bescoby, center, and Miss Universe Thailand 2019 Jennifer Paweensuda “Fahsai” Drouin, right." title="Khaosod English’s Top 6 Watched Videos of 2019" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/12/YEAREND_VIDEOS_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/featured/2019/12/27/khaosod-englishs-top-6-watched-videos-of-2019/" rel="bookmark" title="Khaosod English’s Top 6 Watched Videos of 2019">Khaosod English’s Top 6 Watched Videos of 2019</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/20/surreal-video-of-grandma-slapping-student-to-christmas-carols-goes-viral/" rel="bookmark" class="td-image-wrap" title="Surreal Video of Grandma Slapping Student to Christmas Carols Goes Viral"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Surreal Video of Grandma Slapping Student to Christmas Carols Goes Viral" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/12/slap-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/20/surreal-video-of-grandma-slapping-student-to-christmas-carols-goes-viral/" rel="bookmark" title="Surreal Video of Grandma Slapping Student to Christmas Carols Goes Viral">Surreal Video of Grandma Slapping Student to Christmas Carols Goes Viral</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/04/american-on-phuket-fined-for-fighting-with-burmese-waiters-over-seafood-order-video/" rel="bookmark" class="td-image-wrap" title="American on Phuket Fined for Fighting With Burmese Waiters Over Seafood Order (Video)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="A still from CCTV footage showing a brawl between a foreigner and wait staff outside a restaurant on Karon Beach on Dec. 2, 2019." title="American on Phuket Fined for Fighting With Burmese Waiters Over Seafood Order (Video)" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/12/AMERICAN_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/04/american-on-phuket-fined-for-fighting-with-burmese-waiters-over-seafood-order-video/" rel="bookmark" title="American on Phuket Fined for Fighting With Burmese Waiters Over Seafood Order (Video)">American on Phuket Fined for Fighting With Burmese Waiters Over Seafood&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/videos/2019/11/15/colombian-priest-in-thailand-translates-pope-welcome-song-into-spanish/" rel="bookmark" class="td-image-wrap" title="Colombian Priest in Thailand Translates Pope Welcome Song into Spanish (Video)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Colombian Priest in Thailand Translates Pope Welcome Song into Spanish (Video)" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/maxresdefault-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://www.khaosodenglish.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/videos/2019/11/15/colombian-priest-in-thailand-translates-pope-welcome-song-into-spanish/" rel="bookmark" title="Colombian Priest in Thailand Translates Pope Welcome Song into Spanish (Video)">Colombian Priest in Thailand Translates Pope Welcome Song into Spanish (Video)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td-animation-stack td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/10/30/elephant-squishes-car-in-khao-yai-national-park/" rel="bookmark" class="td-image-wrap" title="Elephant Squishes Car in Khao Yai National Park"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Elephant Squishes Car in Khao Yai National Park" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/10/S__6586773-218x150.jpg"  width="218" height="150" /></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/10/30/elephant-squishes-car-in-khao-yai-national-park/" rel="bookmark" title="Elephant Squishes Car in Khao Yai National Park">Elephant Squishes Car in Khao Yai National Park</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5e3f731a02390" data-td_block_id="td_uid_20_5e3f731a02390"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5e3f731a02390" data-td_block_id="td_uid_20_5e3f731a02390"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
</ul></div></div>


    <div class="td-search-wrapper">
        <div id="td-top-search">
            <!-- Search -->
            <div class="header-search-wrap">
                <div class="dropdown header-search">
                    <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                </div>
            </div>
        </div>
    </div>
                </div>
            </div>
        </div>
    </div>

            <div class="td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_21_5e3f731a0cf53_rand td_block_template_1"><script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/khaosod-khaosodeng/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script> </div>
</div>                </div>
            </div>
        </div>
    
</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.khaosodenglish.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Crime, Courts, Calamity" class="entry-crumb" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime, Courts, Calamity</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Korat Mass Shooter Shot Dead, Police Say</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-1464857669" class="post-1464857669 post type-post status-publish format-standard has-post-thumbnail category-crimecourtscalamity tag-nakhon-ratchasima" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  style="background-color:#d52432; color:#fff; border-color:#d52432;" href="https://www.khaosodenglish.com/category/news/">News</a></li><li class="entry-category"><a  style="background-color:#29b2b5; color:#fff; border-color:#29b2b5;" href="https://www.khaosodenglish.com/category/news/crimecourtscalamity/">Crime, Courts, Calamity</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Korat Mass Shooter Shot Dead, Police Say</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.khaosodenglish.com/author/teeranai/">Teeranai Charuvastra, News Chief</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-02-09T09:14:00+00:00" >February 9, 2020 9:14 am</time></span>                                                        </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Fcrimecourtscalamity%2F2020%2F02%2F09%2Fkorat-mass-shooter-shot-dead-police-say%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Korat+Mass+Shooter+Shot+Dead%2C+Police+Say&url=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Fcrimecourtscalamity%2F2020%2F02%2F09%2Fkorat-mass-shooter-shot-dead-police-say%2F&via=KhaosodEnglish">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?Korat+Mass+Shooter+Shot+Dead%2C+Police+Say%0D%0Ahttps://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/">
                                        <div class="td-social-but-icon"><i class="td-icon-line"></i></div>
                                        <div class="td-social-but-text">LINE</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Korat+Mass+Shooter+Shot+Dead%2C+Police+Say %0A%0A https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/&amp;media=https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg&description=Korat+Mass+Shooter+Shot+Dead%2C+Police+Say">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/&title=Korat+Mass+Shooter+Shot+Dead%2C+Police+Say">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/">
                                        <div class="td-social-but-icon"><i class="td-icon-vk"></i></div>
                                        <div class="td-social-but-text">VK</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><figure><img width="696" height="464" class="entry-thumb" src="https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920-696x464.jpg" srcset="https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920-696x464.jpg 696w, https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920-300x200.jpg 300w, https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920-768x511.jpg 768w, https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920-500x333.jpg 500w, https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920-631x420.jpg 631w, https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg 1000w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="Police commandos at Terminal 21 shopping mall in Nakhon Ratchasima province on Feb. 9, 2020."/><figcaption class="wp-caption-text">Police commandos at Terminal 21 shopping mall in Nakhon Ratchasima province on Feb. 9, 2020.</figcaption></figure></div>
        <div class="td-a-rec td-a-rec-id-content_top  td_uid_23_5e3f731a1126c_rand td_block_template_1"><!-- Revive Adserver Javascript Tag - Generated with Revive Adserver v5.0.4 -->
<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ads5.matichon.co.th/www/delivery/ajs.php':'http://ads5.matichon.co.th/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=21");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ads5.matichon.co.th/www/delivery/ck.php?n=a266a275&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://ads5.matichon.co.th/www/delivery/avw.php?zoneid=21&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a266a275' border='0' alt='' /></a></noscript>



</div>
<p><strong>KORAT</strong> —  Police say a soldier who killed 21 people in a shooting rampage in Korat was shot dead in a police assault, bringing hours-long siege to an end.</p>



<p>Sgt. Jakkrapanth Thomma, who stole military grade weapons from his base in Nakhon Ratchasima on Saturday before <strong><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/" target="_blank" rel="noreferrer noopener" aria-label="going on a rampage (opens in a new tab)">going on a rampage</a></strong> that left multiple victims dead, was killed during a police operation at Terminal 21 shopping mall where he spent hours holed up inside, according to the police at the scene. </p>



<p>The news was also confirmed by deputy PM Anutin Charnvirakul, who posted online that the gunman has been killed.</p>



<p> At least 21 people were killed in what appeared to be Thailand’s worst mass shooting in modern history. Another 42 people were also wounded, Nakhon Ratchasima governor said. </p><div class="td-a-rec td-a-rec-id-content_inlineright  td_uid_22_5e3f731a10d0f_rand td_block_template_1"><div id='div-gpt-ad-1471511141011-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1471511141011-0'); });
</script>
</div>
</div>



<p>The latest fatality is said to be a law enforcement officer who was shot dead on Sunday early morning when Sgt. Jakkrapanth fired his weapons at the police blockade from inside the besieged mall.  </p>



<p>Police sources said Jakkrapanth was shot dead at about 9am in the &#8220;Zone A&#8221; area of the shopping mall&#8217;s basement level.</p>


<p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Fkhaosod%2Fvideos%2F859264531193401%2F&amp;show_text=1&amp;width=560" width="560" height="426" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowtransparency="true" allow="encrypted-media" allowfullscreen="true"></iframe></p>


<p><em>This is a developing story. Article may be updated without notice.&nbsp;</em></p>
<div class="td-a-rec td-a-rec-id-content_bottom  td-rec-hide-on-m td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p td_uid_24_5e3f731a11cf4_rand td_block_template_1"><!--[xyz-ihs snippet="genie"]
<!--  ad tags Size: 300x250 ZoneId:1404334
<script type="text/javascript" src="http://js.genieessp.com/t/404/334/a1404334.js"></script>


--></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.khaosodenglish.com/tag/nakhon-ratchasima/">Nakhon Ratchasima</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Fcrimecourtscalamity%2F2020%2F02%2F09%2Fkorat-mass-shooter-shot-dead-police-say%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Korat+Mass+Shooter+Shot+Dead%2C+Police+Say&url=https%3A%2F%2Fwww.khaosodenglish.com%2Fnews%2Fcrimecourtscalamity%2F2020%2F02%2F09%2Fkorat-mass-shooter-shot-dead-police-say%2F&via=KhaosodEnglish">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?Korat+Mass+Shooter+Shot+Dead%2C+Police+Say%0D%0Ahttps://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/">
                                        <div class="td-social-but-icon"><i class="td-icon-line"></i></div>
                                        <div class="td-social-but-text">LINE</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Korat+Mass+Shooter+Shot+Dead%2C+Police+Say %0A%0A https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/&amp;media=https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg&description=Korat+Mass+Shooter+Shot+Dead%2C+Police+Say">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/&title=Korat+Mass+Shooter+Shot+Dead%2C+Police+Say">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/">
                                        <div class="td-social-but-icon"><i class="td-icon-vk"></i></div>
                                        <div class="td-social-but-text">VK</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/">Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="author-box-wrap"><a href="https://www.khaosodenglish.com/author/teeranai/"><img alt='' src='https://secure.gravatar.com/avatar/c921199f7d8cb37abdd9ab51d337efc6?s=96&#038;d=blank&#038;r=pg' srcset='https://secure.gravatar.com/avatar/c921199f7d8cb37abdd9ab51d337efc6?s=192&#038;d=blank&#038;r=pg 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.khaosodenglish.com/author/teeranai/">Teeranai Charuvastra, News Chief</a></span></div><div class="td-author-description">Teeranai Charuvastra can be reached at <a href="/cdn-cgi/l/email-protection#5f2b3a3a2d3e313e361f34373e302c303b3a313833362c37713c3032"><span class="__cf_email__" data-cfemail="d1a5b4b4a3b0bfb0b891bab9b0bea2beb5b4bfb6bdb8a2b9ffb2bebc">[email&#160;protected]</span></a> and followed on Twitter at <a href="https://www.twitter.com/teeranai_c">@teeranai_c</a>. He began working for Khaosod newspaper in 2012 before founding Khaosod English in late 2013. His interests include politics, crime, the monarchy and the latest Naga sightings.</div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/teeranai.charuvastra" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/teeranaic/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://steamcommunity.com/id/sirthomasrichmond/" title="Steam">
                <i class="td-icon-font td-icon-steam"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/Teeranai_c" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Teeranai Charuvastra, News Chief"></span><meta itemprop="datePublished" content="2020-02-09T09:14:00+00:00"><meta itemprop="dateModified" content="2020-02-09T09:42:10+07:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.khaosodenglish.com/wp-content/uploads/2016/10/logo.gif"></span><meta itemprop="name" content="Khaosod English"></span><meta itemprop="headline " content="Korat Mass Shooter Shot Dead, Police Say"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.khaosodenglish.com/wp-content/uploads/2020/02/S__14409920.jpg"><meta itemprop="width" content="1000"><meta itemprop="height" content="666"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_25_5e3f731a15a12_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_25_5e3f731a15a12" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_td_uid_25_5e3f731a15a12 = new tdBlock();
block_td_uid_25_5e3f731a15a12.id = "td_uid_25_5e3f731a15a12";
block_td_uid_25_5e3f731a15a12.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"td_uid_25_5e3f731a15a12_rand","td_column_number":3,"live_filter_cur_post_id":1464857669,"live_filter_cur_post_author":"4","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_25_5e3f731a15a12_rand","tdc_css_class_style":"td_uid_25_5e3f731a15a12_rand_style"}';
block_td_uid_25_5e3f731a15a12.td_column_number = "3";
block_td_uid_25_5e3f731a15a12.block_type = "td_block_related_posts";
block_td_uid_25_5e3f731a15a12.post_count = "6";
block_td_uid_25_5e3f731a15a12.found_posts = "49";
block_td_uid_25_5e3f731a15a12.header_color = "";
block_td_uid_25_5e3f731a15a12.ajax_pagination_infinite_stop = "";
block_td_uid_25_5e3f731a15a12.max_num_pages = "9";
tdBlocksArray.push(block_td_uid_25_5e3f731a15a12);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_26_5e3f731a18304" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_25_5e3f731a15a12" href="#">RELATED ARTICLES</a><a id="td_uid_27_5e3f731a18368" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_25_5e3f731a15a12" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_25_5e3f731a15a12 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/" rel="bookmark" class="td-image-wrap" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/82177816_2754729561269779_3483236726372040704_o-1-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/" rel="bookmark" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20">Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/culture/net/2020/01/31/woman-who-faceswapped-heroine-statue-faces-criminal-charges/" rel="bookmark" class="td-image-wrap" title="Woman Who Faceswapped Heroine Statue Faces Criminal Charges"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Woman Who Faceswapped Heroine Statue Faces Criminal Charges" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/01/83698880_234374420918687_3409918602382409728_n-copy-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/culture/net/2020/01/31/woman-who-faceswapped-heroine-statue-faces-criminal-charges/" rel="bookmark" title="Woman Who Faceswapped Heroine Statue Faces Criminal Charges">Woman Who Faceswapped Heroine Statue Faces Criminal Charges</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/18/fugitive-killer-kid-the-ripper-arrested-on-korat-train-cops-say/" rel="bookmark" class="td-image-wrap" title="Fugitive Killer ‘Kid the Ripper’ Arrested on Korat Train, Cops Say"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Fugitive Killer ‘Kid the Ripper’ Arrested on Korat Train, Cops Say" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/12/25487301_1629098570483452_6741939852260276280_o-1-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/12/18/fugitive-killer-kid-the-ripper-arrested-on-korat-train-cops-say/" rel="bookmark" title="Fugitive Killer ‘Kid the Ripper’ Arrested on Korat Train, Cops Say">Fugitive Killer ‘Kid the Ripper’ Arrested on Korat Train, Cops Say</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/11/25/police-say-ambulance-driver-dozes-off-killing-patient/" rel="bookmark" class="td-image-wrap" title="Police Say Ambulance Driver Dozes Off, Killing Patient"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="Wrecked ambulance after the accident on Nov. 25, 2019." title="Police Say Ambulance Driver Dozes Off, Killing Patient" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/AMBULANCE_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/11/25/police-say-ambulance-driver-dozes-off-killing-patient/" rel="bookmark" title="Police Say Ambulance Driver Dozes Off, Killing Patient">Police Say Ambulance Driver Dozes Off, Killing Patient</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/11/12/police-seek-arrest-of-copyright-troll-who-demanded-50k-from-teen-krathong-maker/" rel="bookmark" class="td-image-wrap" title="Police Seek Arrest of Copyright Troll Who Demanded 50K from Teen Krathong Maker"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="The 15-year-old, who only identified herself to the media as “Orn,” selling krathongs on Nov. 11, 2019 at a stall in front of Central Plaza Nakhon Ratchasima." title="Police Seek Arrest of Copyright Troll Who Demanded 50K from Teen Krathong Maker" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/11/KRATHONG2_Header-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/11/12/police-seek-arrest-of-copyright-troll-who-demanded-50k-from-teen-krathong-maker/" rel="bookmark" title="Police Seek Arrest of Copyright Troll Who Demanded 50K from Teen Krathong Maker">Police Seek Arrest of Copyright Troll Who Demanded 50K from Teen Krathong Maker</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/10/30/elephant-squishes-car-in-khao-yai-national-park/" rel="bookmark" class="td-image-wrap" title="Elephant Squishes Car in Khao Yai National Park"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Elephant Squishes Car in Khao Yai National Park" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2019/10/S__6586773-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2019/10/30/elephant-squishes-car-in-khao-yai-national-park/" rel="bookmark" title="Elephant Squishes Car in Khao Yai National Park">Elephant Squishes Car in Khao Yai National Park</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5e3f731a15a12" data-td_block_id="td_uid_25_5e3f731a15a12"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_25_5e3f731a15a12" data-td_block_id="td_uid_25_5e3f731a15a12"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/khaosod-khaosodeng/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script> 

<div id="taboola-below-article-thumbnails-2"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'organic-thumbnails-a',
    container: 'taboola-below-article-thumbnails-2',
    placement: 'Below Article Thumbnails 2',
    target_type: 'mix'
  });
</script> 

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script> <div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td_block_wrap td_block_social_counter td_block_widget td_uid_28_5e3f731a1f9b1_rand td-social-style9 td-social-boxed td-social-colored td-pb-border-top td_block_template_1">
<style>
.td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-pulldown-filter-link:hover,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-subcat-item a:hover,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-subcat-item .td-cur-simple-item {
                color: #D62532;
            }

            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .block-title > *,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-subcat-dropdown:hover .td-subcat-more {
                background-color: #D62532;
            }
            .td-theme-wrap .td-footer-wrapper .td_uid_28_5e3f731a1f9b1_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .block-title {
                border-color: #D62532;
            }

            
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td_quote_on_blocks,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-instagram-user a {
                color: #D62532;
            }

            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-next-prev-wrap a:hover,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-load-more-wrap a:hover {
                background-color: #D62532;
                border-color: #D62532;
            }

            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-read-more a,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-weather-information:before,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-weather-week:before,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .td_uid_28_5e3f731a1f9b1_rand .td-post-category,
            .td-theme-wrap .td_uid_28_5e3f731a1f9b1_rand .td-post-category:hover {
                background-color: #D62532;
            }
</style><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">FOLLOW US</span></h4></div><div class="td-social-list"><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-social-box"><div class="td-sp td-sp-facebook"></div><span class="td_social_info">140,430</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/KhaosodEnglish"  target="_blank" >Like</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_instagram"><div class="td-social-box"><div class="td-sp td-sp-instagram"></div><span class="td_social_info">3,109</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://instagram.com/khaosodenglish#"  target="_blank" >Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-social-box"><div class="td-sp td-sp-twitter"></div><span class="td_social_info">30,944</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/khaosodenglish"  target="_blank" >Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_youtube"><div class="td-social-box"><div class="td-sp td-sp-youtube"></div><span class="td_social_info">14,900</span><span class="td_social_info td_social_info_name">Subscribers</span><span class="td_social_button"><a href="https://www.youtube.com/channel/UCftKKSU1fyGv9CkGR4AtRAQ"  target="_blank" >Subscribe</a></span></div></div></div></div> <!-- ./block --><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Revive Adserver Javascript Tag - Generated with Revive Adserver v5.0.4 -->
<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ads5.matichon.co.th/www/delivery/ajs.php':'http://ads5.matichon.co.th/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=18");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ads5.matichon.co.th/www/delivery/ck.php?n=af07b4cd&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank' rel="noopener noreferrer"><img src='http://ads5.matichon.co.th/www/delivery/avw.php?zoneid=18&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=af07b4cd' border='0' alt='' /></a></noscript>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/13542554/KS_Eng_post_B2', [300, 250], 'div-gpt-ad-1572491151193-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!-- /13542554/KS_Eng_post_B2 -->
<div id='div-gpt-ad-1572491151193-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1572491151193-0'); });
  </script>
</div></div></aside><div class="td_block_wrap td_block_9 td_block_widget td_uid_29_5e3f731a211b9_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding td_block_bot_line"  data-td-block-uid="td_uid_29_5e3f731a211b9" >
<style>
.td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-pulldown-filter-link:hover,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-subcat-item a:hover,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-subcat-item .td-cur-simple-item {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .block-title > *,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-subcat-dropdown:hover .td-subcat-more {
                background-color: #d62532;
            }
            .td-theme-wrap .td-footer-wrapper .td_uid_29_5e3f731a211b9_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .block-title {
                border-color: #d62532;
            }

            
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td_quote_on_blocks,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-instagram-user a {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-next-prev-wrap a:hover,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-load-more-wrap a:hover {
                background-color: #d62532;
                border-color: #d62532;
            }

            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-read-more a,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-weather-information:before,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-weather-week:before,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .td_uid_29_5e3f731a211b9_rand .td-post-category,
            .td-theme-wrap .td_uid_29_5e3f731a211b9_rand .td-post-category:hover {
                background-color: #d62532;
            }
</style><script>var block_td_uid_29_5e3f731a211b9 = new tdBlock();
block_td_uid_29_5e3f731a211b9.id = "td_uid_29_5e3f731a211b9";
block_td_uid_29_5e3f731a211b9.atts = '{"custom_title":"LATEST NEWS","custom_url":"","block_template_id":"","header_color":"#d62532","header_text_color":"#","accent_text_color":"#","m8_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"-109","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_29_5e3f731a211b9_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_settings":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_settings":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_settings":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_29_5e3f731a211b9_rand","tdc_css_class_style":"td_uid_29_5e3f731a211b9_rand_style"}';
block_td_uid_29_5e3f731a211b9.td_column_number = "1";
block_td_uid_29_5e3f731a211b9.block_type = "td_block_9";
block_td_uid_29_5e3f731a211b9.post_count = "5";
block_td_uid_29_5e3f731a211b9.found_posts = "20138";
block_td_uid_29_5e3f731a211b9.header_color = "#d62532";
block_td_uid_29_5e3f731a211b9.ajax_pagination_infinite_stop = "";
block_td_uid_29_5e3f731a211b9.max_num_pages = "4028";
tdBlocksArray.push(block_td_uid_29_5e3f731a211b9);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">LATEST NEWS</span></h4></div><div id=td_uid_29_5e3f731a211b9 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/09/korat-mass-shooter-shot-dead-police-say/" rel="bookmark" title="Korat Mass Shooter Shot Dead, Police Say">Korat Mass Shooter Shot Dead, Police Say</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/" rel="bookmark" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20">Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2020/02/07/govt-defends-selling-face-masks-to-public/" rel="bookmark" title="Gov’t Defends Selling Face Masks to Public">Gov’t Defends Selling Face Masks to Public</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/business/2020/02/07/no-tourists-no-buyers-pratunam-vendors-hit-hard-by-coronavirus-phobia/" rel="bookmark" title="No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia">No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/07/boys-playing-with-toy-guns-arrested-mistaken-for-robbers/" rel="bookmark" title="Boys Playing With Toy Guns Arrested, Mistaken For Robbers">Boys Playing With Toy Guns Arrested, Mistaken For Robbers</a></h3>
                <div class="td-module-meta-info">
                                    </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside class="td_block_template_1 widget widget_mc4wp_form_widget"><h4 class="block-title"><span>Get Khaosod English by mail.</span></h4><script>(function() {
	if ( ! window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push(
						{
							event   : event,
							callback: callback
						}
					);
				}
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.7.4 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-1464787522" method="post" data-id="1464787522" data-name="Get Khaosod English by mail. Binge-read when you want." ><div class="mc4wp-form-fields"><p>
	<label>Newsletter: </label>
	<input type="email" name="EMAIL" placeholder="Your email address" required />
</p>	<input type="submit" value="Sign up" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1581216538" /><input type="hidden" name="_mc4wp_form_id" value="1464787522" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></aside><div class="td_block_wrap td_block_13 td_block_widget td_uid_30_5e3f731a258ce_rand td-pb-border-top td_block_template_1 td-column-1"  data-td-block-uid="td_uid_30_5e3f731a258ce" >
<style>
.td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-pulldown-filter-link:hover,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-subcat-item a:hover,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-subcat-item .td-cur-simple-item {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .block-title > *,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-subcat-dropdown:hover .td-subcat-more {
                background-color: #d62532;
            }
            .td-theme-wrap .td-footer-wrapper .td_uid_30_5e3f731a258ce_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .block-title {
                border-color: #d62532;
            }

            
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td_module_wrap:hover .entry-title a,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td_quote_on_blocks,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-opacity-cat .td-post-category:hover,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-opacity-read .td-read-more a:hover,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-opacity-author .td-post-author-name a:hover,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-instagram-user a {
                color: #d62532;
            }

            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-next-prev-wrap a:hover,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-load-more-wrap a:hover {
                background-color: #d62532;
                border-color: #d62532;
            }

            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-read-more a,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-weather-information:before,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-weather-week:before,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-exchange-header:before,
            .td-theme-wrap .td-footer-wrapper .td_uid_30_5e3f731a258ce_rand .td-post-category,
            .td-theme-wrap .td_uid_30_5e3f731a258ce_rand .td-post-category:hover {
                background-color: #d62532;
            }
</style><script>var block_td_uid_30_5e3f731a258ce = new tdBlock();
block_td_uid_30_5e3f731a258ce.id = "td_uid_30_5e3f731a258ce";
block_td_uid_30_5e3f731a258ce.atts = '{"custom_title":"COMING UP IN BANGKOK!","custom_url":"","block_template_id":"","header_color":"#d62532","header_text_color":"#","accent_text_color":"#","header_image":"","mx3_tl":"","m14_tl":"","m14_el":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"123","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_30_5e3f731a258ce_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx3f_title_font_header":"","mx3f_title_font_title":"Article title","mx3f_title_font_settings":"","mx3f_title_font_family":"","mx3f_title_font_size":"","mx3f_title_font_line_height":"","mx3f_title_font_style":"","mx3f_title_font_weight":"","mx3f_title_font_transform":"","mx3f_title_font_spacing":"","mx3f_title_":"","mx3f_cat_font_title":"Article category tag","mx3f_cat_font_settings":"","mx3f_cat_font_family":"","mx3f_cat_font_size":"","mx3f_cat_font_line_height":"","mx3f_cat_font_style":"","mx3f_cat_font_weight":"","mx3f_cat_font_transform":"","mx3f_cat_font_spacing":"","mx3f_cat_":"","mx3f_meta_font_title":"Article meta info","mx3f_meta_font_settings":"","mx3f_meta_font_family":"","mx3f_meta_font_size":"","mx3f_meta_font_line_height":"","mx3f_meta_font_style":"","mx3f_meta_font_weight":"","mx3f_meta_font_transform":"","mx3f_meta_font_spacing":"","mx3f_meta_":"","m14f_title_font_header":"","m14f_title_font_title":"Article title","m14f_title_font_settings":"","m14f_title_font_family":"","m14f_title_font_size":"","m14f_title_font_line_height":"","m14f_title_font_style":"","m14f_title_font_weight":"","m14f_title_font_transform":"","m14f_title_font_spacing":"","m14f_title_":"","m14f_cat_font_title":"Article category tag","m14f_cat_font_settings":"","m14f_cat_font_family":"","m14f_cat_font_size":"","m14f_cat_font_line_height":"","m14f_cat_font_style":"","m14f_cat_font_weight":"","m14f_cat_font_transform":"","m14f_cat_font_spacing":"","m14f_cat_":"","m14f_meta_font_title":"Article meta info","m14f_meta_font_settings":"","m14f_meta_font_family":"","m14f_meta_font_size":"","m14f_meta_font_line_height":"","m14f_meta_font_style":"","m14f_meta_font_weight":"","m14f_meta_font_transform":"","m14f_meta_font_spacing":"","m14f_meta_":"","m14f_ex_font_title":"Article excerpt","m14f_ex_font_settings":"","m14f_ex_font_family":"","m14f_ex_font_size":"","m14f_ex_font_line_height":"","m14f_ex_font_style":"","m14f_ex_font_weight":"","m14f_ex_font_transform":"","m14f_ex_font_spacing":"","m14f_ex_":"","m14f_btn_font_title":"Article read more button","m14f_btn_font_settings":"","m14f_btn_font_family":"","m14f_btn_font_size":"","m14f_btn_font_line_height":"","m14f_btn_font_style":"","m14f_btn_font_weight":"","m14f_btn_font_transform":"","m14f_btn_font_spacing":"","m14f_btn_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_30_5e3f731a258ce_rand","tdc_css_class_style":"td_uid_30_5e3f731a258ce_rand_style"}';
block_td_uid_30_5e3f731a258ce.td_column_number = "1";
block_td_uid_30_5e3f731a258ce.block_type = "td_block_13";
block_td_uid_30_5e3f731a258ce.post_count = "5";
block_td_uid_30_5e3f731a258ce.found_posts = "1036";
block_td_uid_30_5e3f731a258ce.header_color = "#d62532";
block_td_uid_30_5e3f731a258ce.ajax_pagination_infinite_stop = "";
block_td_uid_30_5e3f731a258ce.max_num_pages = "208";
tdBlocksArray.push(block_td_uid_30_5e3f731a258ce);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">COMING UP IN BANGKOK!</span></h4></div><div id=td_uid_30_5e3f731a258ce class="td_block_inner">
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/events/2020/02/06/very-fest-lineup-for-march-is-out-joji-niki-bruno-major/" rel="bookmark" class="td-image-wrap" title="‘Very Fest’ Lineup for March is Out: Joji, Niki, Bruno Major"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="" title="‘Very Fest’ Lineup for March is Out: Joji, Niki, Bruno Major" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/maxresdefault-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/events/2020/02/06/very-fest-lineup-for-march-is-out-joji-niki-bruno-major/" rel="bookmark" title="‘Very Fest’ Lineup for March is Out: Joji, Niki, Bruno Major">‘Very Fest’ Lineup for March is Out: Joji, Niki, Bruno Major</a></h3>                            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/2020/02/05/free-mental-health-workshops-for-thai-teens-in-february/" rel="bookmark" class="td-image-wrap" title="Free Mental Health Workshops for Thai Teens in February"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="" title="Free Mental Health Workshops for Thai Teens in February" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/1000-3-3-324x235.jpeg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/2020/02/05/free-mental-health-workshops-for-thai-teens-in-february/" rel="bookmark" title="Free Mental Health Workshops for Thai Teens in February">Free Mental Health Workshops for Thai Teens in February</a></h3>                            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/2020/02/04/meet-half-mochi-half-rabbit-usagyuuun-and-mascot-friends-this-weekend/" rel="bookmark" class="td-image-wrap" title="Meet Half-Mochi, Half-Rabbit ‘Usagyuuun’ and Mascot Friends This Weekend"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="" title="Meet Half-Mochi, Half-Rabbit ‘Usagyuuun’ and Mascot Friends This Weekend" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/81348803_1153663191490203_517655404411355136_o-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/2020/02/04/meet-half-mochi-half-rabbit-usagyuuun-and-mascot-friends-this-weekend/" rel="bookmark" title="Meet Half-Mochi, Half-Rabbit ‘Usagyuuun’ and Mascot Friends This Weekend">Meet Half-Mochi, Half-Rabbit ‘Usagyuuun’ and Mascot Friends This Weekend</a></h3>                            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/events/2020/02/04/go-on-a-gallery-hopping-date-this-valentines-day/" rel="bookmark" class="td-image-wrap" title="Go on a Gallery-Hopping Date This Valentine’s Day"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="“Uthaipia” photography exhibition. Photo: Chatchai Boonyaprapatsara / Kathmandu Photo Gallery" title="Go on a Gallery-Hopping Date This Valentine’s Day" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/GALLERIES_Header-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/events/2020/02/04/go-on-a-gallery-hopping-date-this-valentines-day/" rel="bookmark" title="Go on a Gallery-Hopping Date This Valentine’s Day">Go on a Gallery-Hopping Date This Valentine’s Day</a></h3>                            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/life/events/2020/02/03/take-a-break-from-pm2-5-at-bangkok-design-week-2020-photos/" rel="bookmark" class="td-image-wrap" title="Take a Break from PM2.5 at Bangkok Design Week 2020 (Photos)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC"alt="&quot;Everlasting Forest by GC&quot; exhibition in front of the Grand Postal Building." title="Take a Break from PM2.5 at Bangkok Design Week 2020 (Photos)" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/DSCF0894-copy-324x235.jpg"  width="324" height="235" /></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/life/events/2020/02/03/take-a-break-from-pm2-5-at-bangkok-design-week-2020-photos/" rel="bookmark" title="Take a Break from PM2.5 at Bangkok Design Week 2020 (Photos)">Take a Break from PM2.5 at Bangkok Design Week 2020 (Photos)</a></h3>                            </div>

        </div>

        </div></div> <!-- ./block --><aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>FRESH CUTS</span></h4><div class="textwidget custom-html-widget"><div style="position:relative;height:0;padding-bottom:56.25%"><iframe src="https://www.youtube.com/embed/uCvNY6JTz_I?&autoplay=1&mute=1&controls=1&amp;showinfo=0?&loop=1
&playlist=mWz8rgyxxkI, dN7aU1gLhMk,jOxjFnnsCkw,YI3PMQt4uo0, JR5csM9QX4Y,4epIJ6Yfwvw, Xt3BlN-IcOw, bI2fSNw-s_I, pz1Dn71Talw, JVbkIE3xCq8, z8xhyb2gang, U8LJlh1KHI4, YYAfF6loezI, pNXEjp9dCbI, Vs9PC_mG5hM, yYZgEbU2ZR0, uYsU3pLgwoQ, lcBKli1dMVw, sUR12BRBksQ, nJ2IlW0GSng, sG4PXiWgTb0, YYAfF6loezI,Hjx6EVSZDdc,KKMT0uqCmWE,SE6XQF3pX8U,ohSsnCt49as,JbLnm0cfxF4,u7_OVX9rZSk,DMsUbJ76Cmw,1_Hhlq-12zs,oE1GLBtqh98,XL2oqFp3Xd4,crNtqFBCvoo,vK12IiKBmY0, 37_QRvMSJeE,Oh4AiPLmkhU, btbkG9lJL5c,PvL1O7DtbbE,iS4CaYRIqsU,MUS6hM_pct0,O-qsge84IIE,nKgtOz5WSnY,fDohK80t-lY,EjL23aAoZEw,sEcwhM72kiA, HrDhsIEdvN0, mrDa14TZIcQ, Of_NSIPUx6o, cfxcaxNkvd8, 9FMVIkCsKuc, mipg3Hz2oB4, yNhGN_ngL-g, 6JoOzLpVScE, c0V_6Nu-RCY, ZmYWvBtTGnQ
" width="300" height="169" frameborder="0" style="position:absolute;width:100%;height:100%;left:0" allowfullscreen></iframe></div>
</div></aside><div class="td_block_wrap td_block_weather td_block_widget td_uid_31_5e3f731a30360_rand td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_31_5e3f731a30360" ><div class="td-block-title-wrap"></div><div id=td_uid_31_5e3f731a30360 class="td-weather-wrap td_block_inner td-column-1"><!-- td weather source: cache -->
		<div class="td-weather-header">
			<div class="td-weather-city">Bangkok</div>
			<div class="td-weather-condition">mist</div>
			<i class="td-location-icon td-icons-location" data-block-uid="td_uid_31_5e3f731a30360"></i>
		</div>

		<div class="td-weather-set-location">
			<form class="td-manual-location-form" action="#" data-block-uid="td_uid_31_5e3f731a30360">
				<input id="td_uid_31_5e3f731a30360" class="td-location-set-input" type="text"
					   name="location" value="">
				<label>enter location</label>
			</form>
		</div>

		<div class="td-weather-temperature">
			<div class="td-weather-temp-wrap">
				<div class="td-weather-animated-icon">
					<span
						class="td_animation_sprite-27-100-80-0-0-1 mist-d td-w-today-icon"
						data-td-block-uid="td_uid_31_5e3f731a30360"></span>
				</div>
				<div class="td-weather-now" data-block-uid="td_uid_31_5e3f731a30360">
					<span class="td-big-degrees">25.6</span>
					<span class="td-circle">&deg;</span>
					<span class="td-weather-unit">C</span>
				</div>
				<div class="td-weather-lo-hi">
					<div class="td-weather-degrees-wrap">
						<i class="td-up-icon td-icons-arrows-up"></i>
						<span
							class="td-small-degrees td-w-high-temp">27.8</span>
						<span class="td-circle">&deg;</span>
					</div>
					<div class="td-weather-degrees-wrap">
						<i class="td-down-icon td-icons-arrows-down"></i>
						<span
							class="td-small-degrees td-w-low-temp">24</span>
						<span class="td-circle">&deg;</span>
					</div>
				</div>
			</div>
		</div>

		<div class="td-weather-info-wrap">
			<div class="td-weather-information">
				<div class="td-weather-section-1">
					<i class="td-icons-drop"></i>
					<span class="td-weather-parameter td-w-today-humidity">94						%</span>
				</div>
				<div class="td-weather-section-2">
					<i class="td-icons-wind"></i>
					<span
						class="td-weather-parameter td-w-today-wind-speed">1kmh</span>
				</div>
				<div class="td-weather-section-3">
					<i class="td-icons-cloud"></i>
					<span class="td-weather-parameter td-w-today-clouds">20						%</span>
				</div>
			</div>


			<div class="td-weather-week">
									<div class="td-weather-days">
						<div class="td-day-0">Sun</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-0">32</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-1">Mon</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-1">31</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-2">Tue</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-2">31</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-3">Wed</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-3">29</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-4">Thu</div>

						<div class="td-day-degrees">
							<span
								class="td-degrees-4">29</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
								</div>
		</div>

		</div></div> <!-- ./block --><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Revive Adserver Javascript Tag - Generated with Revive Adserver v5.0.4 -->
<script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://ads5.matichon.co.th/www/delivery/ajs.php':'http://ads5.matichon.co.th/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=20");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]>--></script><noscript><a href='http://ads5.matichon.co.th/www/delivery/ck.php?n=a858070a&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank' rel="noopener noreferrer"><img src='http://ads5.matichon.co.th/www/delivery/avw.php?zoneid=20&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a858070a' border='0' alt='' /></a></noscript></div></aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->


    <div class="td-main-content-wrap td-footer-instagram-container td-container-wrap ">
        
        <div class="td-instagram-user">
            <h4 class="td-footer-instagram-title">
                Follow us on Instagram                <a class="td-footer-instagram-user-link" href="https://www.instagram.com/khaosodenglish" target="_blank">@khaosodenglish</a>
            </h4>
        </div>

        <div class="td_block_wrap td_block_instagram td_uid_32_5e3f731a30e95_rand td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_32_5e3f731a30e95" ><div class="td-block-title-wrap"></div><div id=td_uid_32_5e3f731a30e95 class="td-instagram-wrap td_block_inner td-column-1"><!-- td instagram source: instagram_cache -->        <!-- header section -->
        
        <!-- user shared images -->
                    <div class="td-instagram-main td-images-on-row-5 td-image-gap-2">
                                        <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B8QomNGH2Kw" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-2.fna.fbcdn.net/v/t51.2885-15/sh0.08/e35/c185.0.1069.1069a/s640x640/83728723_1561283740685469_5491224714438647170_n.jpg?_nc_ht=instagram.fbkk8-2.fna.fbcdn.net&_nc_cat=109&_nc_ohc=cQ5FPSXx1esAX_4metN&oh=d5ba77f63cd9c00aa91886f54354a2a5&oe=5EB9FAB6"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B8NzmyoHxzm" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-2.fna.fbcdn.net/v/t51.2885-15/sh0.08/e35/c180.0.1079.1079a/s640x640/85040729_192002195205135_5836399470610176818_n.jpg?_nc_ht=instagram.fbkk8-2.fna.fbcdn.net&_nc_cat=103&_nc_ohc=u1OKdyAiCCQAX-TmuPH&oh=2f56f8b96f9a76420786097f4052c340&oe=5ED4E9C0"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B8Nzjptn0CY" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-2.fna.fbcdn.net/v/t51.2885-15/e35/c48.0.640.640a/83915251_100763581488038_684438148126340918_n.jpg?_nc_ht=instagram.fbkk8-2.fna.fbcdn.net&_nc_cat=102&_nc_ohc=o-grS7BeoRUAX_41hB_&oh=cdee7fc1a13e372025a3a0dce37ebaad&oe=5ED78BCF"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B8NzUnzHHlp" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-2.fna.fbcdn.net/v/t51.2885-15/sh0.08/e35/s640x640/82923024_579851432871470_3236669999215623001_n.jpg?_nc_ht=instagram.fbkk8-2.fna.fbcdn.net&_nc_cat=102&_nc_ohc=-iHNGH2ZYRwAX-fP0jF&oh=d134acb96547ff688da310a4efcfe962&oe=5EB88AE3"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B8GN8F4Hhs4" target="_blank">
                                <img class="td-instagram-image" src="https://instagram.fbkk8-2.fna.fbcdn.net/v/t51.2885-15/e35/c191.0.617.617a/82565248_3482043228535020_5526943486185725273_n.jpg?_nc_ht=instagram.fbkk8-2.fna.fbcdn.net&_nc_cat=100&_nc_ohc=qMGxMW5kIjkAX_6l0p6&oh=fdeedb5625a43523c9fbd5f957673867&oe=5EC32684"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                    <div class="clearfix"></div>
            </div>
            </div></div> <!-- ./block -->    </div>




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-14 ">
    <div class="td-container td-footer-bottom-full">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.khaosodenglish.com/"><img class="td-retina-data" src="https://www.khaosodenglish.com/wp-content/uploads/2016/11/footerlogo3.png" data-retina="https://www.khaosodenglish.com/wp-content/uploads/2016/11/footeretina-1.png" alt="" title="" width="" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Copyright 2018 Khaosod English 40/10 S. Thetsaban Nimit Tai Road Prachaniwet, Chatuchak Bangkok, Thailand, 10900 <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0665696872676572466d6e67697569626368616a6f756e2865696b">[email&#160;protected]</a></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/KhaosodEnglish" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span></aside></div>        </div>
    </div>
</div>
	<!-- Sub Footer -->
	

</div><!--close td-outer-wrap-->

<!-- Instagram Feed JS -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
var sbiajaxurl = "https://www.khaosodenglish.com/wp-admin/admin-ajax.php";
</script>
                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/" rel="bookmark" class="td-image-wrap" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/82177816_2754729561269779_3483236726372040704_o-1-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/crimecourtscalamity/2020/02/08/rogue-soldier-kills-12-in-rampage-police-say/" rel="bookmark" title="Police, Army Besiege Shopping Mall to Search for Soldier Who Kills 20">Police, Army Besiege Shopping Mall to Search for Soldier Who Kills...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-08T18:50:49+00:00" >February 8, 2020 6:50 pm</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/politics/2020/02/07/govt-defends-selling-face-masks-to-public/" rel="bookmark" class="td-image-wrap" title="Gov’t Defends Selling Face Masks to Public"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="Citizens queue up to purchase face masks at a stall inside the Government House on Feb. 7, 2020." title="Gov’t Defends Selling Face Masks to Public" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/MASK2_Header-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/politics/2020/02/07/govt-defends-selling-face-masks-to-public/" rel="bookmark" title="Gov’t Defends Selling Face Masks to Public">Gov’t Defends Selling Face Masks to Public</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-07T18:29:15+00:00" >February 7, 2020 6:29 pm</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://www.khaosodenglish.com/news/business/2020/02/07/no-tourists-no-buyers-pratunam-vendors-hit-hard-by-coronavirus-phobia/" rel="bookmark" class="td-image-wrap" title="No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia" data-type="image_tag" data-img-url="https://www.khaosodenglish.com/wp-content/uploads/2020/02/840218-2-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.khaosodenglish.com/news/business/2020/02/07/no-tourists-no-buyers-pratunam-vendors-hit-hard-by-coronavirus-phobia/" rel="bookmark" title="No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia">No Tourists, No Buyers: Pratunam Vendors Hit Hard by Coronavirus Phobia</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-07T15:00:00+00:00" >February 7, 2020 3:00 pm</time></span>                            </div>
        </div>

        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 9.5 (rara)
        Deploy mode: deploy
        
        uid: 5e3f731a6c2e8
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
@import url("http://fast.fonts.net/t/1.css?apiType=css&projectid=eb81b52c-09ff-4200-bbfe-693c2db29e76");
    @font-face{
        font-family:"DIN Next LT W01 Black";
        src:url("Fonts/ef79833e-ca28-419f-898a-a96725a0e7b5.eot?#iefix");
        src:url("Fonts/ef79833e-ca28-419f-898a-a96725a0e7b5.eot?#iefix") format("eot"),url("Fonts/7324033f-ef94-4c54-8e88-377b447f0fa2.woff2") format("woff2"),url("Fonts/3efb3b3f-ac55-4ec0-8099-940870596c57.woff") format("woff"),url("Fonts/a6869823-bba8-457d-9f31-3b1cfe4c9bb9.ttf") format("truetype");
    }
</style>

<script>(function() {function addEventListener(element,event,handler) {
	if (element.addEventListener) {
		element.addEventListener( event,handler, false );
	} else if (element.attachEvent) {
		element.attachEvent( 'on' + event,handler );
	}
}
function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf( 'http' ) !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll( '.mc4wp-form input[type="url"]' );
if ( urlFields && urlFields.length > 0 ) {
	for ( var j = 0; j < urlFields.length; j++ ) {
		addEventListener( urlFields[j],'blur',maybePrefixUrlField );
	}
}
/* test if browser supports date fields */
var testInput = document.createElement( 'input' );
testInput.setAttribute( 'type', 'date' );
if ( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll( '.mc4wp-form input[type="date"]' );
	for (var i = 0; i < dateFields.length; i++) {
		if ( ! dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if ( ! dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}
})();</script><script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=726837bbdee984ffb331a234aadde124'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.5'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=726837bbdee984ffb331a234aadde124'></script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.7.4'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.khaosodenglish.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.7.4'></script>
<![endif]-->
<script type="text/javascript" src="//s3.amazonaws.com/downloads.mailchimp.com/js/signup-forms/popup/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script>
<script type="text/javascript">require(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us12.list-manage.com","uuid":"a848e9861d42590de9aef1b00","lid":"7643ab464a"}) })</script>
<!--BEGIN WEB STAT CODE-->
<script type="text/javascript" src="https://lvs.truehits.in.th/data/t0031311.js"></script>
<noscript> 
<a target="_blank" href="http://truehits.net/stat.php?id=t0031311"><img src="http://hits.truehits.in.th/noscript.php?id=t0031311" alt="Thailand Web Stat" border="0" width="14" height="17" /></a> 
<a target="_blank" href="http://truehits.net/">Truehits.net</a> 
</noscript>
<!-- END WEBSTAT CODE -->
<!-- JS generated by theme -->

<script>
    

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Bangkok","api_location":"Bangkok","api_language":"en","api_key":"6ecc38c787e2d975b72b6c67fa443691","today_icon":"mist-d","today_icon_text":"mist","today_temp":[25.6,78],"today_humidity":94,"today_wind_speed":[1,0.6],"today_min":[24,75.2],"today_max":[27.8,82],"today_clouds":20,"current_unit":0,"forecast":[{"timestamp":1581217200,"day_name":"Sun","day_temp":[32,89],"owm_day_index":0},{"timestamp":1581292800,"day_name":"Mon","day_temp":[31,87],"owm_day_index":7},{"timestamp":1581379200,"day_name":"Tue","day_temp":[31,88],"owm_day_index":15},{"timestamp":1581465600,"day_name":"Wed","day_temp":[29,84],"owm_day_index":23},{"timestamp":1581552000,"day_name":"Thu","day_temp":[29,84],"owm_day_index":31}]});
				});
			
			

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_uid_31_5e3f731a30360","location":"Bangkok","api_location":"Bangkok","api_language":"en","api_key":"6ecc38c787e2d975b72b6c67fa443691","today_icon":"mist-d","today_icon_text":"mist","today_temp":[25.6,78],"today_humidity":94,"today_wind_speed":[1,0.6],"today_min":[24,75.2],"today_max":[27.8,82],"today_clouds":20,"current_unit":0,"forecast":[{"timestamp":1581217200,"day_name":"Sun","day_temp":[32,89],"owm_day_index":0},{"timestamp":1581292800,"day_name":"Mon","day_temp":[31,87],"owm_day_index":7},{"timestamp":1581379200,"day_name":"Tue","day_temp":[31,88],"owm_day_index":15},{"timestamp":1581465600,"day_name":"Wed","day_temp":[29,84],"owm_day_index":23},{"timestamp":1581552000,"day_name":"Thu","day_temp":[29,84],"owm_day_index":31}]});
				});
			
			

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[1464857669]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.khaosodenglish.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.khaosodenglish.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5e3f731a6ca3a"></textarea>
						<div id="td_live_css_uid_1_5e3f731a6ca3a" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5e3f731a6ca3a');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5e3f731a6ca3a");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>